Fedora 32: Experiencing Freezing After the latest Update (Kernel to: 5.7.7)

So, I recently updated my system (Two days ago) after that, I am unable to open any application I installed using third party sources. For Eg.: VSCode, Brave Browser, Firefox Developer Edition. I am just able to use application that came preinstalled Like: Firefox (I am currently visiting this website using the same).Although, Firefox has been crashing too but, not like the other applications. For Eg: I tried starting up Brave Browser and suddenly, my screen froze. I was able to move my mouse but, it was of no avail. Then, I used: Ctrl + Alt + F3 to get into those shells and shutdown(ed) my system from there (Used: shutdown command.).
Again, after restarting my PC, I tried to open Brave and VSCode and still, the problem persisted.
So, I was just trying to fix things up and then, during the next startup, I select the version before 5.7.7 (from GRUB) and everything worked fine.

I did a clean install (Like: Wiped out my Linux Portion of the drive and installed Fedora 32 again) and still the problem persists.

Any help will be appreciated.

Regards
SNikhill

Just wanted to post an Update: So, I selected 5.6.6 version from the GRUB menu and everything seems to work fine. (I just re-installed VSCode and Brave and they are working as intended). The reason, I am fixating on Kernel version is cause, I just read another post where the user is facing issues due to Kernel 5.7.7 and I think, my problem and his are closely related.

Regards
SNikhill

Yeah, I haven’t found any version of kernel 5.7.x that works for me on any distro.

Do you have a amd gpu by any chance?

Greetings @dalto

Nope. I don’t have an AMD GPU.

I’m glad to see others having similar issues to me. I did a fedora system update yesterday just using dnf, and now I’m having a number of issues. The smallest issue, is a purple screen that flashes on my monitor when I shut down. The more pressing issue is that the audio output through my Dell WD19 USB C dock is absolutely intelligible. It sounds as though it’s taking the audio samples, filtering out the low frequencies, turning it into 8-bit sound, and then shifting the frequencies down really low (like dungeon music or something).

I am running on a Thinkpad T495 with Ryzen 7 processor (Vega 10 integrated graphics). I had major issues when upgrading from Fedora 31 to Fedora 32, where all of my packages for Latex, python, etc. and basic applications like cheese and libreoffice were completely removed from the system, and the audio drivers for the WD19 dock were messed up, like they are now. The devices are being picked up through the alsa mixer, but the sound is totally wrong. At first I thought this was because of Zoom, but I just did a fresh install, and the dock works before doing dnf update, but after updating, the dock sound does not work and I get that purple screen flashing on shutdown.

I have no idea what it is, and no idea where to start. Really seems like an issue with the kernel upgrade and other package upgrades from the Fedora 32 release until now, but I’m not really sure how to proceed.

Hi @drummerhead7. Welcome to the Fedora Community

@snikhill
Sorry about all the trouble. Usually Fedora keeps three kernels for situations like this. You have succeeded in establishing one thing – which is that Kernel-5.7.7 doesn’t work for you. So file a bug report against it at https://bugzilla.redhat.com. You will provide information to assist developers in resolving the issue. Alternatively, you can wait for another update. Just keep booting the last good Kernel until another working update arrives. That is the design

Interesting I’ve been having similar issues since 5.7.10 and it IS related to AMDGPU. Granted I run risky environments with ROCm and out-of-band OpenCL drivers but suddenly I got no video and even had grub issues since 5.7.10. Turns out there was some kind of regression that broke my AMDGPU dkms in the post script of kernel-core. That includes the latest builds for EL8 and EL7. Trying to reinstall it repeatedly eliminating a few of my AMD packages at a time but I’m pretty close to ripping it out once and for all (and throwing this AMD sidearm into the river because I’m so sick of AMDGPU issues). Sometime along the update the code broke for these ROCm modules which supposedly were finally ready for F32. I’ll disable it and file an issue with AMD.

Building module:
cleaning build area…
make -j40 KERNELRELEASE=5.7.10-201.fc32.x86_64 -j40 TTM_NAME=amdttm SCHED_NAME=amd-sched kdir=/lib/modules/5.7.10-201.fc32.x86_64/build -C /lib/modules/5.7.10-201.fc32.x86_64/build M=/var/lib/dkms/amdgpu/3.5-30.el7/build…(bad exit status: 2)
Error! Bad return status for module build on kernel: 5.7.10-201.fc32.x86_64 (x86_64)
Consult /var/lib/dkms/amdgpu/3.5-30.el7/build/make.log for more information.
Done.

I also have this issue with 5.7.7. Can’t open Brave or play a video. All works fine on 5.6.6.
I have integrated Intel GPU.

Since last update there is no longer possible to select the 5.6.x kernel. It was removed. I can only select from 5.7.10, 5.7.11, 5.7.12. Unfortunately the issue exist on all of them.

The last release of Kernel 5.6.x for Fedora32 was 5.6.8-300.fc32
You can get the koji builds (you can also get any version likewise):

  1. Download the packages for the relevant System Architecture into a folder
  2. Remove one of the installed kernel versions using dnf (don’t forget to remove all dependencies for that particular version)
  3. Change directory to the folder holding your downloaded kernel (on the terminal). cd /path/to/download/folder
  4. sudo dnf install ./kernel*
2 Likes

For 5.6.8-300.fc32 I got following info:
Error:
Problem: conflicting requests
- nothing provides kernel-core-uname-r = 5.6.8-300.fc32.x86_64 needed by kernel-5.6.8-300.fc32.x86_64
- nothing provides kernel-modules-uname-r = 5.6.8-300.fc32.x86_64 needed by kernel-5.6.8-300.fc32.x86_64
(try to add ‘–skip-broken’ to skip uninstallable packages)

I’ve downloaded:

  • kernel-5.6.8-300.fc32.x86_64.rpm
  • kernel-core-5.6.8-300.fc32.x86_64.rpm
  • kernel-modules-5.6.8-300.fc32.x86_64.rpm
  • kernel-modules-extra-5.6.8-300.fc32.x86_64.rpm

I’ve installed 5.6.6-300.fc32.x86_64 without the issue.

I have two questions:

  1. Is it safe to use 5.6.6 ?
  2. How to pin 5.6.6 as default entry and prevent Fedora removing it?

Greetings @panocek1,

I am typing this message from Fedora 32 with kernel version: 5.6.6.

Well ever since I reported the issue, I haven’t updated my kernel. I exclude the same from the updates.

Also, I have observed that if you install kernel using the official channel then, your current kernel will never be replaced. (For e.g.: If I am on kernel 5.6.6 and run a update using dnf then, kernel 5.6.6 will not be replaced). BUT KEEP IN MIND: THIS TRUE ONLY IF YOU UPDATE USING THE OFFICIAL WAY. (Yes, the current kernel can be overridden if you use any third-party method without proper caution.)

Regards
SNikhill

1 Like

Install those dependencies first:
sudo dnf install ./kernel-core-5.6.8-300.fc32.x86_64.rpm
sudo dnf install ./kernel-modules-5.6.8-300.fc32.x86_64.rpm
(assuming you are already in the folder holding the packages)
then install the rest likewise.

Yes

Just like @snikhill said, if you booted with it … dnf will not remove it.

I cannot get any of the three 5.7 kernels to boot either.

https://koji.fedoraproject.org/koji/packageinfo?packageID=8
Choose anyone you like from there. Don’t forget to download the (relevant) accompanying packages and from the correct architecture section.

1 Like

I found a fix for this (at least for me). I uninstalled the Nvidia drivers, then used RPM Fusion to reinstall them. Now all 5.7 kernels work for me.

2 Likes