Fedora 32 fails DNF update

Hello there

I want to install VirtualBox on my Fedora 32 distro, but something seems really wrong with the repo? This is what happens when I try to use:
sudo yum install virtualbox

Errors during downloading metadata for repository ‘epel’:

Any idea how to fix this?

These errors appear to be for the “epel” repo which is not F32, and for the “virtualbox” repo.
Why would you have an epel repo enabled when running fedora (beta or rawhide) since they are different distros and problems have been seen when distros are mixed.
The second stanza tries to download from virtualbox.org and calls the repo “virtualbox”. I don’t know if that is a valid repo.

Also, You use yum, (which I think is still valid) but Fedora has used dnf for at least the last 4 releases.

F32 (due to be released next week) is still only in beta. As beta the updates are frozen until the release date so that might also be part of your issue.
I have not yet tried the upgrade from F31 because I cannot afford to spend the time fighting issues and bugs that come during the final days before a new version is released.

I recommend you check which repos are enabled in /etc/yum.repos.d and make sure you have only the ones needed so the system can avoid conflicts.

With the proper repo, and after final release of F32, the problem should go away.

1 Like

Thank you for all this info.
I think I have the wrong repos, any idea how I can fix this?

Those are currently in my repo folder:
cd /etc/yum.repos.d
ls
epel-playground.repo fedora-updates-modular.repo
epel.repo fedora-updates.repo
epel-testing.repo fedora-updates-testing-modular.repo
fedora-cisco-openh264.repo fedora-updates-testing.repo
fedora-modular.repo virtualbox.repo
fedora.repo

Those are the repo file names.
The command “dnf repolist” will return a full list of all repo IDs and repo names that are enabled.
Once you have the repo id you can use the command “dnf config-manager --disable repo id” and do that for each repo you wish to disable.
You can use similar command with the --enable option to enable a repo as well.

Of those you listed I only use fedora, updates, and fedora-cisco-openh264
All these work with the currently installed version of fedora so if you have F32 beta installed they should point to the proper repo for updates. (remember that until the final release date the update repos for F32 are frozen --no new updates – but that is currently scheduled for Tuesday)

I personally never use the bleeding edge testing repos because sometimes they can break things on your system. Packages there are exactly that – testing changes. – and may or may not function as desired. If you like doing that then leave them enabled; but be aware that if a problem crops up and you don’t report it it may not become known or fixed.
You really don’t need the virtualbox repo because fedora includes virtualbox in its main repo and there it is already configured for the OS.
I also personally don’t use the modular repos and disable them on my system.

No version for 32 in Virtualbox downloads.

1 Like

Oracle usually does not release VirtualBox for many weeks or sometimes months after a Fedora release.
Usually the version for the previous Fedora (f-1) will work on a current Fedora (f).
What you can try is to edit /etc/yum.repos.d/virtualbox.repo and hard-code the $releasever to 31.

Alternatively, rpmfusion will probably provide VirtualBox for F32 very soon.

By the way, there is great, free alternatives available in Fedora: Gnome Boxes and Virtual Machine Manager (virt-mamager) are great!

Anything epel should be removed from your system - it’s made for Enterprise Linux and software in those repos are already in Fedora: sudo rm /etc/yum.repos.d/epel\*

2 Likes