Fedora 32 KDE spin - ufw at startup enabled but not working. Completely new to Fedora.

The subject covers the topic.

/etc/ufw/ufw.conf has ENABLED=yes however I am forced to start ufw manually every time I start my computer. What is the recommended method to correct this problem in Fedora 32?

From the man page:

On installation, ufw is ‘enabled’ (but only actually enabled on bootup if
ufw.service is enabled in systemd) with a default incoming policy of deny,
a default forward policy of deny, and a default outgoing policy of allow, with
stateful tracking for NEW connections for incoming and forwarded connections.

Have you enabled the service?
systemctl enable ufw.service

How exactly do you do that?

1 Like

I just ran $ systemctl enable ufw.service Created symlink /etc/systemd/system/basic.target.wants/ufw.service → /usr/lib/systemd/system/ufw.service.. I will try a restart.

To start ufw manually, I run sudo ufw enable

OK, ufw started automatically when I rebooted, thanks. BTW, is there a reason that gufw doesn’t appear to be available in Fedora? It seems weird to me that when a front end is available, it isn’t included, particularly when dealing with something as potentially complicated as a firewall, despite ufw probably being the most straight forward firewall available.

If you want to start the systemd service (regardless if it’s enabled or not) you do this:
systemctl start ufw.service

1 Like

Because nobody has gone through the trouble of packaging it yet.

Sorry but fedora default firewall isn’t firewalld? Anyway you can install ufw-kde that is the same GUI frontend used in kubuntu. If you can’t find it in the app manager you can install it with:
sudo dnf install ufw-kde

1 Like

Yes, it is firewalld indeed.