Fedora 32 - RTL8723DE Wireless not working

am looking help on Wireless drive issue with HP Laptop.

Driver Details – Network controller: Realtek Semiconductor Co., Ltd. RTL8723DE 802.11b/g/n PCIe Adapter

OS = Fedora release 32 (Thirty Two)

kernal version = Linux savita 5.6.16-300.fc32.x86_64 #1 SMP Thu Jun 4 18:08:38 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Prerequisite Packages installed.

Approach 1st

savita@savita tmp]$ git clone -b extended --single-branch https://github.com/lwfinger/rtlwifi_new.git

Cloning into ‘rtlwifi_new’…

remote: Enumerating objects: 3, done.

remote: Counting objects: 100% (3/3), done.

remote: Compressing objects: 100% (3/3), done.

remote: Total 3611 (delta 0), reused 3 (delta 0), pack-reused 3608

Receiving objects: 100% (3611/3611), 11.71 MiB | 1.11 MiB/s, done.

Resolving deltas: 100% (2895/2895), done.

[savita@savita tmp]$ cd rtlwifi_new/

[savita@savita rtlwifi_new]$ make

make: *** No targets specified and no makefile found. Stop.

Approach 2nd — This worked on Fedora 28 - but not on Fedroa 32.

[savita@savita tmp]$ git clone https://github.com/smlinux/rtl8723de.git -b 4.15-up
Cloning into ‘rtl8723de’…
remote: Enumerating objects: 35, done.
remote: Counting objects: 100% (35/35), done.
remote: Compressing objects: 100% (30/30), done.
remote: Total 636 (delta 13), reused 17 (delta 5), pack-reused 601
Receiving objects: 100% (636/636), 2.72 MiB | 427.00 KiB/s, done.
Resolving deltas: 100% (228/228), done.

[savita@savita tmp]$ sudo dkms add ./rtl8723de
[sudo] password for savita:
Error! DKMS tree already contains: rtl8723de-5.1.1.8_21285.20171026_COEX20170111-1414

[savita@savita tmp]$ sudo dkms install rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414

Kernel preparation unnecessary for this kernel. Skipping…

Building module:
cleaning build area…
‘make’ all KVER=5.6.16-300.fc32.x86_64…(bad exit status: 2)
Error! Bad return status for module build on kernel: 5.6.16-300.fc32.x86_64 (x86_64)
Consult /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/make.log for more information.

log —
/var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/osdep_service.c: In function ‘storeToFile’:
/var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/osdep_service.c:2161:11: error: incompatible type for argument 1 of ‘set_fs’
2161 | set_fs(get_ds());
| ^~~~~~~~
| |
| int
In file included from ./include/linux/uaccess.h:11,
from ./include/linux/sched/task.h:11,
from ./include/linux/sched/signal.h:9,
from /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/include/osdep_service.h:41,
from /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/include/drv_types.h:32,
from /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/osdep_service.c:24:
./arch/x86/include/asm/uaccess.h:29:40: note: expected ‘mm_segment_t’ but argument is of type ‘int’
29 | static inline void set_fs(mm_segment_t fs)
| ~~~~~~~~~~~~~^~
cc1: some warnings being treated as errors
make[2]: *** [scripts/Makefile.build:268: /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/osdep_service.o] Error 1
make[1]: *** [Makefile:1695: /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build] Error 2
make[1]: Leaving directory ‘/usr/src/kernels/5.6.16-300.fc32.x86_64’
make: *** [Makefile:1885: modules] Error 2

1 Like

Heeeeeeey!

Its always nice to meet a Fedora user for the first time. Welcome to the Fedora community. You are trying to install driver for RTL8723DE?

Realtek products tend to work fine out-of-the-box on Fedora. You didn’t need to share your git terminal outputs.

Looks like your OS warned you that a driver already exists. Why are you introducing another one? What’s your experience with the default driver? Share with us. We might be able to propose solutions.

1 Like

The developer change something in git hub repo:

see comment:

master branch empty:

The master branch of this repo is officially abandoned. If you are running a kernel newer than 5.0, use the drivers built into your kernel. That is a lot less work.

extended branch empty:

The extended branch of this repo is officially abandoned. If you are running a kernel newer than 5.0, use the drivers built into your kernel. That is a lot less work.

that why you get, this messages:

Please use, kernel_version branch:

also use, this command to see all builds:

dkms status

this is quite for 4.15 kernel quite old as you can see, that why you’ve got all that error messages, is you prefer this repo you should use, 5.0-up branch:

Reagrds.,

2 Likes

[savita@savita tmp]$ sudo dkms add ./rtl8723de
Error! DKMS tree already contains: rtl8723de-5.1.1.8_21285.20171026_COEX20170111-1414

this above output just to share the steps.

[savita@savita tmp]$ dkms status
rtl8723de, 5.1.1.8_21285.20171026_COEX20170111-1414: added

I think you can do something like this, to remove it:

sudo dkms remove -m rtl8723de -v 5.1.1.8_21285.20171026_COEX20170111-1414 --all

References

https://wiki.archlinux.org/index.php/Dynamic_Kernel_Module_Support

Regards.,

1 Like

[savita@savita tmp]$ sudo dkms remove -m rtl8723de -v 5.1.1.8_21285.20171026_COEX20170111-1414 --all
[sudo] password for savita:


Deleting module version: 5.1.1.8_21285.20171026_COEX20170111-1414
completely from the DKMS tree.

Done.

Should i try same steps again ? approach 2 or something else.

1 Like

[savita@savita tmp]$ git clone https://github.com/smlinux/rtl8723de.git -b 5.0-up

[savita@savita tmp]$ sudo dkms add ./rtl8723de
[sudo] password for savita:

Creating symlink /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/source ->
/usr/src/rtl8723de-5.1.1.8_21285.20171026_COEX20170111-1414

DKMS: add completed.

[savita@savita tmp]$ sudo dkms install rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414

Kernel preparation unnecessary for this kernel. Skipping…

Building module:
cleaning build area…
‘make’ all KVER=5.6.16-300.fc32.x86_64…(bad exit status: 2)
Error! Bad return status for module build on kernel: 5.6.16-300.fc32.x86_64 (x86_64)
Consult /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/make.log for more information.

could you please provide the output of this file…

/var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/make.log

Regards.,

the log file with 518 line… here pasting the last log.

In file included from /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/include/osdep_service_linux.h:86,
473                  from /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/include/osdep_service.h:42,
474                  from /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/include/drv_types.h:32,
475                  from /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/linux/recv_linux.c:22:
476 ./include/linux/ieee80211.h:1460: note: this is the location of the previous definition
477  1460 | #define IEEE80211_MAX_AMPDU_BUF  0x100
478       |
479   CC [M]  /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/linux/ioctl_cfg80211.o
480 In file included from /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/include/drv_types.h:35,
481                  from /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/linux/ioctl_cfg80211.c:22:
482 /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/include/wifi.h:1006: warning: "IEEE80211_MAX_AMPDU_BUF" redefined
483  1006 | #define IEEE80211_MAX_AMPDU_BUF 0x40
484       |
485 In file included from /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/include/osdep_service_linux.h:86,
486                  from /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/include/osdep_service.h:42,
487                  from /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/include/drv_types.h:32,
488                  from /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/linux/ioctl_cfg80211.c:22:
489 ./include/linux/ieee80211.h:1460: note: this is the location of the previous definition
490  1460 | #define IEEE80211_MAX_AMPDU_BUF  0x100
491       |
492 /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/linux/ioctl_cfg80211.c: In function ‘rtw_get_systime_us’:
493 /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/linux/ioctl_cfg80211.c:351:18: error: storage size of ‘ts’ isn’t known
494   351 |  struct timespec ts;
495       |                  ^~
496 /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/linux/ioctl_cfg80211.c:357:7: error: implicit declaration of function ‘ktime_to_timespec’; did you mean ‘ktime_to_timespec64’? [-Werror=implicit-function-de    claration]
497   357 |  ts = ktime_to_timespec(ktime_get_boottime());
498       |       ^~~~~~~~~~~~~~~~~
499       |       ktime_to_timespec64
500 /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/linux/ioctl_cfg80211.c:365:1: warning: control reaches end of non-void function [-Wreturn-type]
501   365 | }
502       | ^
503 /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/linux/ioctl_cfg80211.c: In function ‘cfg80211_rtw_change_iface’:
504 /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/linux/ioctl_cfg80211.c:1801:10: warning: this statement may fall through [-Wimplicit-fallthrough=]
505  1801 |   is_p2p = _TRUE;
506 /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/linux/ioctl_cfg80211.c:1803:2: note: here
507  1803 |  case NL80211_IFTYPE_STATION:
508       |  ^~~~
509 /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/linux/ioctl_cfg80211.c:1825:10: warning: this statement may fall through [-Wimplicit-fallthrough=]
510  1825 |   is_p2p = _TRUE;
511 /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/linux/ioctl_cfg80211.c:1827:2: note: here
512  1827 |  case NL80211_IFTYPE_AP:
513       |  ^~~~
514 cc1: some warnings being treated as errors
515 make[2]: *** [scripts/Makefile.build:268: /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build/os_dep/linux/ioctl_cfg80211.o] Error 1
516 make[1]: *** [Makefile:1695: /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/build] Error 2
517 make[1]: Leaving directory '/usr/src/kernels/5.6.16-300.fc32.x86_64'
518 make: *** [Makefile:1885: modules] Error 2

This is a compiling error, we cannot do much in this situation:

some suggestion:

1.- do a dkms remove
2.- test with

if both version compilation fails, you will have to find another one…

Regards.,

1 Like

try that command and reboot:

echo “options rtl8723be ant_sel=2” | sudo tee -a /etc/modprobe.d/rtl8723be.conf

or try that options, it solves
echo “options rtl8723be msi=1” | sudo tee -a /etc/modprobe.d/rtl8723be.conf
after:
sudo modprobe -r rtl8723be
then:
sudo modprobe rtl8723be

hope it solves ur issues

[savita@savita ~]$ echo “options rtl8723be msi=1” | sudo tee -a /etc/modprobe.d/rtl8723be.conf
“options rtl8723be msi=1”

[savita@savita ~]$ sudo modprobe -r rtl8723be
libkmod: kmod_config_parse: /etc/modprobe.d/rtl8723be.conf line 1: ignoring bad line starting with ‘“options’

[savita@savita ~]$ sudo vim /etc/modprobe.d/rtl8723be.conf

Remove quotes - then hit command again.

[savita@savita ~]$ sudo modprobe -r rtl8723be

[savita@savita ~]$ sudo modprobe rtl8723be

But no Luck. Reboot machine as well.

try this option as well - add without quotes.

[savita@savita ~]$ cat /etc/modprobe.d/rtl8723be.conf
options rtl8723be ant_sel=2

Reboot machine. Won’t work as well.

weird i helped that commands which i provided above.

does wifi activated on the laptop? is it white or orange color?

laptop with airplane mode key (f12) …no color option, this work for enable/disable Bluetooth/LAN but no impact on wifi. same status as above attached pic.

Hi there raman36127,

I just installed Fedora 32 with GNOME. It came with Kernel 5.7.7-200.fc32.x86_64.

I have that same 8723DE Realtek chipset. I was just here to give you an update, because the driver installation was succesful for my system. Mostly because i read this post prior to any modifications to my system, so I think it’s due for me to post.

Option 1. This github repository https://github.com/lwfinger/rtlwifi_new.git is down without any notice so that is not an option anymore. Have no clue why. Now they have active repositories for all the other family versions of realtek chipset, but this one (8723DE).

Option 2. https://github.com/smlinux/rtl8723de. Installation was pretty straightforward and effortless. Just had to install the kernel headers also, so this was what worked for me.

I just sudo su-ed the whole thing, because it was just me on my home workstation. Might want to add sudo to all commands if you’re in a server. And if that’s the case then running the first 2 commands, may not be advised as well, for obvious reasons:

dnf update
dnf upgrade
dnf install -y git
dnf install -y dkms
yum -y install kernel-devel kernel-headers
git clone https://github.com/smlinux/rtl8723de.git -b current
dkms add ./rtl8723de
dkms install rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414
depmod -a
reboot

From what you wrote the only difference I can see is my kernel version. Why don’t you try uninstalling all traces of previous attempts of installing the driver, upgrading the kernel and then try this once again?

Hope that works for you,

Keep us posted.

Nachosan

1 Like