Fedora 32 upgrade via Gnome Software failed

I upgraded my system to Fedora 32 using Gnome Software, but when attempting to boot it failed:

Failed to switch root: Specified switch root path ‘/sysroot’ does not seem to be an OS tree. os-release file is missing

Whichever kernel I pick, it always enter emergency mode. Ideas?

1 Like

Please can someone bring me up to speed? Updating/upgrading a System (release upgrade) from Gnome Software, … is that the new normal? I mean, is this recommended?

1 Like

According to this, it is:
https://docs.fedoraproject.org/en-US/quick-docs/upgrading/
However, the only system I tried this on broke. The other three I upgraded with dnf system-upgrade are all good.

1 Like

This mentions os-tree. Is this a Fedora silverblue installation?

(And yes, gnome-software does allow distribution upgrades)

1 Like

It is Fedora Workstation 31, fresh install.

This have been seen in the past: https://bugzilla.redhat.com/show_bug.cgi?id=1492208
(for Red Hat Enterprise Linux)… and there for Fedora long ago: https://askbot.fedoraproject.org/en/question/112797/specified-switch-root-path-sysroot-does-not-seem-to-be-an-os-tree/

But it is frankly a bit “over my head”… and would not really suggest you the commands suggested if you don’t understand them…might really be just a similar situation.

1 Like

Thank you for the suggestions, but I had already bumped into these and they don’t work. /sysroot is not mounted to start with, and my fstab is missing (the only thing I have is a /etc/fstab.empty which is unsurprisingly empty ;-)). The os-release file is there and looks fine.

After investigating a bit more, the earliest problem that I can identify is this:

systemd-gpt-auto-generator: EFI loader partition unknown, exiting. (The boot loader did not set EFI variable LoaderDevicePartUUID)

Again, my google-fu is failing me and I have no idea how to proceed :-/

I am just now realizing that I am participating in an other post with very similar problem:

From there… I would suggest to verify if you have root=[something] in your Grub entry.

But also keep an eye on:
https://bugzilla.redhat.com/show_bug.cgi?id=1765297

But it might turn out to be quite different issue because you seems to suggest that /sysroot is not empty at all, and that the file /sysroot/etc/os-release file is there… might check the permissions however.

2 Likes

This looks very promising… My sysroot is empty, the os-release file is in /etc/os-release, not under sysroot.

I am having a look now, I will report soon.

1 Like

Well well, I am writing from the system that was broken :slightly_smiling_face:

In grub, I edited the entry and added root=/dev/mapper/fedora-root. That was enough to get it to boot for now.
/boot/efi/EFI/fedora/grub.cfg looks fine, it should set the default kernel options to the correct values… I’ll reboot now and check.

2 Likes

Indeed, now all the grub entries are fine, booting it once with the extra option was enough.
Thank you @pauld for your kind help! :smiley:

1 Like

Glad to see you get it through!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.