Fedora 32. Wayland nvidia drivers hardware acceleration

Hi I am trying to move from X to wayland but unfortunately I have Nvidia 1050Ti. I am manjaro user and there it just doesnt work in both KDE and gnome. I can make it work on both DE but hardware acceleration doesnt work and falls to llvmpipe. So I have a question (prob I even need a guide) how to install nvidia driver on fedora 32 and make it work with hardware acceleration in fedora 32. Thank you very much!

Hi @forestpower and welcome to the community!

For getting the appropriate drivers installed, have a look at this thread:

Thank you very much. I gonna try this Installer tomorrow. I hope wayland will work with hardware acceleration :slight_smile:

Ok it installed nvidia drivers but it also forced me to X11 :confused: now I dont have option of wayland in display manager. So it is defenitely not a thing that I was looking for. I need wayland + nvidia drivers + 3d hardware acceleration. If it doesnt possible at all pls tell me :slight_smile:

2 Likes

You won’t be forced to X11 per se. If you have an Optimus-based laptop, you can still render your desktop with your IGPU (Wayland) and other applications using DGPU (X11-Wayland bridge). If you have a desktop PC, then it can be quite an issue as you won’t have an IGPU/DGPU to pick from anyway.

1 Like

There are some guide to do this? To configure the use IGPU for wayland and DGPU for applications.

Welcome to AskFedora @pixq.

You would want to read this https://docs.fedoraproject.org/en-US/quick-docs/how-to-set-nvidia-as-primary-gpu-on-optimus-based-laptops/.

1 Like

Sorry, but i’m confused. The link is the opposite of what I would like to do.
quote from the guide: “Please do not use this guide if you want to render your desktop using the integrated GPU and specifically select applications to be rendered using the NVIDIA GPU.”

I am so so sorry. I misread your question.
You see, Wayland does not quite play well with NVIDIA proprietary drivers. If you are wanting hardware acceleration, you would have to stick to X11. The default configuration which is left out after the drivers are installed is the one which has Wayland enabled by default and using DGPU for applications. If you have GNOME, you would be having a nifty option to “Run application with Dedicated Graphics Card”.

So, I just install Nvidia drivers from rpmfusion without changing any configuration, in way that Gnome still use igpu for Wayland. Then in context menu there should appear option “run application with dgpu”?
edit:if I understand right, have to do this after driver installed:
comment the “DRIVER==nvidia” line in /usr/lib/udev/rules.d/64-gdm.rules.
comment “WaylandEnable=false” in /etc/gdm/custom.conf

Installing drivers from official sources like RPM Fusion or Negativo17 would automatically set that up for you. You would not need to edit more stuff to get that entry in the context menu.