Fedora 33, cpufreq stuck at 400MHz

Hello,

after upgrading to Fedora 33, my CPU is stuck to 400MHz and the overall performance is really slow. When I run

$ cpu-power frequency-info

I get

analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency:  Cannot determine or is not supported.
  hardware limits: 400 MHz - 2.00 GHz
  available cpufreq governors: performance powersave
  current policy: frequency should be within 400 MHz and 2.00 GHz.
                  The governor "powersave" may decide which speed to use
                  within this range.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 400 MHz (asserted by call to kernel)
  boost state support:
    Supported: no
    Active: no

I’ve removed powertop and tlp to make sure, that the error does not originate from these packages. I’m using Fedora with my laptop since four years and never had a problem with the cpufreq settings.

The laptop model is an ASUS R541U with an Intel Core i3 CPU (nothing exotic ;-)).

Any hints? Thanks in advance!
Marc

After digging around it seems that thermald is producing the problems. I’ve disabled thermald.service by running:

sudo systemctl disable thermald

and now cpupower frequency-info reports:

analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency:  Cannot determine or is not supported.
  hardware limits: 400 MHz - 2.00 GHz
  available cpufreq governors: performance powersave
  current policy: frequency should be within 400 MHz and 2.00 GHz.
                  The governor "powersave" may decide which speed to use
                  within this range.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 2.00 GHz (asserted by call to kernel)
  boost state support:
    Supported: no
    Active: no

The system is fast and usable again now!

2 Likes

Have you considered reporting a bug against thermald?

1 Like

No I haven’t done so yet. I’m not deep enought in this topic to make sure what exactly causes the issue. I just can solve this failure by disabling the service - but I’m not sure if thermald conflicts with another setting.

So I created an issue here: https://github.com/intel/thermal_daemon/issues/280

2 Likes

Update: the bug is indeed caused by thermald. The developers provided a bugfix branch which I compiled and tested. After running the fixed thermald service my laptop was performing fine again.
See https://github.com/intel/thermal_daemon/issues/280#issuecomment-728643156.

4 Likes

The bug is fixed with thermald version 2.4

1 Like