Fedora 33: extremely slow web browsing (Firefox unusable)

Hello.
I did a fresh install of F33 some days ago. It worked for about 2 weeks.
Suddenly on tuesday morning I switched the computer on, no boot errors, but Firefox took several minutes to load a web site.
I made following tests:
-router off and on

  • computer restart(s)
  • new firefox profile
  • log in with other existing user and try firefox
  • create a new user with default configuration and try
    Nothing. Other browsers were doing better, but better means that e.g. Google takes almost 1 minute to load, a newspaper 2-3, youtube is unusable.
    It is not a connection nor a router issue:
  • speedtest show the expected speed
  • all other devices (android and old linux) connect and load webs normally
  • I can listen to radio from command line with mpv or mplayer, download speed with wget, jdownloader and ftp is normal, upload with ftp and mail is normal.
  • I checked the system with chkrootkit, nothing found.

I tried several recepies I found around (stop resolved, modification with nmcli, but nothing helped, firefox takes centuries to load one site, brave, chromium and falcon do better, but terribly slow.

I GAVE UP AND DID A COMPLETE FRESH INSTALL, I even used a new disk:

  • Install to disk, no users created
  • Log on as root, upgrade, install needed software, create groups and users

The surprise is that the new fresh install has exactly the same problem, firefox is unusable, brave makes me feel in the 90’s. Connection is correct, only the web browsing is terrible. Firefox is working normal when running the live fedora.

I don’t have any proxy, I don’t configure the firewall, I didn’t touch anything on the fresh install except the mentioned above: upgrade, software installation and creation of groups and users.

Some idea?

I bet it’s DNS. As an old school sysadmin, it seems like it’s always DNS.

Can you try disabling

https://support.mozilla.org/en-US/kb/firefox-dns-over-https

Or I guess enabling it if it’s off?

1 Like

Thank you, Matthew.
I enabled it and tried all three providers, but nothing changed.
But I don’t think that it is a Firefox issue, because it is affecting the web browsing in general. Brave is the less frustrating browser, Chromium is middle frustrating, Firefox remains unusable (more than 10 minutes and the home of the newspaper is still showing only text without style and keeps loading).

Even the configuration page of the router is taking up to more than one whole minute to load completely.

Weird! Okay, here’s a thing… you mention that wget seems to give normal speeds. Is that both with http and https?

Oh, also: you say that it works with the F33 live, which implies that it’s something that changed in an update somewhere along the way.

Is there anything interesting in the journal? (journalctl -b -pwarning as an admin user.)

I can get https and http web sites in less than a second with wget, I can connect normally to any radio, no matter if they stream with http or https.

journalctl -b -pwarning

I don’t know if it is relevant, but I see some warnings related with freedesktop (no idea what it is).

mar 06 13:26:51 localhost.localdomain systemd-xdg-autostart-generator[1005]: /etc/xdg/autostart/org.freedesktop.problems.applet.desktop:92: Unknown key name 'DBusActivatable' in section 'Desktop Entry', ignoring.
mar 06 13:26:54 localhost.localdomain dbus-broker-launch[1011]: Service file '/usr/share//dbus-1/services/org.kde.plasma.Notifications.service' is not named after the D-Bus name 'org.freedesktop.Notifications'.
mar 06 13:27:15 localhost.localdomain systemd-xdg-autostart-generator[1042]: /etc/xdg/autostart/org.freedesktop.problems.applet.desktop:92: Unknown key name 'DBusActivatable' in section 'Desktop Entry', ignoring.
mar 06 13:27:18 localhost.localdomain dbus-broker-launch[1074]: Service file '/usr/share//dbus-1/services/org.kde.plasma.Notifications.service' is not named after the D-Bus name 'org.freedesktop.Notifications'.
mar 06 13:28:13 localhost.localdomain pulseaudio[1236]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
mar 06 15:21:14 localhost.localdomain kdeconnectd[1203]: propsReply "No existe la interfaz «org.freedesktop.DBus.Properties» en el objeto en la ruta /org/freedesktop/NetworkManager"
mar 06 15:21:14 localhost.localdomain kded5[1140]: propsReply "No existe la interfaz «org.freedesktop.DBus.Properties» en el objeto en la ruta /org/freedesktop/NetworkManager"
mar 06 15:21:14 localhost.localdomain akonadi_followupreminder_agent[1461]: propsReply "No existe la interfaz «org.freedesktop.DBus.Properties» en el objeto en la ruta /org/freedesktop/NetworkManager"
mar 06 15:21:14 localhost.localdomain akonadi_maildispatcher_agent[1465]: propsReply "No existe la interfaz «org.freedesktop.DBus.Properties» en el objeto en la ruta /org/freedesktop/NetworkManager"
mar 06 15:21:14 localhost.localdomain kdeconnectd[1203]: nmReply "No existe la interfaz «org.freedesktop.NetworkManager» en el objeto en la ruta /org/freedesktop/NetworkManager"
mar 06 15:21:14 localhost.localdomain akonadi_followupreminder_agent[1461]: nmReply "No existe la interfaz «org.freedesktop.NetworkManager» en el objeto en la ruta /org/freedesktop/NetworkManager"
mar 06 15:21:14 localhost.localdomain kded5[1140]: nmReply "No existe la interfaz «org.freedesktop.NetworkManager» en el objeto en la ruta /org/freedesktop/NetworkManager"
mar 06 15:21:14 localhost.localdomain akonadi_sendlater_agent[1469]: propsReply "No existe la interfaz «org.freedesktop.DBus.Properties» en el objeto en la ruta /org/freedesktop/NetworkManager"
mar 06 15:21:14 localhost.localdomain akonadi_maildispatcher_agent[1465]: nmReply "No existe la interfaz «org.freedesktop.NetworkManager» en el objeto en la ruta /org/freedesktop/NetworkManager"
mar 06 15:21:14 localhost.localdomain akonadi_sendlater_agent[1469]: nmReply "No existe la interfaz «org.freedesktop.NetworkManager» en el objeto en la ruta /org/freedesktop/NetworkManager"

Today installed Fedora 33 Live Workstation. Made user account “admin”, usermod -m -d /home/admin /opt/home/admin, because /home will be my NFS and admin must be usable without NFS. Then started confguring firefox (I’m cookie/tracking paranoid) and loaded my proxy settings (like I said, I am paranoid and my firewall blocks almost all off Google, Amazon, Facebook, etc, etc, etc) and started search Fedora with duck duck go … … … at … first … I … thought … proxy … is… not …working… but it is. Its just dead slow. Well I found this page at least. And the thing I noticed so far is that in command console top reports 15 … 45 % CPU for “MainThread”, which process id is rteported by ps as firefox.
On Ubuntu my firefox 78.7.0esr works fine. The fedora 33 install is right of the ISO without updates. I was finding out how to update behind a firewall. Will be back, perhaps with more details. During the first fedora start there was also an Kernel error without enough information to be reported. Something about Intel.

trr.mode = 5 which means it uses my proxy DNS and is therfore as fast as for my Ubuntu setup (I think). MainThread and gnome-shell use a lat of CPU > 150% (dual core). My local octoprint is fast though. It doesn’t use DNS but resolves from /etc/hosts. Got at last ublock installed, and disabled java.scripts by default, disabled pre-fetching. Also disabled searching, prefexhing and speculative content in firefox about:config. Still no improvment. Remarkable : ublock shows immidiatly whcih websties are accessed. After minutes of waiting, still the first (=main) website doesn’t show up in ublock. That hints in the direction that making the connection is difficult. An illegal hostname is resolved quickly by my proxy (octoprint’s squid) wich complains it can not find the hostname. Suid passes HTTPS and octopi is configured to block all local reuqest and lets them only get them to squid. Even resolving is locally not possible other then through squid. So I don’t know what is happening, but if connection establishment beyond squid is going on I guess something is still being tunneld through HTTPS although trr.mode is off. Or other checks are being made, sequrity checks, blacklists, whatever … ???

local octoprint is fast means my octoprint apache served octoprint website. That is local and as fast as normal is. I disabled a lot of reporting and deleted all url’s. At first this does not make a diffetence, until I typed dns in the search bar of about:config, and started pokeining there, The network.dns.enable, network.dns.disableIPV6, and the two (IPV4 and IPV6) network.conenctivity-service.DNSvx.domain (which I deleted the value mozilla.org). At that time I changed back and forth, speed dramatically changed to sometimes even normal behaviour. But I can not reproduce stable results, even not tell what is doing what. It may be that it has nothing to do with it, and something other is changing. Perhaps someone out there is just changing DNS services today. But that would not explain why the Ubuntu machine just works fine.

Yesterday brave was working normally, firefox was slow but usable, until the evening, when it began to work normally. Today again firefox is unusable, brave slow, but acceptable. I didn’t change any kind of configuration, either yesterday nor today (actually I had decided to do again a new fresh install and try again). The connection is not an issue: wget, ftp, mail download and upload correctly, radio from command line with mpv works, dnf downloads at normal speed, speedtest-cli shows the expected speed. The only problem is the web browsing (http and https), specially with firefox, but apparently only intermitently.