Fedora 34 - AAC codec

I’ve recently updated to f34 and now i’m unable to get sound playback with (AAC-LC) encoded videofiles. I cannot use ffmpeg or HandBrake to convert it either. HandBrake-gui throws the following error:

encavcodecaudio: avcodec_send_frame failed

When I ffprobe a file it throws the following message:

Assuming an incorrectly encoded 7.1 channel layout instead of a spec-compliant 7.1(wide) layout, use -strict 1 to decode according to the specification instead.

VLC throws the following error:
libmp3lame @ 0x7f4b184f8900] Specified channel layout ‘7.0’ is not supported

All the gstreamer (good bad ugly libav free) are installed and it worked before the upgrade. I also tried to revert to pulseaudo but it did not help. Totem (which uses gstreamer instead of ffmpeg ?) works fine.

Can someone put me in the right path in how-to debug this issue ? Thanks.

1 Like

All these packages are from RPM Fusion, right? Perhaps asking on their mailing list directly may help?

https://lists.rpmfusion.org/archives/list/rpmfusion-users@lists.rpmfusion.org/

1 Like

ffmpeg and HandBrake are indeed, I did not think of that.
I’m going to ask it there, thanks.

1 Like

Thanks, please do let us know if you find the issue and a solution.

Please do let us know if you find a solution. I tried a clean install. I do not get an error, but Handbrake does not encode sound with the video.