Fedora 34 dev. How to change the dash background colour transparent?

Fedora 34 dev. How to change the dash background colour to transparent? Not something that’d trouble anyone, as the dash is always hidden. But, it’d be nice, only to see the dash, when it appears. In the default Adwaita theme, the background is there, but sort of dimmed.

1 Like

hi @chdslv : welcome to the forum! Please take a minute to look at the introductory posts in the #start-here category if you’ve not had a chance to do it yet.

Is your system up to date? I’m not seeing the darker horizontal band on my F34 here.

$ rpm -qa \*gnome\*
NetworkManager-ssh-gnome-1.2.11-2.fc33.x86_64
pinentry-gnome3-1.1.1-3.fc34.x86_64
gnome-menus-3.36.0-4.fc34.x86_64
gnome-video-effects-0.5.0-5.fc34.noarch
gnome-session-40~beta-1.fc34.x86_64
gnome-terminal-3.38.1-3.fc34.x86_64
libgnomekbd-3.26.1-5.fc34.x86_64
gnome-themes-extra-3.28-12.fc34.x86_64
gnome-session-wayland-session-40~beta-1.fc34.x86_64
gnome-session-xsession-40~beta-1.fc34.x86_64
f34-backgrounds-gnome-34.0.1-1.fc34.noarch
desktop-backgrounds-gnome-34.0.0-1.fc34.noarch
chrome-gnome-shell-10.1-12.fc34.x86_64
gnome-shell-extension-pomodoro-0.18.0-2.fc34.x86_64
gnome-terminal-nautilus-3.38.1-3.fc34.x86_64
NetworkManager-vpnc-gnome-1.2.6-6.fc34.x86_64
gnome-user-share-3.34.0-5.fc34.x86_64
NetworkManager-openconnect-gnome-1.2.6-6.fc34.x86_64
NetworkManager-openvpn-gnome-1.8.12-1.fc34.2.x86_64
NetworkManager-pptp-gnome-1.2.8-2.fc34.2.x86_64
gnome-color-manager-3.36.0-4.fc34.x86_64
gnome-logs-3.36.0-4.fc34.x86_64
qgnomeplatform-0.7.0-3.fc34.x86_64
f33-backgrounds-gnome-33.0.8-2.fc34.noarch
fros-gnome-1.1-25.fc34.noarch
gnome-icon-theme-3.12.0-15.fc34.noarch
f32-backgrounds-gnome-32.2.2-3.fc34.noarch
gnome-online-accounts-3.39.92-1.fc34.x86_64
gnome-autoar-0.3.1-1.fc34.x86_64
gnome-shell-extension-background-logo-40.0~rc-1.fc34.noarch
gnome-online-miners-3.34.0-8.fc34.x86_64
gnome-backgrounds-40~rc-1.fc34.noarch
gnome-abrt-1.3.6-5.fc34.x86_64
gnome-desktop3-40.0-1.fc34.x86_64
gnome-settings-daemon-40.0-1.fc34.x86_64
gnome-bluetooth-libs-3.34.5-1.fc34.x86_64
gnome-bluetooth-3.34.5-1.fc34.x86_64
gnome-control-center-filesystem-40.0-1.fc34.noarch
gnome-tour-40.0-1.fc34.x86_64
gnome-remote-desktop-40.0-1.fc34.x86_64
gnome-control-center-40.0-1.fc34.x86_64
gnome-shell-40.0-1.fc34.x86_64
gnome-shell-extension-common-40.0-1.fc34.noarch
gnome-shell-extension-user-theme-40.0-1.fc34.noarch
gnome-boxes-40.0-1.fc34.x86_64
gnome-initial-setup-40.0-1.fc34.x86_64
gnome-calendar-40.0-1.fc34.x86_64
gnome-calculator-40.0-1.fc34.x86_64
gnome-contacts-40.0-1.fc34.x86_64
gnome-maps-40.0-1.fc34.x86_64
gnome-characters-40.0-1.fc34.x86_64
gnome-weather-40.0-1.fc34.noarch
gnome-clocks-40.0-1.fc34.x86_64
gnome-font-viewer-40.0-1.fc34.x86_64
gnome-disk-utility-40.0-1.fc34.x86_64
gnome-system-monitor-40.0-1.fc34.x86_64
gnome-screenshot-40.0-1.fc34.x86_64
gnome-user-docs-40.0-1.fc34.noarch
gnome-keyring-40.0-1.fc34.x86_64
gnome-software-40.0-2.fc34.x86_64
gnome-keyring-pam-40.0-1.fc34.x86_64
gnome-photos-40.0-1.fc34.x86_64
gnome-tweaks-40.0-2.fc34.noarch
gnome-extensions-app-40.0-1.fc34.x86_64
2 Likes

Of course, it is up to date. Like I said, I changed the theme, so the background colour can be seen. Even with the default Adwaita, that background is there, only slightly. Not a big deal, really. :slight_smile:

Do you have some sort of “dock” extension installed?

Corrected the problem by changing gnome-shell.css and setting background-color: transparent; in #dash in the given theme. It would be nice to have a configuration ability, by the way.

1 Like

Best to file an issue with the developers of the theme. In this case, Gnome? For any Gnome related issues, you should file bugs with Gnome upstream. Fedora packages and provides Gnome but does not develop it.