Fedora 34 doesn't wake monitor up from sleep (Radeon RX 580)

Hello everybody, I am an old Linux user who left for and now I’m returning playing with Linux! I had a little experience starting with FC4 / Ubuntu 4.10 but now I feel unable to even report the smallest bug!

Here’s the problem.
Summary: Gnome is set to turn the monitor off after 5 minutes. When I try to wake the system up, nothing happens, except for a little HDD activity; trying to open other terminals does not help
System: Fedora 34 on Intel i5-4690 with Radeon RX 580 (Polaris10)
Kernel: 5.11.20-300.fc34.x86_64

I tried looking for logs; I found that Gnome-logs now is terrible, and that from terminal I could extract a few significant lines I paste below.
I tried looking for Xorg logs but the poor files in the .local/share folder don’t seem to be helpful.
I didn’t find a bug with this particular problem other than 1888048 – R9-390 AMDGPU cannot wake up from Suspend (both 32 and 33) but it’s for suspending the PC. I have to stress I did not suspend it at all.

With Windows 10 it works well; it worked really well on Ubuntu 20.10 before I turned to Fedora.
I am really looking forward to help solve the problem - I could go and return to Ubuntu, but it would not be the right thing!

mag 03 00:12:01 H388X kernel: [drm] PCIE GART of 256M enabled (table at 0x000000F400000000).
mag 03 00:12:11 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:12:14 H388X kernel: amdgpu: 
                           failed to send message 252 ret is 0 
mag 03 00:12:19 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:12:22 H388X kernel: amdgpu: 
                           failed to send message 253 ret is 0 
mag 03 00:12:27 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:12:29 H388X kernel: amdgpu: 
                           failed to send message 250 ret is 0 
mag 03 00:12:34 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:12:37 H388X kernel: amdgpu: 
                           failed to send message 251 ret is 0 
mag 03 00:12:47 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:12:47 H388X kernel: amdgpu: 
                           failed to send message 254 ret is 0 
mag 03 00:12:47 H388X kernel: amdgpu: SMU load firmware failed
mag 03 00:12:47 H388X kernel: amdgpu: fw load failed
mag 03 00:12:47 H388X kernel: amdgpu: smu firmware loading failed
mag 03 00:12:47 H388X kernel: amdgpu 0000:01:00.0: amdgpu: amdgpu_device_ip_resume failed (-22).
mag 03 00:12:47 H388X gnome-shell[1697]: amdgpu: The CS has been rejected, see dmesg for more information (-19).
mag 03 00:12:47 H388X kernel: amdgpu: Move buffer fallback to memcpy unavailable
mag 03 00:12:47 H388X kernel: [drm:amdgpu_cs_ioctl [amdgpu]] *ERROR* Failed to process the buffer list -19!
mag 03 00:12:47 H388X systemd[1]: Starting Fingerprint Authentication Daemon...
mag 03 00:12:47 H388X systemd[1]: Started Fingerprint Authentication Daemon.
mag 03 00:12:47 H388X audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=fprintd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
mag 03 00:12:47 H388X gnome-shell[1697]: Usage of object.actor is deprecated for AuthPrompt
                                     get@resource:///org/gnome/shell/ui/environment.js:317:29
                                     _initEntryRow@resource:///org/gnome/shell/gdm/authPrompt.js:176:9
                                     _init@resource:///org/gnome/shell/gdm/authPrompt.js:93:14
                                     _ensureAuthPrompt@resource:///org/gnome/shell/ui/unlockDialog.js:678:28
                                     _showPrompt@resource:///org/gnome/shell/ui/unlockDialog.js:717:14
                                     vfunc_key_press_event@resource:///org/gnome/shell/ui/unlockDialog.js:617:14
mag 03 00:12:47 H388X kernel: snd_hda_intel 0000:01:00.1: CORB reset timeout#1, CORBRP = 0
mag 03 00:13:07 H388X kernel: [drm:atom_op_jump [amdgpu]] *ERROR* atombios stuck in loop for more than 20secs aborting
mag 03 00:13:07 H388X kernel: [drm:amdgpu_atom_execute_table_locked [amdgpu]] *ERROR* atombios stuck executing E7AE (len 761, WS 0, PS 0) @ 0xE7F9
mag 03 00:13:27 H388X systemd[1]: fprintd.service: Deactivated successfully.
mag 03 00:13:27 H388X kernel: [drm:atom_op_jump [amdgpu]] *ERROR* atombios stuck in loop for more than 20secs aborting
mag 03 00:13:27 H388X kernel: [drm:amdgpu_atom_execute_table_locked [amdgpu]] *ERROR* atombios stuck executing E7AE (len 761, WS 0, PS 0) @ 0xE846
mag 03 00:13:27 H388X audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=fprintd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
mag 03 00:13:30 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:13:32 H388X kernel: amdgpu: 
                           failed to send message 26a ret is 0 
mag 03 00:13:38 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:13:40 H388X kernel: amdgpu: 
                           failed to send message 145 ret is 0 
mag 03 00:13:45 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:13:48 H388X kernel: amdgpu: 
                           failed to send message 146 ret is 0 
mag 03 00:13:49 H388X com.valvesoftware.Steam.desktop[20972]: BRefreshApplicationsInLibrary 1: 0ms
mag 03 00:13:53 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:13:56 H388X kernel: amdgpu: 
                           failed to send message 306 ret is 0 
mag 03 00:14:01 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:14:01 H388X kernel: amdgpu: 
                           failed to send message 5e ret is 0 
mag 03 00:14:21 H388X kernel: [drm:atom_op_jump [amdgpu]] *ERROR* atombios stuck in loop for more than 20secs aborting
mag 03 00:14:21 H388X kernel: [drm:amdgpu_atom_execute_table_locked [amdgpu]] *ERROR* atombios stuck executing B42E (len 1227, WS 8, PS 8) @ 0xB81B
mag 03 00:14:41 H388X kernel: [drm:atom_op_jump [amdgpu]] *ERROR* atombios stuck in loop for more than 20secs aborting
mag 03 00:14:41 H388X kernel: [drm:amdgpu_atom_execute_table_locked [amdgpu]] *ERROR* atombios stuck executing DB8A (len 824, WS 0, PS 0) @ 0xDCCC
mag 03 00:14:41 H388X kernel: [drm:amdgpu_atom_execute_table_locked [amdgpu]] *ERROR* atombios stuck executing DA44 (len 326, WS 0, PS 0) @ 0xDACF
mag 03 00:14:41 H388X kernel: [drm:dce110_link_encoder_enable_tmds_output [amdgpu]] *ERROR* dce110_link_encoder_enable_tmds_output: Failed to execute VBIOS command table!
mag 03 00:14:41 H388X kernel: [drm] REG_WAIT timeout 10us * 6000 tries - dce_mi_allocate_dmif line:743
mag 03 00:14:41 H388X kernel: [drm] REG_WAIT timeout 10us * 6000 tries - dce_mi_allocate_dmif line:743
mag 03 00:14:43 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:14:46 H388X kernel: amdgpu: 
                           failed to send message 26a ret is 0 
mag 03 00:14:51 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:14:54 H388X kernel: amdgpu: 
                           failed to send message 145 ret is 0 
mag 03 00:14:59 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:15:01 H388X kernel: amdgpu: 
                           failed to send message 146 ret is 0 
                           last message was failed ret is 0
mag 03 00:15:01 H388X kernel: amdgpu: 
                           failed to send message 146 ret is 0 
mag 03 00:15:04 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:15:06 H388X gsd-power[1990]: Error setting property 'PowerSaveMode' on interface org.gnome.Mutter.DisplayConfig: È stato raggiunto il timeout (g-io-error-quark, 24)
mag 03 00:15:06 H388X kernel: amdgpu: 
                           failed to send message 5d ret is 0 
mag 03 00:15:07 H388X kernel: [drm:hwss_wait_for_blank_complete [amdgpu]] *ERROR* DC: failed to blank crtc!
mag 03 00:15:07 H388X kernel: [drm:dce110_reset_hw_ctx_wrap [amdgpu]] *ERROR* DC: failed to blank crtc!
mag 03 00:15:27 H388X kernel: [drm:atom_op_jump [amdgpu]] *ERROR* atombios stuck in loop for more than 20secs aborting
mag 03 00:15:47 H388X kernel: [drm:amdgpu_atom_execute_table_locked [amdgpu]] *ERROR* atombios stuck executing E7AE (len 761, WS 0, PS 0) @ 0xE7F9
mag 03 00:15:47 H388X kernel: [drm:atom_op_jump [amdgpu]] *ERROR* atombios stuck in loop for more than 20secs aborting
mag 03 00:15:47 H388X kernel: [drm:amdgpu_atom_execute_table_locked [amdgpu]] *ERROR* atombios stuck executing E7AE (len 761, WS 0, PS 0) @ 0xE846
mag 03 00:16:07 H388X kernel: [drm:atom_op_jump [amdgpu]] *ERROR* atombios stuck in loop for more than 20secs aborting
mag 03 00:16:07 H388X kernel: [drm:amdgpu_atom_execute_table_locked [amdgpu]] *ERROR* atombios stuck executing E7AE (len 761, WS 0, PS 0) @ 0xE7F9
mag 03 00:16:27 H388X kernel: [drm:atom_op_jump [amdgpu]] *ERROR* atombios stuck in loop for more than 20secs aborting
mag 03 00:16:27 H388X kernel: [drm:amdgpu_atom_execute_table_locked [amdgpu]] *ERROR* atombios stuck executing E7AE (len 761, WS 0, PS 0) @ 0xE846
mag 03 00:16:29 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:16:32 H388X kernel: amdgpu: 
                           failed to send message 26a ret is 0 
mag 03 00:16:37 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:16:40 H388X kernel: amdgpu: 
                           failed to send message 145 ret is 0 
mag 03 00:16:45 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:16:47 H388X kernel: amdgpu: 
                           failed to send message 146 ret is 0 
mag 03 00:16:52 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:16:55 H388X kernel: amdgpu: 
                           failed to send message 306 ret is 0 
mag 03 00:16:58 H388X kernel: amdgpu: 
                           last message was failed ret is 0
mag 03 00:17:40 H388X gsd-media-keys[1988]: Unable to get default sink
mag 03 00:17:40 H388X gsd-media-keys[1988]: Unable to get default source

I’m on an AMD CPU, but with the same gfx card. I’d removed Gnome because, well …
But I added it back to test, and the only thing that brings it out of suspend properly is a quick tap of the power button (as it should be) (x or wayland). Sorry, I know that may not help much; but none the less - it’s not the card.

Oh, sorry, Did not see you said you DID NOT suspend. my bad. Sounds like a flacky cable TBH.

@suspiciousmilk Thanks for the answer!
I found the suggestion to look at the power cables in other posts - however, using Windows 10 on the same pc (dual boot) I did not find any problem at all, nor it did have problems with Ubuntu 20.10 or using Ubuntu 21.04 from live USB. The monitor turns off and the system wakes up correctly every time.
However, suspend works perfectly!
Looks like a Fedora-specific problem, maybe with a sleep state not supported by my system?
Maybe a user-specific problem? The only “strange” thing is that the home folder has not been recreated, it’s the same I used on Ubuntu, same username; if X.org or Wayland uses some conf file from ~, maybe it’s were the problem lies. I’ll try with a new empty user.
I will also retry checking the cables (it’s a single cable to the graphic card so assuming the PSU does its job, it’s not a long check) but if I cannot solve it I will go sadly back to Ubuntu…

Tried with a new user and the problem is still here.
Also tried benchmarking using Basemark; the score looks good and the system was stable and working.

https://www.gitmemory.com/issue/fedora-silverblue/issue-tracker/172/842505546

Well it seems a similar problem. Sorry, I’m no help again - but you are not alone it seems.

I have the exact same problem. My card is a Sapphire RX 590. My machine is also perfectly stable under Windows 10. The freezing issues for me started sometime during the Fedora 33 release cycle, and persisted with Fedora 34.

Also it is noteworthy that after booting up the machine it either ends up in a state where this issue occurs deterministically (the machine freezes once the screen locker is activated and the monitors go to standby) or ends up in a state where it does not happen at all.