Fedora 34 freezes

Got it @chrismurphy I’ll play around with Windows about the timezone.

Do you mean just install memtest and leave for the night or firstly overclock cpu/ram and then start memtest?

As for today’s freeze, I saw that time wasn’t changing, but I could move the pointer and at this moment I could switch to tty3 it was prompting login as expected. But When I decided to type it was already completely frozen. Trying to give as much information about my freeze behavior as possible))

Returning back to netconsole, it seems like I’ve properly set it up, it’s starting from the boot order and running successfully.

Note: Firewall is temporarily disabled.

Here’s dmesg |grep netcon:

[   10.535605] netpoll: netconsole: local port 6666
[   10.535610] netpoll: netconsole: local IPv4 address 192.168.1.100
[   10.535612] netpoll: netconsole: interface 'wlo1'
[   10.535613] netpoll: netconsole: remote port 6666
[   10.535614] netpoll: netconsole: remote IPv4 address 192.168.1.163
[   10.535616] netpoll: netconsole: remote ethernet address 8c:89:...
[   10.535875] Modules linked in: netconsole(+) overlay bnep sunrpc squashfs vfat fat loop snd_sof_pci_intel_cnl snd_sof_intel_hda_common soundwire_intel soundwire_generic_allocation soundwire_cadence snd_sof_intel_hda snd_sof_pci snd_sof_xtensa_dsp snd_sof snd_soc_skl snd_soc_hdac_hda snd_hda_ext_core snd_soc_sst_ipc snd_soc_sst_dsp snd_soc_acpi_intel_match snd_soc_acpi snd_soc_core snd_hda_codec_realtek intel_tcc_cooling x86_pkg_temp_thermal snd_hda_codec_generic intel_powerclamp snd_compress coretemp ledtrig_audio iwlmvm snd_hda_codec_hdmi snd_pcm_dmaengine ac97_bus iTCO_wdt kvm_intel intel_pmc_bxt snd_hda_intel snd_intel_dspcfg snd_intel_sdw_acpi mac80211 ee1004 iTCO_vendor_support mei_hdcp ucsi_ccg intel_rapl_msr snd_hda_codec libarc4 kvm uvcvideo snd_hda_core btusb btrtl snd_hwdep videobuf2_vmalloc iwlwifi irqbypass videobuf2_memops snd_seq btbcm videobuf2_v4l2 btintel rapl videobuf2_common snd_seq_device dcdbas intel_cstate bluetooth i2c_i801 intel_uncore cfg80211 pcspkr
[   10.535935]  write_msg+0xd8/0xf0 [netconsole]
[   10.535936]  init_netconsole+0x20e/0x1000 [netconsole]
[   10.545436] printk: console [netcon0] enabled
[   10.545440] netconsole: network logging started

So in this case remove PC is running windows and nc -l -u -p 6666 > netconsole.txt but the file is empty when I plug in the drive on the problematic laptop (which triggers kernel logs in /var/log/messages). I’m able to see this messages on the host laptop but it’s not transferring those messages to my remote PC even though I can ping it.

I’ve also tried this process on my other laptop running F33 respectively changing the IP before testing. Still no luck…

I found my problem why mine was freezing up on me. I don’t have any issues of a freeze up on my fedora 34 using a Ethernet connection. But when I turn off the wire connected and turn on and connect to a WiFi it freezes up after about 15 minutes. So that tells me there is a problem in the kernel with the WiFi drivers. My driver was recently added to the kernel as it never was in the kernel for a long while. As long as I don’t use my WiFi my system won’t freeze up.

1 Like

Yeah, interesting case you had.

I use WI-Fi most of the time, sometimes I don’t have freezes the whole day and my workflow is pretty the same from day-to-day. The problem is we can’t trace back the source of the freezes in my case. Seems like logs aren’t giving much of the information to debug.

I also use an ethernet connection using an adapter. And the laptop isn’t freezing after a specific time. It’s very random at this point while we don’t have enough information.

I don’t know why but I’m linking freeze with losing the power of USB ports as I understand from the logs and there are errors about Nvidia drivers not installed and one more error is about that this machine isn’t dell (it’s something related to the bios), can’t get what’s the point here…

I contact Razer support in my free time and try to install Nvidia drivers.

1 Like

Well, it took me two days to figure out what it is. But I’m not done yet and will see what I can do to use my WiFi so I can connect my other computer to the Ethernet so I can share internet with it. So more work ahead for me.

1 Like

When I look at the logs, I find this line for my WiFi driver.
rtw_8821ce 0000:03:00.0 wlp3s0: renamed from wlan0
which I never saw it do on Linux before. I mean it’s always been named as wlan0 when I have used WiFi before on other computers.

1 Like

Hmmm, maybe the driver is doing weird things??

I’ve found this article very randomly, not searching the net specifically for my problem, though here it is:
https://www.phoronix.com/scan.php?page=news_item&px=Samsung-860-870-More-Quirks

I don’t know maybe this is a very dumb connection to my issue, I’ve Samsung 980 SSD - M.2 NVMe. Maybe disable trim or something else and see the result.

Can this be the source of the freeze issue? @ankursinha do you know any tool/command I can test and see if the laptop will freeze while testing?

Yeh, worth trying:

https://fedoraproject.org/wiki/Changes/EnableFSTrimTimer#User_Experience

No, without knowing what the issue is it’s hard to think of a command that will simulate the freeze :frowning:

1 Like

Yeah, I see.

I’ll disable fstrim and see the result.

1 Like

I believe that is called Consistent Network Device Naming and Predictable Network Interface Names. Also see the biosdevname man page.