Fedora 34 GNOME 40 Nvidia driver install + cuda

Hi guys i have some trouble for install the Nvidia driver GTX 960 in Fedora 34.
My main propose is game dev using primary Blender with Cuda or Optix.

My installation of Fedora is clean, I just install the update of the system and install Blender.
If some one can help :pray:

The main problem for me is this:

My config:

[tairo@fedora ~]$ inxi -Fzx 
System:
  Kernel: 5.11.17-300.fc34.x86_64 x86_64 bits: 64 compiler: gcc 
  v: 2.35.1-41.fc34 Desktop: GNOME 40.0 
  Distro: Fedora release 34 (Thirty Four) 
Machine:
  Type: Desktop Mobo: Gigabyte model: B85M-D3PH v: x.x serial: <filter> 
  BIOS: American Megatrends v: F4 date: 07/04/2014 
CPU:
  Info: Quad Core model: Intel Core i7-4790 bits: 64 type: MT MCP 
  arch: Haswell rev: 3 cache: L2: 8 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 57470 
  Speed: 3896 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 3896 2: 3847 
  3: 3946 4: 3989 5: 3929 6: 3895 7: 3976 8: 3955 
Graphics:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
  vendor: Gigabyte driver: i915 v: kernel bus-ID: 00:02.0 
  Device-2: NVIDIA GM206 [GeForce GTX 960] vendor: Gigabyte driver: nouveau 
  v: kernel bus-ID: 01:00.0 
  Display: wayland server: X.Org 1.21.1.1 compositor: gnome-shell driver: 
  loaded: nouveau note: n/a (using device driver) - try sudo/root 
  resolution: 1: 1920x1200~60Hz 2: 1440x900~60Hz 
  OpenGL: renderer: NV126 v: 4.3 Mesa 21.0.3 direct render: Yes 
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  driver: snd_hda_intel v: kernel bus-ID: 00:03.0 
  Device-2: Intel 8 Series/C220 Series High Definition Audio 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
  Device-3: NVIDIA GM206 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
  Sound Server-1: ALSA v: k5.11.17-300.fc34.x86_64 running: yes 
  Sound Server-2: PipeWire v: 0.3.26 running: yes 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: d000 bus-ID: 05:00.0 
  IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IF-ID-1: virbr0 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.76 TiB used: 3.63 GiB (0.2%) 
  ID-1: /dev/sda vendor: SanDisk model: SDSSDA120G size: 111.79 GiB 
  ID-2: /dev/sdb vendor: Samsung model: HD154UI size: 1.36 TiB 
  ID-3: /dev/sdc vendor: Western Digital model: WD3200AAJS-00L7A0 
  size: 298.09 GiB 
Partition:
  ID-1: / size: 110.79 GiB used: 3.42 GiB (3.1%) fs: btrfs dev: /dev/sda2 
  ID-2: /boot size: 975.9 MiB used: 215.1 MiB (22.0%) fs: ext4 
  dev: /dev/sda1 
  ID-3: /home size: 110.79 GiB used: 3.42 GiB (3.1%) fs: btrfs 
  dev: /dev/sda2 
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 33.0 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 834 
Info:
  Processes: 295 Uptime: 7m Memory: 19.4 GiB used: 2.43 GiB (12.6%) 
  Init: systemd runlevel: 5 Compilers: gcc: 11.1.1 Packages: 1741 
  Shell: Bash v: 5.1.0 inxi: 3.3.03 

INFO. GPU:

 [tairo@fedora ~]$ lspci |grep -E "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 960] (rev a1)
1 Like

It is not my area of expertise, but a little googling suggests that there have been many problems with nvidia on 5.9+ kernels. You could try downloading and installing the 5.8.14 from here: kernel-5.8.14-200.fc32 | Build Info | koji

I think you will need to download the kernel, kernel-core, kernel-modules, and maybe kernel-modules-extra (install the same set that you have installed on your system). It should allow you to have multiple versions of those packages installed simultaneously (I think you can only have one version of kernel-headers, but hopefully you won’t need to downgrade that).

Once you’ve downloaded them into a directory, you should be able to install them with rpm -ivh *.rpm.

I’m not sure if you can run that old of a kernel on Fedora LInux 34, but it seems worth a try.

P.S. If you need to downgrade the kernel-headers package, it looks like this would be the one to use: kernel-headers-5.8.11-200.fc32 | Build Info | koji

I know the version numbers don’t match exactly, but that is normal. For an explanation, see this post: https://laptrinhx.com/thorsten-leemhuis-package-names-can-be-false-friends-too-as-linux-kernel-headers-show-2396218373/

Excerpted from the above article:

Kernel headers are backwards compatible, but not forwards compatible. This means that a program built against a C library using older kernel headers should run on a newer kernel (although it may not have access to new features), but a program built against newer kernel headers may not work on an older kernel.

1 Like

It looks like your running the latest kernel so maybe check out rpmfusion for the nvivia drivers and how to install cuda.

1 Like

I’ve tried this on other times … but,i think I’m using the wrong commands, princialy for cuda. But it’s probably something I do wrong …
It is possible to send the command line for installation.

I read, but its too advanced for me at the moment… Im not at this level, but i can try the comands if i have the way.

Please install this first NVIDIA Auto Installer for Fedora now works with Fedora 34.

Then run the following two commands in succession.

sudo nvautoinstall --nvrepo
sudo nvautoinstall --plcuda

Assuming that you already have the proprietary drivers installed from RPM Fusion.

1 Like

I just made the below video demo if you want to try installing the older kernel. Try the newer nvidia driver first though.

P.S. If you do find that it only works on the older kernel, you will need to lock your kernel version to prevent it from being updated with the rest of the system. You can do so by adding the following line to /etc/dnf/dnf.conf.

exclude=kernel,kernel-*

3 Likes

I followed this first. then broken system kkkk, but no problem, i just reinstall again, because black screen and nothing works.

[tairo@fedora ~]$ uname -r
5.8.14-200.fc32.x86_64
=)
Lets try the driver now

it was 3:00 am and i was tryng install the driver… I so tirede and cant’ remember exactly the error menssagem, but i think is fail to load, kernel devel, kernel headers"

The newer driver might depend on a newer kernel. Sometimes the drivers will state what kernels they are compatible with (e.g. for zfs). I don’t know where that would be documented for NVidia. Maybe someone else knows. It can be tricky finding a stable nvidia+kernel combination. I think the general consensus is that NVidia is to blame. AMD cooperates much better with the Linux kernel development team.

1 Like

Hiya, I haven’t tested the cuda part, but this is what I do in my laptop with hybrid Intel + Nvidia graphics and tends to work (currently running kernel 5.11.17-300 and nvidia 465.27 from rpmfusion):

sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm
sudo dnf install akmod-nvidia
sudo dnf install xorg-x11-drv-nvidia-cuda

Then just restart and be careful when you log back into the system. Previously in Fedora 33 after installing the nvidia drivers, the X11 session was preselected while in 34 it’s Wayland, so just make sure to select the X11 session.
After that you should hopefully be using the right drivers :crossed_fingers:

For the record, are you using the blender package from the fedora repository or the upstream distribution of blender ?

(Please drop about using kernel package from f32, that’s non-sense at all, sorry Gregory. Current nvidia drivers works with current fedora released kernels).

1 Like

Yeah, I thought he was having trouble getting the current nvidia drivers installed though, in which case, downgrading the kernel would be the other option. Going back that far is a bit much though. It was just based on a report from someone that the older nvidia driver was known to work with that kernel version:

Excerpted from No compatible GPUs found for path tracing – nvidia support:

@Philipp Oeser (lichtwerk) and @Blake (dearzhenx), I finished downgrading the kernel and header to 5.8.14 on Arch and the errors have gone away, so far.

I try the blender package from the fedora, flatpak and blender upstream.

After the last try, the system broken.
i reinstalled again, updated and do the rpm fuzion comand list + cuda.
The blender and GPU driver works now =)

Now the boot is too slow, before and after login screen… how solve this ?

now my system :slight_smile:

[tairo@fedora ~]$ inxi -Fzx 
System:
  Kernel: 5.11.18-300.fc34.x86_64 x86_64 bits: 64 compiler: gcc 
  v: 2.35.1-41.fc34 Desktop: GNOME 40.0 
  Distro: Fedora release 34 (Thirty Four) 
Machine:
  Type: Desktop Mobo: Gigabyte model: B85M-D3PH v: x.x serial: <filter> 
  BIOS: American Megatrends v: F4 date: 07/04/2014 
CPU:
  Info: Quad Core model: Intel Core i7-4790 bits: 64 type: MT MCP 
  arch: Haswell rev: 3 cache: L2: 8 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 57468 
  Speed: 3992 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 3992 2: 3991 
  3: 3991 4: 3993 5: 2504 6: 3994 7: 3996 8: 3984 
Graphics:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
  vendor: Gigabyte driver: i915 v: kernel bus-ID: 00:02.0 
  Device-2: NVIDIA GM206 [GeForce GTX 960] vendor: Gigabyte driver: nvidia 
  v: 465.27 bus-ID: 01:00.0 
  Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting,nvidia 
  unloaded: fbdev,nouveau,vesa resolution: 1: 1440x900~60Hz 
  2: 1920x1200~60Hz 
  OpenGL: renderer: NVIDIA GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 465.27 
  direct render: Yes 
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  driver: snd_hda_intel v: kernel bus-ID: 00:03.0 
  Device-2: Intel 8 Series/C220 Series High Definition Audio 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
  Device-3: NVIDIA GM206 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
  Sound Server-1: ALSA v: k5.11.18-300.fc34.x86_64 running: yes 
  Sound Server-2: PipeWire v: 0.3.27 running: yes 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: d000 bus-ID: 05:00.0 
  IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IF-ID-1: virbr0 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.76 TiB used: 12.34 GiB (0.7%) 
  ID-1: /dev/sda vendor: SanDisk model: SDSSDA120G size: 111.79 GiB 
  ID-2: /dev/sdb vendor: Samsung model: HD154UI size: 1.36 TiB 
  ID-3: /dev/sdc vendor: Western Digital model: WD3200AAJS-00L7A0 
  size: 298.09 GiB 
Partition:
  ID-1: / size: 110.79 GiB used: 12.13 GiB (11.0%) fs: btrfs dev: /dev/sda2 
  ID-2: /boot size: 975.9 MiB used: 214.8 MiB (22.0%) fs: ext4 
  dev: /dev/sda1 
  ID-3: /home size: 110.79 GiB used: 12.13 GiB (11.0%) fs: btrfs 
  dev: /dev/sda2 
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 34 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 24% 
Info:
  Processes: 306 Uptime: 6m Memory: 19.4 GiB used: 1.8 GiB (9.3%) 
  Init: systemd runlevel: 5 Compilers: gcc: 11.1.1 Packages: 2062 
  Shell: Bash v: 5.1.0 inxi: 3.3.03 

Glad it worked :slight_smile:
Regarding the slow boot time, you can use “systemd-analyze blame” from the terminal to find how long does every element of the boot sequence take. If you don’t use any kind of enterprise login, you can almost surely disable the “NetworkManager-wait-online” service and that should improve things a bit.
Bear in mind anyway that whenever you get a kernel update, the next boot is going to take a while because the system will rebuild the nvidia modules.

1 Like

Please ask another TOPIC referring to this to solve your performance issue, one clue is what @franute suggest, and again WELCOME to ask again, this is because:

1.- The TOPIC can be too long.
2.- One Question to solve two different problems.
3.- The solution to the first problem can be difficult to find for normal $USER navigation for the hole TOPIC.

Regards., HTH

2 Likes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.