Fedora 34 - KDE - How To Revert To DNF Updater Instead Of Discover

Since Fedora 34, I have noticed that Discover has taken the role of the Dnf updater. I decided to give it a try and see how things go.
I don’t like it and would like to know how to use (if possible) the Dnf updater, maybe that is not what it is called, for all previous versions of Fedora that I have used before Fedora 34 KDE, I would be prompted to install updates via dnf. If my terminology is incorrect, my aoplogies.

Now concerning Discover, I find that it Violently kill any running application to inform that updates are available, so whatever I was doing is stopped.
Today in the list of updates, there was the following " google-noto-emoji-color-fonts", along with a couple of other applications.
Discover updated all the other applications, did it usual things of requiring a restart and it sill listed the google-noto fonts to be updated. Clicking on “Update All” does absolutely nothing.

In a terminal I ran sudo dnf check-update
The google-noto font was listed. I performed the update with sudo dnf update
That went well.

Discover is still listing google-noto-emoji-color-fonts as an available update.

This is a long post, almost a rant :sweat_smile: But in essence I’d like to know how to revert to the old dnf update notifications.

1 Like

I think you can run on Fedora 33 until November.

Probably not the best way to support the development of Fedora 34, but well, in the case you have some urgent workload, I would try it with a fresh installation of Fedora 33.

Fedora is a very fast release with many nice features, but the latest and greatest is sometimes very time-intensive with many distractions.

I have criticised “Discover” a long time ago and it has gotten only worse.

Speaking truth to power - like myself here - usually comes at a cost.

I actually have the impression, and that has nothing to do with this topic here or that board, that you have to come up with something extraordinary in order to be heard at all.
Probably because I don’t have a direct boss, which I actually think is very good for my development.

1 Like

You must be a mind reader :grinning: your reply is exactly what went on in my mind as I decided to post this. Let’s say that I have solved this problem and it does not involve Fedora…let’s slip away quietly into the night. …happy days…

Yeah, that’s what a lot of people say about me. (I’m kidding)

I’m currently thinking about that it’s possible that you are Stephen King in reality.
Writing literacy and a name that reminds of the scenes in his books.
I apologize, but English is not my mother tongue.

I began the Frontiers Saga a couple of days ago, mainly because I thought that there may be some room for improvement in not-technical English.

Are you referring to dnfdragora? It’s the only dnf front end that I’m aware of. dnf itself is purely a command line application. You can install dnfdragora using dnf:

sudo dnf install dnfdragora

More information on it here:

https://src.fedoraproject.org/rpms/dnfdragora

Discover, like Gnome-Software is a software installer for GUI applications:

So, it’ll allow one to install GUI applications, and Flatpaks etc (dnf doesn’t work with flatpaks at all).

This is probably EarlyOOM:

https://fedoraproject.org/wiki/Changes/EnableEarlyoom

The idea is that when a system is running out of memory, it’ll kill lower priority applications to ensure that critical processes can continue running. The wiki page includes information on how to disable it also (if you wish to).

This is probably because its cached state was out of date. I’m not entirely sure how this is updated—I think one can use the packagekit command line tool to update it:

pkcon refresh

Note that dnf and pkcon/Gnome-software/Discover do not use the same metadata or cache. So any of their data could be out of date and so incorrect. In that case, we must update their states ourselves.

@ankursinha In All versions of Fedora prior to Fedora 34, an “update” icon would show in the system tray, advising that updates were available (without Discover). Whatever caused this I don’t know. However I know that it was not dnfdragora-updater, because in previous versions of Fedora, after enabling the dnfdragora-updater, two dissimilar icons would show up in the system tray.

I don’t want to engage in a terminology fest.
If simply opening a Libreoffice document is sufficient to cause EarlyOOM, something is wrong with Fedora

Since it seems that going forward Discover is the new shiny thing. So be it.

As far as I am concerned, let’s close this topic and let’s all have a great day.

Hrm, this is unlikely. I’m not aware of the KDE spin shipping another software update tool. Discover has been their default for a while. We’ll need another KDE user to comment on this, though. Did you have Gnome installed too? That would pull in Gnome-software which is the same as Discover but for Gnome?

This is not a “terminology test”. One has to figure out what component is causing issues to be able to fix it. Discover cannot kill other processes.

Not really. It depends on the amount of memory you have. Without earlyoom, you’ll experience swapping which will slow your system down considerably. As I’ve noted, you can disable earlyoom to see if that “fixes” the issue. You can also look at your logs to see if earlyoom did indeed kill other processes.

https://docs.fedoraproject.org/en-US/quick-docs/viewing-logs/

Right.