Fedora 34 KDE I Cannot See SDDM

Hi. After days of tries, i installed NVIDIA drivers successfully. But sddm works pretty well until i installed NVIDIA drivers. Now i cannot see sddm but if i type my password, i can login and i can see sddm if computer wakes up from sleeep. I don’t know what’s happened ? Please help.
Btw for issue of NVIDIA, Thanks to @t0xic0der. Solved my problem.
Here is the link.

I don’t know anything about SDDM, but as a workaround, you should be able to use a different display manager (and still start KDE). GDM and LXDM are among a couple other options on Fedora Linux 34:

$ dnf search "display manager"
Last metadata expiration check: 23:42:12 ago on Mon 10 May 2021 08:02:44 PM CDT.
======================================================== Summary Matched: display manager =========================================================
gdm.x86_64 : The GNOME Display Manager
lightdm.x86_64 : A cross-desktop Display Manager
lxdm.x86_64 : Lightweight X11 Display Manager
nodm.x86_64 : A display manager automatically starting an X session
xorg-x11-xdm.x86_64 : X.Org X11 xdm - X Display Manager

You should be able to install and enable another display manager. For example:

$ sudo dnf install gdm
$ sudo systemctl enable gdm.service

You can view/verify which display manager is enabled with the following:

$ ls -al /etc/systemd/system/display-manager.service 
lrwxrwxrwx. 1 root root 35 Feb 17  2019 /etc/systemd/system/display-manager.service -> /usr/lib/systemd/system/gdm.service
1 Like

Aft after this how can I disable/remove SDDM?

Yeah, you can only have one display manager enabled. Having multiple display managers installed is harmless though. You might leave them both installed if you want to try re-enabling SDDM from time to time to see if a recent update has fixed it.

1 Like

Try the following, once you have an alternative display manager installed.

sudo systemctl disable --now sddm.service
sudo dnf remove sddm

EDIT - @glb Very correct. Blindly removing a package would remove its dependencies and other packages that depend on the said package, so it should be avoided at all costs - unless the user is knowing what they are doing.

1 Like

dnf remove anything -y scares me. I’d worry that it would remove KDE as an “unused” dependency. I’m probably overly cautious though. :slightly_smiling_face:

3 Likes

I tried:
LXDM = no response
Lightdm = no response
GDM = ok but it installed GNOME and if i switch to KDE, sound goes
Nodm = i didn’t try it
xorg = i didn’t try it

My current “sddm.service” file:

[Unit]
Description=Simple Desktop Display Manager
Documentation=man:sddm(1) man:sddm.conf(5)
Conflicts=getty@tty1.service
After=systemd-user-sessions.service getty@tty1.service plymouth-quit.service systemd-logind.service
StartLimitIntervalSec=30
StartLimitBurst=2

[Service]
ExecStart=/usr/bin/sddm
Restart=always
EnvironmentFile=-/etc/sysconfig/sddm

[Install]
Alias=display-manager.service

As I do not have a spare device lying around, it would not be possible for me to replicate your issue. Could you please go through the following discussions and see if they can be of any help?

  1. Generalize and test the tool in KDE Plasma spin · Issue #5 · t0xic0der/nvidia-auto-installer-for-fedora · GitHub
  2. dnf update failed : conflict vidia-kmod-common-3:440.95.01-1.fc29.x86_64 · Issue #44 · t0xic0der/nvidia-auto-installer-for-fedora · GitHub

These both issues are related to the KDE Plasma spin of Fedora, though the circumstances might differ.

1 Like

Sorry that GDM pulled in GNOME. It used to be a fairly stand-alone package, but a lot has changed since then.

If you are still interested in using GDM as a workaround, the sound problem might be something to do with the new PipeWire system. You might be able to work around that issue by reverting to PulseAudio until the problem gets fixed:

$ sudo dnf swap --allowerasing pipewire-pulseaudio pulseaudio

1 Like

Unfortunetly, my computer does not love pulseaudio :frowning:

Unfortunetly, This is not related my issue.

Well, there is a third option if neither PipeWire nor PulseAudio work for you. It is called the Advanced Linux Sound Architecture (ALSA). It is a lower-level sound system that is built into the Linux kernel and it is what the newer PipeWire and PulseAudio systems run “on top of”. It is more difficult to configure, but if neither of the other options will work, it might be an option. I’m using ALSA directly on my Fedora Workstation 34 right now because it currently has better support for surround sound on my HDMI port. Below is a guide that I found helpful when setting it up if you want to give it a try.

https://alsa.opensrc.org/DigitalOut

2 Likes

I think, i am using that ?


I am sorry for late response.

That tool does appear to be using ALSA directly. It might be necessary to add your user to the audio group. According to the Arch wiki, that shouldn’t be necessary however.

https://wiki.archlinux.org/title/Advanced_Linux_Sound_Architecture#User_privileges

I also spent 6 hours trying to fix gdm / SDDM crashes : “White Screen Of Death” telling you to relogin, which of course is futile.

gdm seems problematic to me.