Fedora 35 + X11 + HiDPI

I am using Fedora 35 under X11 on a typical 4K monitor / NVIDIA card and since there seems to be no support for fractional scaling in GNOME under X11, I have specified a screen scaling of 2 and then I modify the scaling upon a graphical login using the following script:

#!/bin/bash
/usr/bin/xisxwayland
if [ $? -eq 0 ]
then
echo “X server is Wayland”
else
echo “X server is not Wayland”
xrandr --output DP-2 --scale 1.5x1.5
fi

This works fine in the sense that it resizes the screen properly. However, I suspect that this scaling is software based because when the graphical environment becomes heavy, particularly when doing a Zoom with screen sharing, the performance goes down and any interaction with screen elements becomes laggy.

Under Wayland there is no such problem and fractional scaling is supported but I have other problems with Electron-based applications, including Zoom, which display empty windows without any content and I don’t think that these problems will be fixed any time soon. So, I was wondering if there is a way to achieve a 1.5 scaling on GNOME under X11 but of higher performance compared to the method I currently use.

Try this

gsettings set org.gnome.mutter experimental-features "['x11-randr-fractional-scaling']"

After that, if you head to the GNOME Control Center, you’ll be able to see both the 125% and 175% options now:

https://fosspost.org/fractional-scaling-between-windows-linux/

1 Like

Thank you for the tip but this command has no effect in my case. The GNOME Control Center panel on Display still allows the selection of the non-fractional scaling options of 100%, 200% etc. I believe that this option only works on Ubuntu and not Fedora 35.

Try this

https://github.com/burntcustard/x11-fractional-display-scaling

1 Like