Fedora 36 beta does not wake up after suspending, but Fedora 35 does

, ,

Hello,
I recently installed fedora 36 on my machine, but after I suspend, the computer won’t wake up, and I have to shut down my machine and power it on again to access it again. To see if the issue existed in Fedora 35, I burned it onto a live USB, and suspend works properly. I don’t know what causes this issue, so I can’t really properly file a bug report. Also, I’m new to fedora, so I don’t know what the right thing would be to do. I use a Acer Nitro 5 with a AMD Ryzen 5 processor.

1 Like

Welcome to :fedora:
Can you verify with a live usb with fedora 36 beta in it and try with live and suspend if that happens again in live you need to file a bug report in bugzilla.redhat.com
For additional info use inxi -Fxz
And add a copy of that here also in </>
Edit adding to that post
journalctl -b -1 and so on? Hopefully there will be something about the failing resume there.
Or post this journalctl --since="-5 minutes
This will be required for bug tracking but what i have said reporting bug is the next step but first try with a live usb with f36
I really understand you want to help fedora team with bug track. But still if you are new you should stick to 35 for now.

Be aware that Fedora 36 is not yet released. So if you currently use Fedora 36, you are using something that has still to be tested, and that is not ready for “daily use”. This version exists only so that experienced users and developers can test it before release.

If you are new to Fedora, I suggest to stick with Fedora 35 until 36 is released.

If you want to help testing Fedora 36 (which you should not do on a production machine), you have to get into topics like log files (journalctl) and such (very useful information for the bug report).

To explain “beta” version:

Hello, sorry for the long response, but thank you :slight_smile:. I tried f36 with a live USB, and it worked to suspend, but I don’t know if it was really properly suspending, because my laptop woke up much faster than it ever did with an installed os. To see if live USB’s just always worked and the issue was fedora when it was on the hard drive, I installed fedora 35 on my hard drive, and suspend/wake up worked. I then did a fresh install of fedora 36 to make sure the install was not broken for some reason the first time I installed it. Even after installing again, suspend/wake up would not work. I suspected that the issue was either with the kernel version or the display manager. Since the DM was easier to change, I switched it. I have always had issues with SDDM with gnome and the gnome keyring not starting, so I tried lightDM, because ubuntu used to use it a while ago. After changing it, I was able to suspend and wake up without issue! When I have time, I will try and switch the kernel to see if the issue has to do somehow with the interaction of the f36 kernel and GDM.

edit:
Oops! Apparently that was a fluke. I just tried to suspend again, and it would not wake up. The DM has nothing to do with this. Also, installing lightdm installed pantheon, and suspend in pantheon doesn’t work either, so I think this is a kernel issue I will try to switch the kernel though!

I installed kernel 5.15, and suspend now works!

1 Like

I had the same issue. I tried Fedora 36 and my laptop didn’t wake up after suspending. And now I’ve just returned to Fedora 35 which works fine.

1 Like

I have a feeling that kernel 5.17 is the culprit here. I have updated from F35 with suspend working fine and each time I use the default kernel from F36 my laptop won’t resume. If I switch to kernel 5.16 from F35 it resumes without issues.

As mentioned, F36 is a beta version that is not yet intended for production purposes. It is for testing to identify bugs and other issues in order to solve them before the release.

Therefore, the use of F36 beta is currently only reasonable when it involves filing bugs/issues in bugzilla:
https://docs.fedoraproject.org/en-US/quick-docs/howto-file-a-bug/

And of course to gather some insights of what is to come next - but in a beta version, you have to expect things like that.

1 Like

I think it’s fine to discuss and try to find solutions to beta[1] problems here. Those will sometimes correspond to things which should be filed as bugs (or are already!), but won’t always.


  1. and pre-beta, including rawhide! ↩︎

2 Likes

I’m having the same problem with kernel 5.17.3. My laptop (Thnkpad T14s AMD) won’t resume after suspend. If I boot 5.17.2 everything works as expected. It happens with both 5.17.3-300 and 5.17.3-302.

Hi Lluis, I’ve run a quick check on my laptop with Ryzen 5 3500U and after upgrading to 5.17.3-300 or -302 both seem to work fine.
A small side note - 5.17.3 resolved crackling microphone over BT for RTL8822BE.

Fedora 36 Workstation Edition on my ZBOX Mi646 won’t wake up after I execute the suspend action. I have to manually power it off (holding the power button), and then power it on again.
I’ve tried various solutions from the forums, EFI settings, etc… At the end same issue remains with Linux 5.17 and fresh install updated to 5.18.

For such a stable system, it is really senseless that this problem has already been dragged through several versions.

Additional info:
CPU: 11th Gen Intel Core i5-1135G7
GPU: Intel IrisXE (integrated) / using HDMI port
Kernel: 5.18.19-200.fc36.x86_64 #1 SMP PREEMPT_DYNAMIC Sun Aug 21 15:52:59 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux)
Memory: 32GB (2 x Kingston FURY Impact 16GB 3200MHz DDR4)
Storage: NVME Viper VPN100 512GB

The only version this problem this has been reported on here is 36. Since this thread was back from beta, it may have since been resolved. If you’ve had issues since before 36, then you likely have a different problem and should start a new topic.

Please read what you comment. I wrote that it is an issue on Fedora 36 Workstation Edition, kernel versions 5.17 and 5.18. Fedora 36 from beta until now still has mentioned issues when you try to use the suspend.

Hello @sergiojovanotti
I think that @vwbusguy was suggesting to start a new thread instead of bumping an old one dated back when Fedora Linux 36 was still in beta stage. Maybe your issue is different from this one (at least the hardware is[1]), maybe you could have better visibility instead of commenting (necroposting) on an old issue.



  1. yes, the topic is related to suspend issues, but in my experience since I started to use the computers, suspension has always been a magic topic :slight_smile: On some hardware it works out of the box, with some configurations it doesn’t, with some kernel versions it’s random, etc. The topic is always “suspension”, I don’t know what would be better: start yet another thread or comment on a similar one :slight_smile: ↩︎

2 Likes