Fedora 36 Gnome failing to play any video source

Hi, I have been looking for a solution to this problem all afternoon, After booting up I discovered that firefox is not playing youtube videos or videos from other streaming sources. I then tried playing video using mpv from my own catalog and videos will not play. Just a still image is displayed.
Ive tried, power cycling, updates, checking status of rpm fusion, installed vlc, i tried this (sudo dnf swap ffmpeg-free ffmpeg --allowerasing) and this (dnf groupupdate core).
I am obviously missing something important but unfortunately my knowledge isn’t great, Fedora works so well normally.

You’re likely missing audio/video codes.
rpmfusion provides all you need … see:

https://docs.fedoraproject.org/en-US/quick-docs/assembly_installing-plugins-for-playing-movies-and-music/

Enable rpmfusion free and non-free and then install vlc, which will pull in all you need.

1 Like

Hi,
thanks for the reply, I have the fusion repos setup, I have checked them as well, all installed correctly. I tried re-installing but this made no difference. The system has been setup for some time it is not new.
This was working yesterday without issue, today not.
Correction:
Ok so without re-booting everything started working, after 3 hours or so and several reboots. This just means the issue is going to be hard to reproduce.
Seperate but maybe related issue: fldigi is not loading and throwing an error.
Pulse Audio Error: Timeout
Is the server running?

thanks

1 Like

Have you checked that pipewire and wire plumber are running?

Hi,
thanks, yes it looks like pipewire is running, but then apart from fldigi deciding not to work video is now working.
I have no ideas, I may have to consider a clean install as I can not upgrade to 37 anyway.
Thanks for your suggestions,
Please consider this closed untill I get more info. Until I can repeat the problem I cannot fix it.
j

1 Like