Fedora 36 install randomly freezes/crashes/black screens on external SSD

OK, I will resort to 2 actions to troubleshoot:

  1. Install Cinnamon: if Fedora does not crash anymore, GNOME is the culprit.
  2. Plug the SSD into my old desktop, as an internal one, not a USB device. If Fedora still crashes, the problem is Fedora itself, not my hardware. If no crashes occur within 1h, my USB adapter is maybe to blame.

It may actually be a problem with the SSD firmware. It may support Windows normally but not Linux. For example my Kingston SSD had a firmware bug that would cause my Linux system to totally freeze. Back then I was a newbie and though that Linux isn’t good because it freezes for no reason. Months later I found that Kingston SSD manager had a firmware upgrade for my SSD that fixes SSD freezing on some Linux systems (fixed the problem for me).

Also on another laptop a bug in the SSD firmware causes the laptop to never be able to resume from sleep, unless you set the iommu to software.

SSD firmware bugs can cause wild issues and having it working in Windows does not mean that it isn’t the problem.

1 Like

I did do an SSD firmware for my internal one, that added copy on write support for btrfs. I will try this on my external SSD now. But Linux did not crash on another pc, where the SSD is connected via sata and not USB. The USB adapter may be the problem… Also I don’t think a cheap 50$ (not $$d LOL) can have it’s firmware updated?

EDIT: No firmware update found. After yet another crash, I checked Journalctl, which did not save logs in the minute before the crash… I still don’t know what processes fail. I can still move my mouse when the system freezes, if that helps.
I found when the journal crashed:
“Jun 26 20:19:34 fedora systemd-journald[268]: Journal stopped”
Why is the time the GMT time and not my system time, which is 2h earlier?

Try booting from a live USB and plugging that USB SSD and wait, do some I/O (read/write on the USB SSD) on it and keep checking the logs. Maybe the problem will be properly reported if it is saved to the live USB instead of the flawed USB SSD

I already tried copying a 30+gb file made of data from/dev/random. I did a hash of the file, moved it to my internal SSD, did another hash, and moved it back, did another hash. All three were the same. If the SSD corrupted the data, the hashes would be different.

Have you tried booting the Fedora of the USB SSD from another computer?

Since it is working with windows which is more I/O intensive than Fedora, I think it may be worth to reinstall Fedora. Backup your home then restore it after install, then only you will have to reinstall the applications. Maybe your installation is corrupted for some reason.

Very good point. The unfortunate truth is that I tried this once a week ago. Also Fedora didn’t crash in 4h on a 2011 i7 12gb ram Desktop. What is wrong with my pc??? Anyways Fedora seemed to be stabler on Cinnamon. I can try reinstalling Gnome.

Edit: ran the command to uninstall cinnamon while in cinnamon… Funny results!


Clicking on the apps still works though.

Was fedora made for aliens? I don’t understand this language :joy::upside_down_face:

Funny missing fonts you got there!

I can’t understand why you got critical processes like journald crashing for no clear reason. As a last resort try another Linux distro like Ubuntu and see if you get the same problems.

Well I ran some stability tests with… GIMP! (Creating a max size image and filling it with random pixels) and sometimes the test passes. Sometimes GIMP repeatedly crashes, then my other apps start crashing, until the whole shell freezes. After a minute of everything freezing up, I can’t even move my mouse! The ram wasn’t even 80 full and the temps were about 75c when System Monitor froze. Before this, they were weird bugs, like the inability to drag a window or to access the app library. The notifications panel was the last thing working. Why does high load cause such instability? On windows running a benchmark doesn’t make it BSOD.

Sorry but I have no more clues and I have finals soon so I couldn’t help in the near future. I hope someone else with more knowledge than me helps you out to sort the issue. (Or maybe take a shorter path and try another SSD?)

You can try disabling all powersaving features of USB buses, maybe it is entering a low power state and not resuming properly?

The SSD I bought was acquired for this purpose. I originally had a 120gb SSD. Thanks for helping me!

I actually found a “solution”: switch to LXDE. I tried generating fractals in GNOME but GIMP kept crashing. In LXDE it works fine.

The question has nothing directly linked to software, just connection of hardware between motherboard and distant local storage … external SSD usually have simple USB connection as used for data storage, not fast enough, try something else like USB-C.

My SSD is connected using a 5gbps usb type c cable, on a USB 3.2 gen 1 port. Anyways, slow storage is not the cause of this instability. I get 400 mbytes per second sequential read speeds. I suspect that my problem could be the sata to USB adapter not liking constant random read/writes. It also gets noticeably warm, even if 5mm of air and 1mm of plastic separates the chip from my finger.

Edit: I strongly suspect that the USB to sata link is the problem, as I tested the SSD on another computer, this time directly to a sata cable, and no crashes occured in 3h.

USB-C is different from USB 3, an operating system needs to read and write from the storage device used, different from containerized instance in memory, normal hardware setup uses SATA connection. Specific tailored software system used in IoT devices will work, completely different from full blown Linux desktop what ever apps installed.

When connected via usb C did you have additional power to the SSD or was it powered solely from the USB? It is possible that the USB to SATA adapter interface required more power than was available directly from the usb C port and thus was occasionally dropping out.

1 Like

I have some unrelated questions:
Did you expected a poping / cracking sound from the speakers when your Lenovo is rebooting/shutting down?
I have this problem on every linux distro and I have simmilar laptop model as yours.

Also I have question to your bios: did you update to GLCN48WW via Windows Update or by downloading .exe file from Lenovo website. I’ve heard about problem with this bios version and I don’t know if I should update.

No I don’t have a popping sound when rebooting. I updated my BIOS from Lenovo Vantage, not from the website nor from Windows Update. For the popping sound, I heard that on many laptops in the past and I just assume it’s a power surge when the MOBO powers on.

Maybe that’s the problem as my port is rated for 5v 0.5a and my SSD for 1 amp.

Bingo! I used a USB hub with an external power supply, did some benchmarks and my system didn’t freeze up! Thank you very much for all your support!

2 Likes