Fedora 36 KDE Live image freezes immediately on startup of new computer

Greetings,

The screen freezes when booting Fedora Scientific 36 (FS36) using a live image loaded from a USB stick. I can overcome this problem by running in ‘Safe Mode’, but this puts the screen resolution to 800x600.

I have not attempted to install FS36.

Is FS36 using the Wayland display server with KDE-Plasma? If this is so, would that combination (Wayland/KDE-Plasma) contribute to the instability I’m observation (as noted in Fedora System Adminstrators Guide: https://docs.fedoraproject.org/en-US/fedora/latest/system-administrators-guide/Wayland/).

Do you have any recommendations for edits to make when starting up FS36?

Thank you

1 Like

A live image is running in memory and will crash when you run out of memory, which can happen if you start doing major compiles, etc., so it makes sense that a lower resolution uses less memory and let’s you go a little longer. The live image is really for you to test the waters a little and get it installed, but isn’t exactly indicative of the full experience, especially in terms of performance.

1 Like

Thanks, Scott.

I should have mentioned that the freeze occurs immediately, i.e., I can see the graphical screen background, and the mouse cursor, but am not able to move the cursor.

1 Like

As I noted in the other topic, the scitech lab image is based on the KDE one. All it does is adds more packages to it, but it does not modify the KDE UI in any way (from what I can see in the kickstart).

So, this is likely an issue with KDE in general. What you can do to quickly confirm is try the KDE live image. I’d expect you to run into the same issue there.

https://spins.fedoraproject.org/en/kde/

If that does work, you can just install the packages you want there using dnf etc. Of course, you can also use a different desktop environment if you wish and install packages there—we just have to pick a desktop environment for the live media and the SciTech has used KDE for a long time so it remains.

There are also the updated ISOs that include all the updates, but they are not generated for all the lab images:

https://dl.fedoraproject.org/pub/alt/live-respins/

Thanks, Ankur. I learned quite a lot from your response!

I tried your suggestion to try the KDE live image and confirm the immediate freeze-up occurs for that one too. This is not a problem with FS36, but with the F36 KDE live image, at least on my computer*

I’m revising the Subject line accordingly. Thanks again!

*CPU:Intel Core i7 10700 @ 2.9 Ghz; RAM:16Gb; Motherboard:Lenovo 1048; Graphics Card:4Gb Nvidia Quadro P1000.

2 Likes

That makes sense. I guess the updated ISOs may be worth trying, in case it has been fixed already. Or of course, a different DE should work to begin with. It’s possible this is a nouveau issue and installing the proprietary Nvidia drivers fixes the freeze too:

https://rpmfusion.org/Howto/NVIDIA

2 Likes

For what it’s worth, I just did a fresh F36 KDE install last week with a Ryzen/Radeon setup and did not experience any freezes or crashes, so I also suspect it to be specific to the nvidia hardware here. You might consider installing it in basic graphics/safe mode, then updating your system, and then, if you still have issues (or if you just prefer the proprietary drivers), install the nvidia driver per @ankursinha 's link and then you’ll likely be good to go.

2 Likes

Thanks for all your help.

FYI, I’ve encountered the same immediate freeze-up loading F36 KDE live image via USB on the same computer but replacing the Nvidia Quadro P1000 with the base graphics provided by Lenovo (Intel UHD Graphics 630).

This appears to be a relatively common issue with F36 KDE, at least when loading the live image via USB.

I think my best bet is to load/install the proprietary Nvidia driver after having installed KDE in graphics safe mode.

1 Like

I could not boot into F36 Gnome DE without the very same issue after installing to hdd.

What I did was editing a custom.conf -file in /etc/gdm with this content:

[daemon]
# Uncomment the line below to force the login screen to use Xorg
WaylandEnable=false
DefaultSession=gnome-xorg.desktop

Not sure, if KDE uses GDM, though… just thought it might possibly be helpful.

It did the trick for me in Gnome42. With KDE the display manager is or was(?) called KDM.

@admins: Feel free to remove this post, if irrelevant. Thank you.

Today, the KDE spin and Kinoite work with SDDM.

1 Like

Thanks, Scott.

I’ve installed the proprietary Nvidia driver by following How to Install NVIDIA Drivers on Fedora 36 Linux - LinuxCapable. Unfortunately, the Nvidia driver doesn’t load, and GRUB says that it’s falling back to the nouveau driver.

I think the reason for this is that SecureBoot is enabled on my computer* which means that steps may need to be taken, e.g., signing the Nvidia driver with a private key, when installing that driver.

Via ‘modprobe nvidia’ the following appears:

modprobe: ERROR: could not insert ‘nvidia’: Key was rejected by service

If modprobe is supposed to be run to install the nvidia driver, how come this step isn’t included in the above link?

Thanks,

Lyman

*I’d prefer to retain SecureBoot as this is how the computer was delivered.

I believe the above question has been answered.

In summary, I was not able to boot the F36 KDE live image at the desired resolution; the screen immediately freezes even before logging in. The only way I found to overcome the freeze-up was to enter the lower resolution rescue mode.

Thanks!

That error makes sense then. The good news is there’s a way to have your cake and eat it, too. You’ll need to sign the nvidia kernel module with a key you’ll also give to your BIOS and then it should work. Here are the general docs for doing that.