Fedora 36 KDE - Suspend issues with Bluetooth Enabled

Hello All
Thanks for Fedora 36… I am running the KDE spin on a Lenovo X1 Carbon Gen 8 with the latest BIOS updates. Everything works fine with Fedora except if bluetooth is enabled 80% of the time it will not suspend and it will stay powered up. If I open the lid I can see that the computer is still on. If I disable bluetooth the suspend operation works perfectly all the time. So I have been getting in the habit of disabling bluetooth before I close the lid. But the other day I forgot and when I pulled my laptop out it was extremely hot to the touch since it was on the whole time.

  • journalctl shows the lid open and lid close events properly so it is being detected.
  • BIOS is set to Linux which is S3. However, I have tried both settings (Windows & Linux) with the same results.
  • I was running OpenSuse Tumbleweed before Fedora and did not have this issue with the latest kernel, etc.

I am curious if others are having this issue or if their might be a fix.

Thanks everyone and I appreciate this awesome distro
Dave

Welcome to ask :fedora:edora

This you best check on your own on the https://bugzilla.redhat.com/ page.
You can log in with the accounts.fedoraproject.org , and also config a separate email if you want to participate on the bugzilla site.

If you want to compare with other Linux distributions you need at least tell us which kernel versions you used on both distributions. Kernel is changing often, so there is no comparison possible.

Have you checked the the power-saving options if you can switch off automatically Bluetooth when hibernate/suspend?

This would be a workaround till fixing the issue.

Thanks for your reply. Apparently someone with a Gen 9 X1 carbon is having the same issue.

https://bugzilla.redhat.com/show_bug.cgi?id=2069499

I tried some of the suggestions in the post regarding changing “Disable Always On” in the BIOS but that does not help. It does appear related to a kernel issue but I really do not know.

I was on the latest tumbleweed up until a couple weeks ago and that was kernel 5.17.x and it did not seem to have this issue.

Anyway Thanks for the response I will wait it out to see if it gets resolved…Perhaps in 5.18 or sooner.

I have this problem, on Fedora 36 Gnome, with my Intel SkullCanyon NUC. I just tried kernel-5.18.1-200.fc36 from koji, but it didn’t help.

In my case, the following workaround avoids the problem:

cat <<'EOF' | sudo tee /lib/systemd/system-sleep/bluetooth-suspend
#!/bin/bash
if [[ $1 = pre ]]; then
    btmgmt power off
elif [[ $1 = post ]]; then
    btmgmt power on
fi
EOF
sudo chmod +x /lib/systemd/system-sleep/bluetooth-suspend
1 Like