Fedora 36: Occasional crashes on system startup

Hi there,

the Fedora Linux 36 KDE on my laptop occasionally crashes during system startup after I have entered the hard disk encryption password.

Operating System: Fedora Linux 36
KDE Plasma Version: 5.25.5
KDE Frameworks Version: 5.97.0
Qt Version: 5.15.5
Kernel Version: 5.19.8-200.fc36.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i5-6300U CPU @ 2.40GHz
Memory: 7.7 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 520
Manufacturer: Dell Inc.
Product Name: Latitude E5270

Symptoms:
After entering the disk encryption password, in about half of all boot attempts the system takes a few seconds to proceed to login manager asking for my system password, fine.

But sometimes the login does not appear. The screen stays black and the system seems to fall into some kind of sleep mode. Occasioally the power light flashes slowly to indicate sleep mode, once I even managed to wake it by pushing Esc, but usually the power light stays on but nothing else happens.

The only way out then is to push the power button. then it takes about 1 second for the DELL and fedora logos to reappear and the system to shut down.

This problem does not seem to be caused by the electricity source, it happens when running on battery as well as adaptor power. It does not seem to depend on whether I entered the disk password correctly either.

At the Berliin Linux Users Group we copied some journals and core dumps, here they are:
https://nextcloud.totux.de/index.php/s/x9mJGPcF4H4zfJM

Greetings,
Bernd