Fedora 37 Beta Gnome. No wifi Auto/2.4/5GHZ drop down selection

Doesn’t appear to appear on the network wifi panel.

So how else can I control this setting ( as I’m trouble shooting and can’t connect to the net from the problem system).

And where is the disconnect from WIFI network button? Seems very well hidden! At the moment I have to forget one wifi to join another! Is this correct?

Forget is not necessary. Simply connect to a new wifi AP and the last one will be disconnected but remembered.

The connection itself determines if it is 2.4 or 5 GHz. If using the same SSID for both bands on the AP then it is a crap shoot to determine which is used. If you give each band a distinct and unique SSID name on the AP then the SSID you connect to will determine the speed used.

It’s in the panel on the top right. Click on the SSID, not the “>” arrow next to it.

Fedora37-wifi

Disconnecting is necessary because I might not be connecting to a new Wifi router (for some time) or an ethernet on the same subnet. (Granted that is different from what I originally said)

There is an issue with the Atheros driver that prevents it from connecting to a router that uses the same SSID for both 2.4 and 5GHZ bands. The two suggested solutions are rename one of the bands on the router or specifically select the band on the client.

I would like to test the later because changing the router is beyond my control.

Anyway kudos to Scott for showing me the disconnect button. Never would have found it!!!

1 Like

The button with the “SSID” isn’t actually the disconnect button. It’s the disable Wifi button and so turns off all connections.

So apparently there isn’t a disconnect button that I can find!