Fedora 37 Error - Activation: failed for connection (For Wired etho connection)

Since upgrading to Fedora 37 my wired connection, which is ran through USB-C to a Dell docking station, has quit working on my Dell Precision 5530 Laptop. It keeps failing to activate on the wired connection and then will eventually go to the toggled off position in network manager. How to I fix/resolve/repair? Is this a driver issue? Any thoughts or assistance is appreciated.

See uname, neofetch and journalctl info below

Linux fedora-precision 6.0.12-300.fc37.x86_64 #1 SMP PREEMPT_DYNAMIC Thu Dec 8 16:58:47 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

Running: journalctl -f -u NetworkManager.service

shows this:

Dec 12 07:43:49 fedora-precision NetworkManager[1041]: <warn>  [1670849029.7545] device (enp58s0u1u4): Activation: failed for connection 'Wired_Fedora'
Dec 12 07:43:49 fedora-precision NetworkManager[1041]: <info>  [1670849029.7549] device (enp58s0u1u4): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Dec 12 07:43:49 fedora-precision NetworkManager[1041]: <info>  [1670849029.7694] dhcp4 (enp58s0u1u4): canceled DHCP transaction
Dec 12 07:43:49 fedora-precision NetworkManager[1041]: <info>  [1670849029.7694] dhcp4 (enp58s0u1u4): activation: beginning transaction (timeout in 45 seconds)
Dec 12 07:43:49 fedora-precision NetworkManager[1041]: <info>  [1670849029.7694] dhcp4 (enp58s0u1u4): state changed no lease
Dec 12 07:43:49 fedora-precision NetworkManager[1041]: <info>  [1670849029.7704] policy: auto-activating connection 'Wired_Fedora' (5a144239-9bf5-3604-8d70-03a666bfa652)
Dec 12 07:43:49 fedora-precision NetworkManager[1041]: <info>  [1670849029.7708] device (enp58s0u1u4): Activation: starting connection 'Wired_Fedora' (5a144239-9bf5-3604-8d70-03a666bfa652)
Dec 12 07:43:49 fedora-precision NetworkManager[1041]: <info>  [1670849029.7709] device (enp58s0u1u4): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Dec 12 07:43:49 fedora-precision NetworkManager[1041]: <info>  [1670849029.7711] device (enp58s0u1u4): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Dec 12 07:43:49 fedora-precision NetworkManager[1041]: <info>  [1670849029.7794] device (enp58s0u1u4): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
Dec 12 07:43:49 fedora-precision NetworkManager[1041]: <info>  [1670849029.7799] dhcp4 (enp58s0u1u4): activation: beginning transaction (timeout in 45 seconds)
Dec 12 07:43:49 fedora-precision NetworkManager[1041]: <info>  [1670849029.7837] dhcp4 (enp58s0u1u4): state changed no lease
Dec 12 07:43:49 fedora-precision NetworkManager[1041]: <info>  [1670849029.7900] dhcp4 (enp58s0u1u4): state changed no lease
Dec 12 07:43:51 fedora-precision NetworkManager[1041]: <info>  [1670849031.7960] dhcp4 (enp58s0u1u4): state changed no lease
Dec 12 07:43:55 fedora-precision NetworkManager[1041]: <info>  [1670849035.8010] dhcp4 (enp58s0u1u4): state changed no lease
Dec 12 07:44:03 fedora-precision NetworkManager[1041]: <info>  [1670849043.8078] dhcp4 (enp58s0u1u4): state changed no lease
---------------------- 
      .;cccccccccccccccccccccc;.         OS: Fedora release 37 (Thirty Seven) x86_6 
    .:cccccccccccccccccccccccccc:.       Host: Precision 5530 
  .;ccccccccccccc;.:dddl:.;ccccccc;.     Kernel: 6.0.12-300.fc37.x86_64 
 .:ccccccccccccc;OWMKOOXMWd;ccccccc:.    Uptime: 45 mins 
.:ccccccccccccc;KMMc;cc;xMMc:ccccccc:.   Packages: 1926 (rpm), 12 (flatpak), 7 (sna 
,cccccccccccccc;MMM.;cc;;WW::cccccccc,   Shell: bash 5.2.9 
:cccccccccccccc;MMM.;cccccccccccccccc:   Resolution: 1920x1080 
:ccccccc;oxOOOo;MMM0OOk.;cccccccccccc:   DE: GNOME 43.2 
cccccc:0MMKxdd:;MMMkddc.;cccccccccccc;   WM: Mutter 
ccccc:XM0';cccc;MMM.;cccccccccccccccc'   WM Theme: Adwaita 
ccccc;MMo;ccccc;MMW.;ccccccccccccccc;    Theme: Adwaita [GTK2/3] 
ccccc;0MNc.ccc.xMMd:ccccccccccccccc;     Icons: Adwaita [GTK2/3] 
cccccc;dNMWXXXWM0::cccccccccccccc:,      Terminal: gnome-terminal 
cccccccc;.:odl:.;cccccccccccccc:,.       CPU: Intel i9-8950HK (12) @ 4.800GHz 
:cccccccccccccccccccccccccccc:'.         GPU: NVIDIA Quadro P2000 Mobile 
.:cccccccccccccccccccccc:;,..            GPU: Intel CoffeeLake-H GT2 [UHD Graphics  
  '::cccccccccccccc::;,.                 Memory: 4107MiB / 31776MiB

Well…not sure why this is happening after upgrading. BUT…if I just enter a static IP on my NIC for wired, it works? Which makes sense given the error that it isn’t activating and pulling DHCP. Which is fine for a work around since there isn’t an actual RJ45 port on this DELL, so I primarily use it wireless unless I’m using my home docking station with wired across USB-C.

Still strange, why did this work fine on Fedora 36?

after setting wired as static

Dec 12 08:01:55 fedora-precision NetworkManager[1041]: [1670850115.8897] policy: auto-activating connection ‘Wired_Fedora’ (5a144239-9bf5-3604-8d70-03a666bfa652)
Dec 12 08:01:55 fedora-precision NetworkManager[1041]: [1670850115.8908] device (enp58s0u1u4): Activation: starting connection ‘Wired_Fedora’ (5a144239-9bf5-3604-8d70-03a666bfa652)
Dec 12 08:01:55 fedora-precision NetworkManager[1041]: [1670850115.8910] device (enp58s0u1u4): state change: disconnected → prepare (reason ‘none’, sys-iface-state: ‘managed’)
Dec 12 08:01:55 fedora-precision NetworkManager[1041]: [1670850115.8919] device (enp58s0u1u4): state change: prepare → config (reason ‘none’, sys-iface-state: ‘managed’)
Dec 12 08:01:55 fedora-precision NetworkManager[1041]: [1670850115.9141] device (enp58s0u1u4): state change: config → ip-config (reason ‘none’, sys-iface-state: ‘managed’)
Dec 12 08:01:55 fedora-precision NetworkManager[1041]: [1670850115.9197] device (enp58s0u1u4): state change: ip-config → ip-check (reason ‘none’, sys-iface-state: ‘managed’)
Dec 12 08:01:55 fedora-precision NetworkManager[1041]: [1670850115.9510] device (enp58s0u1u4): state change: ip-check → secondaries (reason ‘none’, sys-iface-state: ‘managed’)
Dec 12 08:01:55 fedora-precision NetworkManager[1041]: [1670850115.9512] device (enp58s0u1u4): state change: secondaries → activated (reason ‘none’, sys-iface-state: ‘managed’)
Dec 12 08:01:55 fedora-precision NetworkManager[1041]: [1670850115.9516] device (enp58s0u1u4): Activation: successful, device activated.

There is a discussion ongoing about hardware who was available in F36 an not anymore in F37 (alias in older kernel and in newer not anymore).
If you want to debug please do the following as described in:

Please post your outputs here because your case could be slightly different as you might used a Offical Workstation iso ?!
If you go on debugging please take also out your solution/workaround you marked.

Well, it seems the issue was likely related to something networking on my end. I have a business class network setup at my house and I think the issue was related to a hostname/MAC conflict with IP reservations that I had. Once I cleared out the reservation and removed my static IP that I had set back to DHCP, it connected fine.

SMH @… “me”. :slight_smile: i am going to resolve this a fixed.

So my 2c is: If you get this error with the inability to connect (Activation failed for connection) AND you determine that it is either wired or wireless, to make sure that you don’t have any duplicate MAC addresses tied to different hostname’s with IP reservation. I assume most probably won’t have this issue, but it’s just relevant to check. You could test this out by setting a static IP on your NIC (wired or wireless, depending on where you have the issue). If that resolves your issue then you likely have a DHCP issue for one reason or the other, like I did. It was strange for me because this coincided with my upgrade from F36 → F37…I just happened to change my hostname at the same time shortly after.

@jrabbott34 @ilikelinux

Hi guys

I have decided to give up on using Fedora at the moment and may consider resume with the next iteration, possibly Fedora 38 or 39.

I’d like to take this opportunity to send my best wishes of the season to you and your loved ones.

1 Like