Fedora 37 on Raspberry Pi 4

I’m running the new Fedora 37 on a Raspberry Pi 4 with the nice Argon One case - see Argon ONE V2 Case for Raspberry Pi 4 – Argon 40 Website Store.
In order to get the fan control and power button features provided by that case working, the following three interfaces need to be provided by the OS according to https://gitlab.com/DarkElvenAngel/argononed/-/issues/9: /dev/i2c-1, /dev/gpiochip0 and /dev/gpiomem. While the first two of those already exist (in order to get /dev/i2c-1 I just had to install the package i2c-tools and add a line ‘dtparam=i2c_arm=on’ to the file /boot/efi/config.txt), /dev/gpiomem is still missing though.
Does anyone have any idea how to get /dev/gpiomem on Fedora 37?
Thank you very much in advance!

Welcome to ask.fedora @gkjakob

Reading carefully would help you to see how to install the gitlab app … it says you shuld check:
Tree 0.4.x, there fedora-iot appears.

Files · 0.4.x · DarkElvenAngel / Argon One Daemon · GitLab

Thank’s for your reply!
Prior to my post I had already carefully read the advices given at DarkElvenAngel / Argon One Daemon · GitLab and did indeed check the tree 0.4.x. However I ran into the same problem documented at Experimental Support : Fedora-Server 37 (aarch64) (#45) · Issues · DarkElvenAngel / Argon One Daemon · GitLab, namely that the power button feature does not work. Unfortunately, this issue has been marked as closed without a (working) solution existing.
The reason why I was asking how to get the /dev/gpiomem interface on Fedora 37, is because I had noticed that this device exists “out-of the-box” when running a Raspberry Pi downstream kernel (in contrast to the 6.0.x upstream kernel being used by the latest Fedora distribution).

1 Like

Try this:
https://copr.fedorainfracloud.org/coprs/kwizart/kernel-longterm-5.15/
Check if you have gpiomem available.

As long as it not works with V6.0.x

P.S. i will put the server tag, so might be the server teem gets a look on it too.

Unfortunately, this kernel does not even boot through on my raspberry pi 4 with the /boot/efi/config.txt provided with Fedora 37. As far as I remember, only upstream kernel series later than 5.15 have received v3d support , which is essential for one of the main functions of the Raspberry Pi 4.

Thanks for tagging us. But for this kind of issues, I recommend to contact the ARM SIG directly. Did you already try their mailing list?

1 Like

Ok then, here is the page to the ARM-SIG list … please check also the archive. It looks like there are already some issues with F37

https://lists.fedoraproject.org/admin/lists/arm.lists.fedoraproject.org/

On the bottom of this page https://arm.fedoraproject.org/ are links to wiki and libera chat.