Fedora Account System and Bugzilla Mismatch

I created an account at the Fedora Account System to be able to follow the development of a given Fedora package.

The account has been created and works, but every day I get an e-mail whose subject is “Fedora Account System and Bugzilla Mismatch”, asking me to create a bugzilla account. It even states at the end of the message:

Note: this message is being generated by an automated script. You’ll continue getting this message until the problem is resolved. Sorry for the inconvenience.

Well, I then tried creating a bugzilla account. I entered my e-mail address, then received an e-mail with a link, then entered a password and tried creating my bugzilla account. But whenever I do it, I get the following error:

An unexpected error occurred. This could be a temporary problem, or some code is behaving incorrectly. If this problem persists, please email this page to bugzilla-owner@redhat.com with details of what you were doing at the time this message appeared.

URL: http://bugzilla.redhat.com/token.cgi?realname=&a=confirm_new_account&t=4wBF1wKJYW

 An error occurred while performing a database operation:

DBD::Pg::db do failed: ERROR:  insert or update on table "profiles_activity" violates foreign key constraint "fk_profiles_activity_who_profiles_userid"
DETAIL:  Key (who)=(458030) is not present in table "profiles". [for Statement "INSERT INTO profiles_activity
                          (userid, who, profiles_when, fieldid, newvalue)
                   VALUES (?, ?, NOW(), ?, NOW())"]
<pre>
 at /var/www/html/bugzilla/Bugzilla/User.pm line 2680.

</pre>

I waited for several days and tried again, but no success. I even sent an e-mail to bugzilla-owner@redhat.com as suggested, and received an automated reply, but several days have passed. I’m still receiving the “mismatch” e-mail every day, and I see no progress otherwise.

1 Like

Hiya,

Are you able to login to bugzilla with your FAS?

The mismatch indicates that the e-mail you’ve used in your FAS is not the same as the one you’ve used in bugzilla—they’re meant to be the same. Can you try logging in to bugzilla with the e-mail address you’ve used in FAS to see if that works? You may need to use “forgot password” to get a password etc.

I’m not sure of the error. The Fedora community does not manage the Bugzilla instance so the Fedora Infrastructure team cannot help here. It is managed by Red Hat. I’ll see if there’s a way of getting in touch with them someplace else.

I don’t have a bugzilla account (“Red Hat Bugzilla could not map your Fedora Account System account to an existing Bugzilla account”), and trying to create one leads to the error I mentioned, so I cannot do it.

Sometimes I forget to dissociate between Fedora and Red Hat, so sorry about the confusion.

Red Hat bugzilla account creation seems to be frozen at this point, so I need to disable/delete my FAS account, or at least remove the association to my e-mail, to avoid receiving these e-mails everyday.

Should I post a new question concerning that?

Currently, I could not find a way to do it. The Fedora Wiki says:

Account Termination

Voluntary

If you wish to deactivate your account for some reason, simply edit your account to remove all personal information, and mark the account as “Inactive.”

I could not do this: if I try to remove my name or e-mail, when clicking Save I get:

Error!

The following error(s) have occurred with your request:

human_name: Please enter a value

email: Please enter a value

So I cannot delete them, and therefore I cannot click “Inactive”.

Hrm, I’d file an issue with Fedora infrastructure for this particular bit. I think they run a script that links FAS accounts to Bugzilla so maybe that didn’t work. In any case they may be able to shed some light on this or direct us to the right people.

https://pagure.io/fedora-infrastructure/issues

For clarity, could you state what you’ve done till now? You said you wanted to follow the development of a given Fedora package: how were you doing this? Did you click “watch” on src.fedoraproject.org or something of the sort?

You don’t need to delete your FAS account. I don’t see how that’ll help, since the issue seems to be on the Bugzilla side of things. I’d set up a filter to send these e-mails to a different folder for the time being, so that they don’t add noise to your general mailbox.

Not sure about this bit. Haven’t tried to deactivate my account yet :slight_smile:

Sorry, I forgot to come back here and reply.

About one month after I tried creating my account, I got contacted by someone from Red Hat who manually created my account, and now it’s working.

2 Likes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.