Fedora ARM 64 Does Not Work On Raspberry Pi 4

Well, doing as you did, I used the same tool as you did. However…

I still get nothing but a black screen right after the boot sequence completes. On the serial console I get a login prompt, on the HDMI monitor after GDM service start., nothing on the HDMI monitor, in fact my monitor reports NO SIGNAL after about 30 seconds. The serial console shows a bit more services starting and the following, with a login prompt is:

[ OK ] Finished systemd-user-sess…ervice - Permit User Sessions.
Starting gdm.service - GNOME Display Manager…
Starting plymouth-quit-wai… until boot process finishes up…
[ OK ] Started rpc-statd-notify.s…m - Notify NFS peers of a restart.
[ OK ] Started gdm.service - GNOME Display Manager.

This is on the same hardware setup, that I can use Pi OS 11 ARM64, Manjaro ARM64, Ubuntu ARM64, SparkyLinux ARM64, and Kali ARM64, without issue. If it was a hardware issue, surely at least some of these other distributions would fail in like manner in some way.

To be sure, I have also tried multiple different SD cards, multiple Pi4B devices, etc., Still can’t get Fedora 37 ARM64 image as noted above to display any UI on the HDMI monitor. I see the same boot sequence you do, the same start up sequence you do, but I never get the HDMI monitor display result you do.

Is there any thing I can tweak or change in the config.txt file to force the HDMI configuration to a ‘safe’ mode, or set the Fedora image to a safe mode type of state? At this point open to suggestions, but have come full circle. In my case, Fedora ARM64 Does not work on Raspberry Pi 4, when other OSes work fine.

Did you press the esc key on a usb connected keyboard about 15-20 seconds after applying power?
My Pi first displays the multicolored screen then goes black. After a few seconds time it displays the grub boot menu (in text) and continues booting with a black screen.
Waiting 15-20 seconds them pressing the esc key (sometimes twice) starts the text display of the boot messages so I can watch the boot progress. I do not have a serial console attached, nor anything except the keyboard and mouse attached to usb.

I doubt it is hardware related.
If using the serial console it seems quite probable that fedora sees the serial console and does not fully configure the graphics. Once again, when installing the workstation version, it is designed to boot to graphics mode only and if the serial console is connected that may be interfering.

I cannot see exactly what you are doing but I used a monitor attached to HDMI port 1, and USB connected mouse and keyboard. In that manner everything just worked for me to boot to the graphics desktop.

I think this may be caused by how you are connecting and not either the image or the hardware.

Oh, I needed to give you the link that seemed incorrect…

A Fedora ARM image from: https://arm.fedoraproject.org/. At this link (from the official Fedora documentation page) there is no Pi ARM image to download. So this link is wrong IMHO. I can not use this link to download the actual Fedora 37 Pi 4 Image.

The Fedora workstation link on the above link is for image 36, not image 37. The raw link is below, that illustrates my assertion that the official documentation needs to be updated.


Just for reference…

So, no video signal at all coming out of the Pi when Fedora 37 image used, even with the tool recommended to be used, there IS VIDEO during boot, during services start, but once the serial console (and HDMI monitor) show GDM started, the HDMI monitor goes blank. The serial console goes until it demands a login. The Pi is clearly booted up, the image is working, since SSH is working and Pi can be pinged on its IP address. But no HDMI monitor video signal. This suggests that there is a driver issue, or such, with the Fedora 37 image in some way.

Suggestions on what to try next? Is there a text only mode for the Fedora configuration sequence? That might let the configuration sequence be completed without relying on a high resolution KMS driver, or such?

Rereading you comments above… This setup unchanged works with Pi OS 11, and other OSes. I do see the boot sequence, I do see the grub menu, I see the services start. I do see the Pi typical hardware boot (multi color screen).

I have tried all of the above without the serial console connected. You raised a good question on that.

I have HDMI to port 1 (next to power), USB keyboard and mouse. So I think we are on common ground there. Of course, ethernet connected as well (you did not mention that).

Oh, thanks for the testing and suggestions, I do appreciate it.

I know this sounds odd… but I think I have another monitor with HDMI, I just need to grab it from another location in the house. But as you noted, I don’t think it is hardware. :slight_smile:


Try the default config.
monitor attached to HDMI 1
Keyboard and mouse to USB

Then let us know the result.
This will test my theory that the attached serial console is interfering with graphical boot.

If ssh is working then it would appear something has been modified in the boot image. Fedora does not enable sshd by default, and even if they did it would require a user account to be able to connect. The Pi does autoconfigure the network if ethernet connected, but wifi does not get configured until the first-boot setup process.

Are you installing the vanilla workstation image or is it somehow modified before install and boot? If modified then yours is different than mine and I can help no further. If not altered then please test it as I stated above.

Oh… sorry that is my miss-statement… serial console is working not ssh.

Sure, I will try with out serial attached. I am installed the image unchanged in the last series of tests. A day or so ago, I tried hdm_safe=1 thinking that might work as it does with other OSes until you explicitly set the hdmi_mode. But the current HDMI monitor works with default settings with other OSes. The very last test, when I used the recommended tool to copy the image to SD card, was complete unchanged, straight from download.

I am going to create a new SD card as well, so will take a bit. I will ensure, HDMI monitor connected to port 1 (next to power), USB keyboard and mouse only. Cross my toes… we get it to work!

Remember, Do not panic if it goes to black screen with no spash or spinner. That is when I used the esc key to see the progress. Be patient and it should boot.

Right. Panic is when the power is turned on and nothing happens. LOL That has never been an issue here. If this turns out to be some odd bug with the video driver or such, that ONLY I had the joy of finding? So be it.

One has to have something to do, while watching all the World Cup 2022 round of 16 games!

Just for validation, I doubled check the sha256 sum for the image file, it does match the official sum value, so the image I am using is valid. Just dotting eyes and cross tees.

Just for confirmation, on a Pi4B the HDMI ports are label ‘0’ and ‘1’, do you mean HDMI 1 as HDMI ‘0’ i.e. the HDMI port closest to power? Or do you mean literally HDMI 1 as HDMI ‘1’ the HDMI port closest a/v (audio jack?

Turns out, the boot works on either HDMI 0 or HDMI 1, I tested this with Pi OS 11 and the Fedora 37 image. Regardless of the HDMI port used, on the Fedora image, I see the boot, see GRUB menu, see the ‘Booting…’ message, if I hit the escape key, I see the ‘classic’ 3 dots animation, then the screen goes black and nothing more. If I never hit the escape key, I see the various services start, OK, OK, etc., and then I see the GDM start, then nothing but black screen. After either the start services sequence, or the classic 3 dots animation the result is a black screen, and if I leave the Pi4B alone, after about 30 seconds my HDMI monitor reports No signal, and after 5 minutes HDMI monitor goes into sleep mode, which it only does when it receives not communication.

This is with only HDMI monitor connected, USB keyboard and mouse.

I have an HDMI Y adapter, I am going to try to record the video sequence as it happens, and upload it here, if that would help further research on this. Or I think I could setup my phone and record the sequence that way as well. Which ever works, I will do. At this point, not sure what else to try. This really does seem to ‘feel’ like a driver issue, even if it turns out to be otherwise at some point.

Then you power the Pi off and back on and wait again.

I mean the HDMI port closest to the power. (HDMI 0).

I usually have to press the esc key at least twice before I get any display.

Your Pi may be at a different firmware level than mine. I have not updated it for a couple years, but it does boot with F37 properly.

Good question, I have updated the firmware recently. I will document it and publish it here. Yes, I did have to hit the ESC key a couple of times to get the classic 3 dot screen, versus the services start details. Mine always seems to default to the services start detail.

I have tried two other Pi4B devices, but all have recent firmware. And one or two I have had different boot loader images, testing boot to USB disk, PXE, but all are currently set to boot to SD card.

Thank you very much for assisting with this. I have contact with the Raspberry Pi team on Github, and will outline what we have documented here, give them the link, and see if they can suggest something.

What is REALLY ODD to me, is that it is only the Fedora 37 image that is having an issue, Pi OS 11, etc. as I noted above, all work. Of course, Fedora 37 is new, so there maybe something odd lurking, I just happen to trip over.

As I recall only image 37 supports Pi right? The two questions maybe the Fedora team can respond to?

  1. Is there a different setting or something in the config.txt file I can change or set, to change the video mode attempted? Low resolution, bump up GPU memory split? Whatever?

  2. Is there a text mode or Lite version of Fedora 37 we could enable or set, that would let us get into the OS, so we could query the software/hardware for clues to this? I would love to be able to see dmesg for example.

When the grub menu displays you have a second or 2 where a key will stop the boot. Then you can edit the grub boot part for the kernel the same as on other fedora machines. Maybe adding nomodeset to the line beginning with linux would help. Have not tried that since other than a black screen during boot mine seems to work.

It is late and I need to sleep. Will see how much progress was made tomorrow.

@computersavvy, Yeah, it is not that late here… on the West Coast. Thanks again.


I just tried the editing of the boot command line, but the editing commands are not working as expected. I have used GRUB many times, and have done before just what you are suggesting, many times, so fully understand the direction you are suggesting.

But I have no cursor at all, so appear to have no cursor control, for some reason once I hit edit (e) key. In fact, grub is not in the right video mode, or character set… the line graphics all look like odd characters, I noticed before but did not mention it. Does that match what you see?

If this is not what you see, then that might be a clue? Even GRUB is having issues with the video configuration on the Pi?