Fedora Boot Problem

Hello ,
After i install fedora to hard disk i remove flash disk and restart but system go directly to windows 10
not let me choose which system i would run
when i open boot options i see boot from only
1- Hard
2 - usb
No From Fedora
My boot type UEFI

Did you create a boot partition at /boot/efi with FS EFI partition or FAT32?

One of the ways of checking this out would be using the same live USB you used to install Fedora to go back into the live environment to check on the partitions you modified/created.

it is FAT 32

What is your disk / partition layout before and after Fedora installation?

1 Like

how i can know it ?

layout now simple type basic

You can boot use a Fedora LiveCD, then open a Terminal, and check the following outputs:

#lsblk

1 Like

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
loop0 7:0 0 1.8G 1 loop
loop1 7:1 0 7.5G 1 loop
├─live-rw 253:0 0 7.5G 0 dm /
└─live-base 253:1 0 7.5G 1 dm
loop2 7:2 0 32G 0 loop
└─live-rw 253:0 0 7.5G 0 dm /
sda 8:0 1 29.3G 0 disk
└─sda1 8:1 1 29.3G 0 part /run/initramfs/live
zram0 252:0 0 4G 0 disk [SWAP]
nvme0n1 259:0 0 953.9G 0 disk
├─nvme0n1p1 259:1 0 300M 0 part
├─nvme0n1p2 259:2 0 128M 0 part
├─nvme0n1p3 259:3 0 261.1G 0 part
├─nvme0n1p4 259:4 0 640G 0 part
├─nvme0n1p5 259:5 0 900M 0 part
├─nvme0n1p6 259:6 0 21.5G 0 part
├─nvme0n1p7 259:7 0 1G 0 part
└─nvme0n1p8 259:8 0 29G 0 part
[root@localhost-live liveuser]#

when i setup it to hard disk i made 30G for it

can anyone help with this ?

It can be related to your system ‘BIOS’ setting.

Some UEFI firmware let user to select a UEFI boot entry for a specific OS - this by passing the GRUB2 menu completely.

In my mainboard, I can press F12 during boot up and access the boot menu. Then I can choose Windows or Fedora to boot.

Boot into the UEFI settings, check your boot priority and try access the boot menu to cross check.

1 Like

it is worken now thank you it is f11 to open boot menu
but another problem appear xD I set everything and in terminal when i try to login as root
i cannt
type passowrd

i write su and password appear but when i enter it not typing with me
but when i boot it i can enter it easily

Good to hear that there is progress regarding your issue.

For your setup, are you booting into multi-user.target (text mode) or GUI mode?

When you install Fedora, do you setup a password for the root account? It not, then you cannot do ‘su’ as it need the root password.

One way of doing it is
sudo su

It will prompt for your admin user password.

1 Like

thanks so much it is working now finally i can start my course :blue_heart:

1 Like