Fedora CoreOS auto-update

Hi,

I move from CoreOS to Fedora CoreOS and I would like to know how I can disable auto-update on FCOS, with the previous version it was as simple as:
sudo systemctl disable update-engine.service
but this service is no longer available,

thanks,

Steve

Fedora CoreOS… Do you means Silverblue?

According to:
https://docs.fedoraproject.org/en-US/fedora-silverblue/updates-upgrades-rollbacks/
updates are downloaded by default, but not done by default. And it is said:

this can be changed from the update preferences in Software

No I mean Fedora CoreOS project https://getfedora.org/en/coreos/

The problem with autoupdate is the reboot, I don’t want my VM reboots anytime without my supervision.

Hi @stefhen,
welcome to the Fedora community!

Fedora Core OS is a pretty special and recent thing, which has its own forum platform. If you don’t get the right answer here, I would suggest, asking there:

There is also an IRC channel and a mailing list that you could contact: https://docs.fedoraproject.org/en-US/fedora-coreos/getting-started/#_where_to_report_bugs_and_ask_questions

https://docs.fedoraproject.org/en-US/fedora-coreos/update-streams/ says that

sudo systemctl stop zincati.service

stops the service that performs the automatic updates…

If you don’t want to disable the service altogether, you can find a description on how to simply stop auto-updating here:

thank you so much florian this fixes my problem :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.