"Fedora Flathub Selection" third-party repository can't be easily enabled if you don't enable it initially

Problem

When you install or upgrade to Fedora Workstation 35, if you don’t opt-in to Fedora Third-party repositories initially (during the first boot after the installation, or from an info bar in GNOME Software after an upgrade), you are supposed to be able to opt-in through the GNOME Software repositories dialog later. However, the “Fedora Flathub Selection” third-party repository will not be visible there, so cannot be enabled.

Related Issues

Bugzilla report: #2011274

Workarounds

As a workaround, from the command line, run:

sudo fedora-third-party disable
sudo fedora-third-party enable

This will result in all third-party repositories being created and enabled. You can disable any repositories you don’t want through the GNOME Software repositories dialog.