Fedora freezes after suspend

@paltis additionally to the tests in Fedora freezes after suspend - #7 by py0xc3, can you provoke the freeze if you disable wpa_supplicant with sytemctl stop wpa_supplicant.service before suspending? stop will turn it off within this boot, but it will be automatically started again in the next boot. This will disable your wifi for the time it is stopped. Just to exclude this as potential origin…

Seems like it is a new issue in the kernel newer can anyone confirme is it the case if yes does it already on bugzilla. About this issue.

if i set iommu=pt I can still get a freeze just like when i set intel_iommu=on.
If i set intel_iommu=off I cannot provoke a freeze, however, during operation with a long sleep, it can happen.
Another strange thing when i turn it on laptop in grub strange artifact is running from the top of the screen to the bottom, preventing me from interacting with the menu before it ends, this did not occur in ubuntu 20.04 lts distros from which I switched.
I accumulate, save logs, but for now I switched to kde spin, because it causes itself to be folded in planetary hibernation. and I basically use kde for work.

Can you show a photo/picture of that?

Sounds indeed like a bug so far. My guess is that it is related to ACPI (which is the “backbone” of suspending tasks): iommu (which is also acpi-related) seems to have an influence on the freeze occurrence, but even when turned off, it does not exclude the freeze to occur (so I assume the bug, or whatever, is not iommu itself). We would need the logs to find out more:

wpa_sytemctl stop wpa_sytemctl.service has no changes for me, I didn’t quite understand how to attach the file, so I’ll leave a link to the logs. boot log on hibernation is updated on suspend.
https://github.com/Paltis96/boot_logs.git

@paltis With regards to my guess above, let’s check out the acpi related things.

Install the acpitool (you can remove it when we solved the issue):
sudo dnf install acpitool

Then, check the output of sudo acpitool -w (with a lowercase -w) → this outputs information of the acpi devices with wakeup capability. Let us know the output.

I will compare it to the logs and then we will try to disable some devices’ acpi capabilities to identify the device that causes the error (assuming that this the problem is related to acpi). This will be also done with the acpitool.

okay, i add log on previous link

Here is such a strange artifact in the menu




Indeed strange. I am not a grub expert, but if you don’t have comparable issues in grub, I don’t think it is related.

To me that appears as a scan issue with the grub menu terminal stage. It is only an issue if something similar continues after the boot has completed

1 Like

I also have this issue (about moving underscore on boot menu) in the past when still using F34. At that time the problem gone after recreating grubenv and boot.cfg. Not sure if it will work now.

And also recently with F35, I also have same experience (and I ignore it) but it was gone it self after several update.

If you want to try it:

# backup current grubenv
sudo cp /boot/grub2/grubenv /boot/grub2/grubenv.bak

# recreate grubenv
# there <space> - <space> to auto create to default directory
sudo grub2-edit - create

# recreate grub.conf for efi system
sudo grub2-mkconfig -o /etc/grub2-efi.cfg
1 Like

Your comment made me think that it might be worth checking the bluetooth, when I turn it off in the settings, I can’t provoke freezes, but I still need bluetooth…

The first thing is to find out what the origin of the problem is. Then, we can check if and how we can solve it (this does not necessarily mean deactivate it permanently; the acpitool deactivation of devices is just temporarily and intended to identify the origin). So, if your bluetooth is in the acpi list, try to deactivate it with acpitool as mentioned above and check out if the freeze still appears. If this is the problem, we might find alternatives to make it work in a way not causing freezes (… if the bluetooth proves to be the origin…). If it is not the bluetooth device, activate it again and try out the remaining devices one by one.

I just saw that I have not mentioned above how to use acpitool for that: -w (lowercase w) outputs information including the device numbers, -W (uppercase W) enables/disables devices with the device number, (e.g., sudo acpitool -W 3)

@paltis If I understood you right, you already verified that everything is fine when bluetooth remains off? You have tested this several times? In that case, let us know the output of acpitool -w about the bluetooth controller, and the output of lsusb or lspci , depending on which bus the bluetooth is attached. Also, uname -r

Btw, have you already updated the kernel? You started with 5.15.16-200. Does the problem remain with 5.15.17-200, 5.15.18-200, and 5.16.5-200 ? Especially the latter would be interesting: if it remains in the 5.16 kernel, it maybe makes even sense to file a bug.

Additionally, I assume you use the default GNOME GUI tools to control your bluetooth?

I’m on version 5.16.
Yes, I just decided to check if something changes by turning off the bluetooth in the GNOME GUI.
I’ll watch for some more time, but so far I have not managed to get the laptop to freeze.

You may also check if the kernel 5.16 itself makes a difference. So, also try to use your bluetooth and such as usual, and check out if freezing keeps happening despite the new kernel.

Here if I understand correctly

acpitool
   Device	S-state	  Status   Sysfs node
  ---------------------------------------
  1. PEG0	  S4	*disabled
  2. PEGP	  S4	*disabled
  3. PEG1	  S4	*disabled
  4. PEGP	  S4	*disabled
  5. PEG2	  S4	*disabled
  6. PEGP	  S4	*disabled
  7. ECIR	  S4	*disabled
  8. XHCI	  S3	*enabled   pci:0000:00:14.0
  9. XDCI	  S4	*disabled
  10. HDAS	  S4	*disabled  pci:0000:00:1f.3
  11. RP01	  S4	*disabled
  12. PXSX	  S4	*disabled
  13. RP02	  S4	*disabled
  14. PXSX	  S4	*disabled
  15. RP03	  S4	*disabled
  16. PXSX	  S4	*disabled
  17. RP04	  S4	*disabled
  18. PXSX	  S4	*disabled
  19. RP05	  S4	*disabled
  20. PXSX	  S4	*disabled
  21. PEGA	  S4	*disabled
  22. RP06	  S4	*disabled
  23. PXSX	  S4	*disabled
  24. RP07	  S4	*disabled
  25. PXSX	  S4	*disabled
  26. RP08	  S4	*disabled
  27. PXSX	  S4	*disabled
  28. RP09	  S4	*enabled   pci:0000:00:1d.0
  29. PXSX	  S4	*disabled  pci:0000:2b:00.0
  30. RP10	  S4	*disabled
  31. PXSX	  S4	*disabled
  32. RP11	  S4	*disabled
  33. PXSX	  S4	*disabled
  34. RP12	  S4	*disabled
  35. PXSX	  S4	*disabled
  36. RP13	  S4	*disabled
  37. PXSX	  S4	*disabled
  38. RP14	  S4	*disabled
  39. PXSX	  S4	*disabled
  40. RP15	  S4	*disabled
  41. PXSX	  S4	*disabled
  42. RP16	  S4	*disabled
  43. PXSX	  S4	*disabled
  44. RP17	  S4	*disabled
  45. PXSX	  S4	*disabled
  46. RP18	  S4	*disabled
  47. PXSX	  S4	*disabled
  48. RP19	  S4	*disabled
  49. PXSX	  S4	*disabled
  50. RP20	  S4	*disabled
  51. PXSX	  S4	*disabled
  52. RP21	  S4	*disabled
  53. PXSX	  S4	*disabled
  54. RP22	  S4	*disabled
  55. PXSX	  S4	*disabled
  56. RP23	  S4	*disabled
  57. PXSX	  S4	*disabled
  58. RP24	  S4	*disabled
  59. PXSX	  S4	*disabled
  60. CNVW	  S4	*disabled  pci:0000:00:14.3
  61. TXHC	  S3	*enabled   pci:0000:00:0d.0
  62. TDM0	  S3	*enabled   pci:0000:00:0d.2
  63. TDM1	  S3	*disabled
  64. TRP0	  S3	*enabled   pci:0000:00:07.0
  65. PXSX	  S3	*disabled
  66. TRP1	  S3	*disabled
  67. PXSX	  S3	*disabled
  68. TRP2	  S3	*disabled
  69. PXSX	  S3	*disabled
  70. TRP3	  S3	*disabled
  71. PXSX	  S3	*disabled
  72. AWAC	  S4	*enabled   platform:ACPI000E:00
lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 10a5:9200 FPC FPC Sensor Controller
Bus 003 Device 003: ID 05c8:03ec Cheng Uei Precision Industry Co., Ltd (Foxlink) XiaoMi USB 2.0 Webcam
Bus 003 Device 002: ID 046d:c247 Logitech, Inc. G100S Optical Gaming Mouse
Bus 003 Device 005: ID 8087:0026 Intel Corp. AX201 Bluetooth
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
lspci
00:00.0 Host bridge: Intel Corporation 11th Gen Core Processor Host Bridge/DRAM Registers (rev 01)
00:02.0 VGA compatible controller: Intel Corporation TigerLake-LP GT2 [Iris Xe Graphics] (rev 01)
00:04.0 Signal processing controller: Intel Corporation TigerLake-LP Dynamic Tuning Processor Participant (rev 01)
00:07.0 PCI bridge: Intel Corporation Tiger Lake-LP Thunderbolt 4 PCI Express Root Port #0 (rev 01)
00:08.0 System peripheral: Intel Corporation GNA Scoring Accelerator module (rev 01)
00:0d.0 USB controller: Intel Corporation Tiger Lake-LP Thunderbolt 4 USB Controller (rev 01)
00:0d.2 USB controller: Intel Corporation Tiger Lake-LP Thunderbolt 4 NHI #0 (rev 01)
00:14.0 USB controller: Intel Corporation Tiger Lake-LP USB 3.2 Gen 2x1 xHCI Host Controller (rev 20)
00:14.2 RAM memory: Intel Corporation Tiger Lake-LP Shared SRAM (rev 20)
00:14.3 Network controller: Intel Corporation Wi-Fi 6 AX201 (rev 20)
00:15.0 Serial bus controller: Intel Corporation Tiger Lake-LP Serial IO I2C Controller #0 (rev 20)
00:15.1 Serial bus controller: Intel Corporation Tiger Lake-LP Serial IO I2C Controller #1 (rev 20)
00:16.0 Communication controller: Intel Corporation Tiger Lake-LP Management Engine Interface (rev 20)
00:1d.0 PCI bridge: Intel Corporation Tiger Lake-LP PCI Express Root Port #9 (rev 20)
00:1f.0 ISA bridge: Intel Corporation Tiger Lake-LP LPC Controller (rev 20)
00:1f.3 Multimedia audio controller: Intel Corporation Tiger Lake-LP Smart Sound Technology Audio Controller (rev 20)
00:1f.4 SMBus: Intel Corporation Tiger Lake-LP SMBus Controller (rev 20)
00:1f.5 Serial bus controller: Intel Corporation Tiger Lake-LP SPI Controller (rev 20)
2b:00.0 Non-Volatile memory controller: Yangtze Memory Technologies Co.,Ltd Device 1001 (rev 03)

uname 5.16.7-200.fc35.x86_64

I assume your bluetooth controller was disabled while running acpitool -w? :smiley:
But no problem, we now know your controller:

However, that one should work fine out of the box (at least now). I could only find two reports in Ubuntu with some problems (related to this controller) in 5.15 but solved in 5.16.

I suggest to test if the Bluetooth now (with kernel 5.16) works properly when enabled, without causing freezes or such. If this is not the case, file a bug at the bugzilla.

Contain:

  • clear description of the issue (what happens when and in which conditions, etc.)
  • all kernels you have tested (incl. current uname -r)
  • freeze-related journalctl logs
  • the information related to intel_iommu=igfx_off , iommu=pt , intel_iommu=on , intel_iommu=off (what you described above)
  • the information related to Bluetooth (no freeze possible when disabled, acpitool tests, lsusb output, etc.)

Thanks for your help, I’ll try your advice

After a long observation, it turned out that if you charge the laptop through the second usb-c, this also causes it to freeze after suspension, apparently, is a bluetooth morbidity.