Fedora Media Writer made my USB stick unusable

I used Fedora Media Writer and successfully installed Fedora 32 Workstation on my PC. Now when I try to format my USB drive that I used with Fedora Media Writer it is not possible to find it in Windows “File Expolorer” only in “Disk Management”. I tried to format it in “Disk management” where I can see a MBR partition and another partition. It did not work to format the MBR because the options are greyed out and the other partition is possible to delete but not to create a new NTFS partition. Also, Windows 10 does not find the USB drive when I plug it in the PC, its only findable in the “Disk management” place.

Could you help me to fix my USB drive and maybe fix your Fedora Media Writer program?

Boot into your Fedora32 install, and use Disks (gnome-disks) to delete the existing partition and create a new one.


Greetings @fedorauser2,

I have been there and haven’t used Fedora Media Writer ever since.

I fixed my USB-drive using a tool called Rufus.
Here is the link for the same: https://rufus.ie/

Now, after you install the same (You will need Windows to install the same),

  • Plug in your USB stick, start the program(Rufus).
  • Select the same from Device.
  • From Boot Selection, Select Non-Bootable.

You may read this too: https://github.com/pbatard/rufus/wiki/FAQ#Help_my_USB_drive_is_not_detected

[Moderators of this forum, I am not sure whether I am allowed to mention a third-party tool. Therefore, Apologies if I negated any rule(s) and you may remove my comment but only after @fedorauser2 has read the same.]




I am sure a search (within Ask Fedora) using “rufus” in your query will give you several hits. Its a free world.

Hi and thanks for the reply. This Rufus program worked to fix my USB drive.

Now its up to the Fedora developers to fix their Fedora Media Writer so it is more windows-friendly (so you can format it after use in Windows 10 for example).

Oh, the fact that Rufus helped you with your USB stick does not indict Fedora Media Writer (FMW) in any way. In fact, it serves as evidence that FMW did not damage the stick. If your stick was marked “bootable” by FMW, the tool did its job properly by setting that flag ( gparted, parted, or testdisk in Fedora could revert that for you too).

Without setting the boot flags, your stick will not boot any Operating System (not only Fedora). I hope you can forgive FMW now.

Here is the thing: Explorer in Windows 10 will not reveal a boot-able drive formatted as a UEFI boot device. That is a design decision by the developers of Windows. It doesn’t mean the USB stick is bad. It means that Windows is hiding it from you – Windows protects system files/partitions.


I believe earlier versions of FMW could be used to restore the original partitioning on a USB stick. I have not tried it recently so don’t know if that is still the case.

I have had very good luck as mentioned above with simply using fdisk, gparted, and parted, as well as the fedora disks utility to restore the original partitioning on USB drives.
It is a given that when using dd or FMW that the USB is repartitioned to the size of the iso written to it and is marked bootable. To restore it will require having the partitioning restored by some tool designed for that purpose…

Thank you @twohot for the info about windows and the fact that Explorer will not reveal boot-able UEFI devices. I seldom use windows so had not encountered this issue.

1 Like

FWIW, I have found that you can use FDISK or GDISK to create a new MBR or GPT partition table and Windows will then see it and ask if you would like to format it.

1 Like

Thanks so much! Though my brand new flash drive was dead.