Fedora Rawhide wrong releasever

I switched over to Fedora Rawhide three weeks ago and everything worked fine. Today, I tried to upgrade my system and that was the result (and the update does not work with GPG signature problems)

 Problem 1: package rpmfusion-free-release-31-0.3.noarch requires system-release(31), but none of the providers can be installed
  - package fedora-release-workstation-31-0.9.noarch conflicts with system-release provided by fedora-release-workstation-32-0.1.noarch
  - package fedora-release-workstation-32-0.1.noarch conflicts with system-release provided by fedora-release-workstation-31-0.9.noarch
  - cannot install both fedora-release-workstation-32-0.1.noarch and fedora-release-workstation-31-0.9.noarch
  - cannot install the best update candidate for package rpmfusion-free-release-31-0.2.noarch
  - cannot install the best update candidate for package fedora-release-workstation-31-0.9.noarch
 Problem 2: package fedora-release-workstation-31-0.9.noarch requires fedora-release-common = 31-0.9, but none of the providers can be installed
  - package rpmfusion-nonfree-release-31-0.3.noarch requires system-release(31), but none of the providers can be installed
  - cannot install both fedora-release-common-32-0.1.noarch and fedora-release-common-31-0.9.noarch
  - cannot install the best update candidate for package rpmfusion-nonfree-release-31-0.2.noarch
  - cannot install the best update candidate for package fedora-release-common-31-0.9.noarch
 Problem 3: problem with installed package rpmfusion-nonfree-release-31-0.2.noarch
  - package rpmfusion-nonfree-release-31-0.2.noarch requires system-release(31), but none of the providers can be installed
  - package rpmfusion-nonfree-release-31-0.3.noarch requires system-release(31), but none of the providers can be installed
  - package fedora-release-workstation-31-0.9.noarch requires fedora-release-common = 31-0.9, but none of the providers can be installed
  - package fedora-release-common-31-0.9.noarch requires fedora-repos(31), but none of the providers can be installed
  - cannot install both fedora-repos-32-0.2.noarch and fedora-repos-31-0.2.noarch
  - cannot install the best update candidate for package fedora-repos-31-0.2.noarch
 Problem 4: problem with installed package rpmfusion-free-release-31-0.2.noarch
  - package rpmfusion-free-release-31-0.2.noarch requires system-release(31), but none of the providers can be installed
  - package rpmfusion-free-release-31-0.3.noarch requires system-release(31), but none of the providers can be installed
  - package fedora-release-workstation-31-0.9.noarch requires fedora-release-common = 31-0.9, but none of the providers can be installed
  - package fedora-release-common-31-0.9.noarch requires fedora-repos(31), but none of the providers can be installed
  - package fedora-repos-31-0.2.noarch requires fedora-gpg-keys = 31-0.2, but none of the providers can be installed
  - cannot install both fedora-gpg-keys-32-0.2.noarch and fedora-gpg-keys-31-0.2.noarch
  - cannot install the best update candidate for package fedora-gpg-keys-31-0.2.noarch

The warning, e.g. here for gnome-control-center looks like this:

warning: /var/cache/dnf/rawhide-2d95c80a1fa0a67d/packages/gnome-control-center-3.33.90-1.fc31.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 12c944d0: NOKEY
Fedora - Rawhide - Developmental packages for the next Fedora release                                                                                                              1.6 MB/s | 1.6 kB     00:00    
GPG key at file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-31-x86_64 (0x3C3359C4) is already installed
The GPG keys listed for the "Fedora - Rawhide - Developmental packages for the next Fedora release" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.. Failing package is: gnome-control-center-3.33.90-1.fc31.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-31-x86_64
Public key for gnome-control-center-filesystem-3.33.90-1.fc31.noarch.rpm is not installed. Failing package is: gnome-control-center-filesystem-3.33.90-1.fc31.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-31-x86_64
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: GPG check FAILED

So it looks like, dnf now tries to get it’s packages from f32, which was branched this weekend.
So why does dnf try to get packages from f32? cat /etc/os-release also reports f31:

NAME=Fedora
VERSION="31 (Workstation Edition)"
ID=fedora
VERSION_ID=31
VERSION_CODENAME=""
PLATFORM_ID="platform:f31"
PRETTY_NAME="Fedora 31 (Workstation Edition)"
ANSI_COLOR="0;34"
LOGO=fedora-logo-icon
CPE_NAME="cpe:/o:fedoraproject:fedora:31"
HOME_URL="https://fedoraproject.org/"
DOCUMENTATION_URL="https://docs.fedoraproject.org/en-US/fedora/rawhide/system-administrators-guide/"
SUPPORT_URL="https://fedoraproject.org/wiki/Communicating_and_getting_help"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="Fedora"
REDHAT_BUGZILLA_PRODUCT_VERSION=rawhide
REDHAT_SUPPORT_PRODUCT="Fedora"
REDHAT_SUPPORT_PRODUCT_VERSION=rawhide
PRIVACY_POLICY_URL="https://fedoraproject.org/wiki/Legal:PrivacyPolicy"
VARIANT="Workstation Edition"
VARIANT_ID=workstation

And, how do I fix my updates?

Thank you guys :slight_smile:

We need wait; please read about it in the Email list Fedora

3 Likes

Ah perfect, thank you!

Obligatory note: if you are using rawhide, then you should be keeping up with the QA and devel mailing lists. Rawhide is NOT for daily use and is not supported by the community the way releases are.

https://fedoraproject.org/wiki/Releases/Rawhide?rd=Rawhide

https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/

https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/

1 Like

Sure, but I needed some point where to start and hadn’t have a look at the mailing lists yet. Thank you for the two pointer :slight_smile:

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.