Fedora Silverblue limits where I save or pick up my files

I have being using Silverblue for around a year and my main concern is how to enable my apps to save or get files. For example, with Evolution and Telegram I cannot drop files directly to send, but I can browse to attach them. But the worst issue is getting Evolution to print into pdf. I only get the option to print into my home directory but the printed file is nowhere to be found. I have tried several Evolution installs, either as a user or system wide, but the issue remains the same. Is there any system permission I need to change to get access to these features? Thanks in advance.

1 Like

Are you using the Flatpak versions of Evolution and Telegram?

If you are, then I suspect the issue in due to Flatpak apps are being sandboxed, not due to Silverblue. (Of course, we are encouraged to use Flatpak apps on Silverblue to avoid overlaying packages to the base os.)

2 Likes

Yes, you are absolutely right. I’m using Flatpack apps. I tried installing user-specific as well as system wide versions, with the same results.

1 Like

“Flatseal—Linux Apps on Flathub” Flathub—An app store and build service for Linux

Flatseal can fine tune permissions given to Flatpak apps.

See if it helps.

1 Like

Sampson, you’re right. Thank you so much. It’s ironic since I had Flatseal installed for around a week and paid no attention to it. With Evolution, I switched on the “All user files” permission option and that was it. I left the remaining options untouched. Thanks again.

1 Like