Fedora sluggish, laggy ( High Memory Usage )

I installed Fedora just now, hoping that it would be faster than Windows 10 ( windows 10 wasnt laggy at all ), and I got massive surprise… I deleted my whole windows 10, and now im stuck with a sluggish operating system that I was hoping was smoother than ever, is there a way to fix this? If so, how ( put some instructions what I could do )

Please be patient. I think it was the latest update. I have also experienced sluggishness today.

I would say hang on for the next update and see if the performance improves.

Fedora Workstation is usually snappy!

2 Likes

I installed it 2 days ago, it was very fast and snappy actually, on my legacy hardware it was like i just bought the latest. Tbh today there was some sluggishness but nothing to be noted, it is still fast till now, so it might be a corrupt image installation or a wrong setup.

Also, if this is your first time using linux I wouldn’t recommend deleting windows very soon like this, after all if something goes wrong you can resort to it. After you’ve learned the linux quite a bit I would advice to then proceed to delete windows.

Here is a little thing to do, But I doubt it’ll fix your problem but it might help:

1- Open the terminal.
2- Type : sudo dnf update
3- Enter your password.
4- If your system is up to date, it’ll just state that there’s nothing to upgrade.
5- If it’s not up to date, you will see the packages followed by the size of all of them and then a prompt if you want to install or no, type y and click enter and just do you on the system while it upgrades.
6- After it’s done, Type : reboot in the terminal.
7- If prompted choose the first option in the grub bootloader.
8- Voila you’ve upgraded your linux and the problem maybe solved.

Hope my reply was helpful.

  •    If your computer is old, try to swap Gnome to KDE or some WM (sway is one of the best Wayland WM, btw).
  •    If you’re not planning to compile anything from source or run a server, disable swap (especially on HDD).
  •    If RAM is really scarce, seriously consider to also swap GDM (Desktop Manager, “login screen”) to something other, as it’s fat (not less than a “Gnome mini-session” it is).
1 Like

I think there is an option to boot into xorg when one click the gear on log on, instead of Wayland.

I don’t know if there is a option to boot into a previous kernel, when there is trouble after a kernel update.

There is, if the grub menu is being displayed at system startup. But, Fedora has done stuff in recent releases to hide the grub menu. There is some command to re-enable it, but it’s been a long time since I did it. I’ll do a search and see if I can find it.

1 Like

This is what the Fedora documentation says, but it is not how I did it, so I don’t know whether it actually works:

“With the GRUB_TIMEOUT key set to 0 in the /etc/default/grub file, GRUB 2 does not display the list of bootable kernels when the system starts up. In order to display this list when booting, press and hold any alphanumeric key when the BIOS information is displayed; GRUB 2 will present you with the GRUB menu.”

https://docs.fedoraproject.org/en-US/fedora/rawhide/system-administrators-guide/kernel-module-driver-configuration/Working_with_the_GRUB_2_Boot_Loader/

Ah, here is what I did: Hidden grub menu in Fedora 30

1 Like

Thanks for going to all the trouble. On second thought I think my problem is either Gnome that doesn’t work after a update and restart. I would click a icon of a program and it would not open the program. When I restart it gets stuck for 10 minutes and then I get fed up and force restart it.

It could also have something to do with Wayland, but that’s less likely.

Anyway I don’t think it’s the new kernel that’s at fault.

orikindspirit,

I presume you have an SSD - if you have a rotating hard disk, you should ignore this. But if you have an SSD, the following might explain why things are slower than you expect.

After deleting a large amount of data (like Windows 10) from an SSD, you should TRIM the SSD. Kalev Lember (who’s a Fedora developer) has a very clear video on it here:

In simplistic terms, the SSD and the OS have different ideas of what’s deleted - and TRIM enables them to sync up. You don’t want your SSD to hang on to all the blocks that contained Windows 10 because it’s not aware they’re no longer needed.

Around 5:30 in the video, Kalev tells you how to run it as a one-off:

systemctl start fstrim.service
journalctl -b -u fstrim.service

The journal check will tell you how much space has been trimmed - that’s the amount of space that the SSD was hanging on to unnecessarily.

How useful this will be will depend on exactly how Windows 10 was deleted, but if you have an SSD, you should try it and see.

1 Like

   I’d read that in F32 some trim-service will be enabled by default, but aren’t the modern SSD aren’t need to be trim anymore?

There’s a very good article that explains TRIM here:

To quote the ‘skinny’:

TRIM is never a requirement, but it always helps, and you’re always better off with it than without it.

There’s also more background in the Wikipedia article:

As Kalev mentions in the video, all that’s being done in F32 is scheduling trimming to run automatically (via systemd’s fstrim.timer); it runs once per week. The fstrim service has been in Fedora since F21 (2014). Fedora is playing catch-up here - nearly all other distributions have trim automated already.

2 Likes