Fedora Workstation : Get buttons bigger?

Greetings everyone !

I’m using Fedora Workstation 30 Gnome 3.32.

I recently bought a Huawei Matebook D14, it runs flawlessly :slight_smile: .

Thus, I do have a problem (which is in no way related to the hardware) with the desktop : The screen is a 14" screen FHD (1920x1080).

Consequently, everything is a lot smaller than on usual FHD screens.

I did change the font size in the Tweak tool but how do i increase buttons size in Gnome ?

Thanks in advance

https://wiki.archlinux.org/index.php/HiDPI#GNOME

Maybe it is now simpler than what you can read on such link.
dnf install gnome-tweaks
In the Fonts section there is a Scaling Factor option.
In addition, in such link it is stated that GNOME only allows integer scaling numbers to be set. 1 = 100%, 2 = 200%, etc.: it was true until some previous version. Now you can set also floating numbers.

1 Like

I’m quite sure that it’s for HiDPI scaling, not for font scaling option. I.e. it’s for this setting:

gsettings set org.gnome.desktop.interface scaling-factor 2

And Fonts – Scaling Factor should correspond to:

gsettings set org.gnome.desktop.interface text-scaling-factor 1.5

I’ve been using Font Scaling Factor set to 1,25 for ages (and leaving font sizes to defaults). Also if you enable Large text option in Gnome settings - Accessibility – it actually sets the Font Scaling Factor exactly to 1,25

From my experience, Font Scaling Factor setting forces quite a few (if not all) buttons to become larger when text labels are no more able to be painted inside a button, so to say. On 1,25 buttons’ increase in size isn’t very big. Also for some application it leads to misalignment of buttons, text labels, etc – but again, mainly on larger than 1,25 factors.

Fractional HiDPI scaling – when it works good – should scale all the interface elements proportionally, as far as I understand, and would be a better / more pretty option.

2 Likes

Uh, sorry, then I was confusing these things.

It’s ok, we all humans. You can’t know it all. And now it’s clarified :wink:

1 Like

valenciano! try experimental gnome 3.32 scaling HiDPI
run in terminal :

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

and after that check Settings --Displays should be 100,125,150,175 and 200 % scaling factor .

Greetings everyone !

The following command worked :

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

Thus, I still have a problem… Firefox is full of blur due to the HiDpi scaling factor.

How can I fix this kind of blur ?

Thanks in advance

Altough this is still experimental, you could try to use ‘firefox-wayland’ and see how it goes.

Hi @returntrip !

Yes, indeed, it solved the issue ! Thanks a lot !

But last issue is that when I use “Firefox On Wayland”, if I minimize/maximize, the window is covered by white and black points during 1 second (very quick) and then everything goes back to normal.

Do you think it has to do with either Firefox itself or Wayland ?

I would not know to be honest. Here I see also references to graphical glitches: https://bugzilla.redhat.com/show_bug.cgi?id=1678453