Fedora34: Plasma workspace restart required

I’m continuously asked to reboot to get updates in effect. I can reboot repeatedly and the same message appear.
plasma

Would you like to try from KDE settings to check the status “Restore previous session”. It should be place on KDE settings → Startup and Shutdowns → Desktop Session.

The default should be “Restore previous session”.

You could try by use the default or if it currently selected, you could try with “Start with an empty session” then reboot. Or the otherwise if not currently use the default, try the default one (Restore previous session enable) then reboot.