Firefox 68 crashing constantly on Fedora 30 (NVidia driver and HW acceleration was the culprit)

I just upgraded to Firefox 68 on my Fedora 30, and now it crashes constantly – sometimes when I open a webpage, sometimes when I interact with some extension (eg. BitWarden). I am using the proprietary Nvidia driver, don’t know if it is related. Anyone else experiencing this?

1 Like

Not here, I’m afraid. Can you please create a new profile and see if the crash persists?

https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles?redirectlocale=en-US&redirectslug=profile-manager-create-and-remove-firefox-profiles

1 Like

Thks for the reply. I investigated a little further, and it does seem to be related to the Nvidia driver somehow. I accessed the troubleshooting information page (about:support) and realized that I had forced hardware acceleration in the past to see if it worked (and it did apparently, at least until v67), and the setting was still enabled. Resetting it to the default value apparently fixed the problem.

4 Likes

@ocosta, it could be useful for other users in the future looking for solution for similar problems to mark your post as the solution (and the whole thread would be marked as resolved as well). Also maybe changing the thread’s name to something like

[Solved] Firefox 68 crashing constantly on Fedora 30 (NVidia driver and HW acceleration was the culprit)

– just an example.

1 Like

You’re absolutely right, my bad, thanks for the reminder.

Please don’t change the title.
Mark the appropriate post as the solution of the topic is the way to go.
Thanks.

1 Like

Can you please explain why to me?

My thought in suggesting it was like this: I’m a user (let’s say, several months from now), I have Firefox crashing, I come here to Ask Fedora. I find 10 (20, 30) themes – all named Firefox crashing, I have to open each one and at least look thorough to decide if it can be relevant to my case.

If I see (NVidia driver and HW acceleration was the culprit) in the name, and I absolutely know that I have only Intel video and I haven’t enabled HW acceleration, then I can skip this post and save my time. Looks useful for me.

I would still return to this post if all the other 9 (or 29) posts didn’t apply to my case after all – but initially it can save my time and some frustration on my part )

Improving the title to make the issue clearer is fine, but please do not add [Solved] to it—that’s what @alciregi meant . Discourse puts a nice tick mark next to solved threads, and the solution turns up in the initial thread too.

The basic issue with [Solved] etc in titles is that if it’s done in one or two threads, new users that see them may assume that it is the way things are done—and lose out because it isn’t and not all solved threads will be marked that way (and we don’t want to have to do it either).

3 Likes

Yes. Sorry. I meant to don’t add “[Solved]” in the title, but instead use the tick mark provided by Discourse.
Obviously you are welcome to change the title if it could improve the topic.

2 Likes

@FranciscoD, @alciregi, thanks for explanation/clarification, we are on the same page now :slight_smile:

2 Likes