Firefox (and Chromium) cannot play any videos

I’ve just installed Fedora 36, and Firefox can’t play any videos except for YouTube. Twitch.tv doesn’t work for example. I’ve tried to install all the openh264 and gstreamer1 packages I could find but nothing seems to work.

https://rpmfusion.org

Install the codecs from there

There’s no mention of “codecs” on that site.
The Gnome Store (I’m using Gnome btw) has a “Codecs” category, which lists all the codecs in the RPM repo.
I’ve installed all of those:

The OpenH264 plugin is enabled in Firefox as well:

But Twitch.tv still looks like this:

Codecs are not mentioned on the site, but there are many in the associated repo, particularly the rpmfusion-nonfree repo. Your choice to install them but many may be needed that are NOT available through the fedora repos.

Well as you can see, I’ve installed them all, and it still doesn’t work.
Any suggestions on what to do?

Install ffmpeg and gstreamer stuff from rpmfusion

https://rpmfusion.org/Howto/Multimedia?highlight=(\bCategoryHowto\b)

https://docs.fedoraproject.org/en-US/quick-docs/assembly_installing-plugins-for-playing-movies-and-music/

1 Like

You have installed all from the gnome-software panel, but far from all available and obviously needed.

Do you have any of these installed?

$ dnf list installed ffmpeg* gstreamer* | grep rpmfusion
ffmpeg.x86_64                                 5.0.1-3.fc36                      @rpmfusion-free-updates-testing
ffmpeg-devel.x86_64                           5.0.1-3.fc36                      @rpmfusion-free-updates-testing
ffmpeg-libs.x86_64                            5.0.1-3.fc36                      @rpmfusion-free-updates-testing
ffmpegthumbnailer.x86_64                      2.2.3-0.2.20210902gitd92e191.fc36 @rpmfusion-free                
ffmpegthumbnailer-devel.x86_64                2.2.3-0.2.20210902gitd92e191.fc36 @rpmfusion-free                
ffmpegthumbs.x86_64                           22.04.0-1.fc36                    @rpmfusion-free-updates-testing
gstreamer1-libav.x86_64                       1:1.20.0-1.fc36                   @rpmfusion-free                
gstreamer1-plugins-bad-freeworld.x86_64       1:1.20.0-1.fc36                   @rpmfusion-free                
gstreamer1-plugins-ugly.x86_64                1:1.20.0-1.fc36                   @rpmfusion-free                
1 Like

hi, it works on my Fedora 36. Perhaps the video has a particular encoding, in that case try Google Chrome or chromium-freeworld. Check the fedy repo too for more codecs.
Perhaps post a concrete link of the non working video, if I just go to the page and click a random video in Firefox, it works.