Firefox Top Sites not show up in Private Window mode

Hi all, I have just re-installed Fed.33 after having some problems with Pre-release Fed.34.
Now with the fresh install, Firefox Private Windows shows no “Top Sites” tiles. On the normal Window it functions normally, just in the Private Window if fails to show up.
I have an ubuntu on another PC and there it works fine in the Private Window.
I compared the two firefox “Prefrences” and they look like they are set up pretty identical.
Any Ideas anyone?



You’re in a Private Window

Firefox Developer Edition clears your search and browsing history when you quit the app or close all Private Browsing tabs and windows. While this doesn’t make you anonymous to websites or your internet service provider, it makes it easier to keep what you do online private from anyone else who uses this computer.

It says >…clears your search and browsing history … Top sites are a kind of history too. The Idea of private window is that you can browse without leave traces.

1 Like

Hi ilikelinux
Did you read my post completely? I wrote that I have it on another PC and there it works, Private Windows with Tiles for “Top Sites” It is ubuntu with the same version of Firefox 87.
So how do explain that, please?
I don’t see a way to load a Screen shot here, but I made one.


Apart from the standard firefox in Fedora 33, I have three other firefox installations:

  1. Firefox Beta on Fedora installed from the Mozilla site
  2. Firefox on Windows from the Mozilla site
  3. Firefox Nightly on Windows from the Mozilla site

None of these show top sites in a private window. They all show the standard text

You’re in a Private Window

  Firefox clears your search and browsing history ....etc

Looks to me that Ubuntu is the outlier. Perhaps you should ask on an Ubuntu site how they manage to do it.

Given that the standard Mozilla firefox installations don’t do this, I assume there’s a good reason not to do it.

1 Like

Hi Jonathan,
I sure believe that I had it, Top Sites, on Fed.34 pre-release before I reinstalled Fed.33 again.
I am baffled at this time. Both Firefoxes are 87, why could / should / would one have it and not the other?



Hi Magic

I’ve now also tried the firefox on:

  1. Fedora 34 Beta (iso booted from a USB stick)
  2. Latest Linux Mint (20.1 - booted from an external HD)

Both show the same as all the others in a private window - not a top site anywhere on a private window. You might want to boot a Fedora 34 Beta USB stick yourself to convince yourself that firefox private window there doesn’t work as you remember.

Although Mint uses its own version of firefox (it comes from a Mint repository rather than an Ubuntu one), I’d be surprised if Ubuntu’s version was different regarding this issue.

You should check whether your Ubuntu firefox really shows top sites in a private window - if it does, you’ll need to ask in an Ubuntu forum as we’re obviously not qualified to answer that here.

1 Like

Hi Jonathan, I am sending you two screenshots on the Ubuntu system.

The first is the normal Private Window, then I clicked on a new tab and it shows the Top Site Tiles.

When I do the same thing on the Fed.33 OS, it just gives another Private Window (purple 2 X)

Don’t know why it would be different in Fed.33?



Just compare the settings (about:preferences#privacy) between Ubuntu and Fedora Linux, I’m sure you will find the difference.

In fedora it opens a window while new tabs inherit the status of private window. In Ubuntu it opens just a Private tab while new tabs are just normal browsing windows (no purple background).

1 Like

Hi ilikelinux,

I checked and compared both, they are identical.

Don’t know what else to do.

greetings, Magic

Last tip i have for you, after you better look with Ubuntu:

I also changed the title, as it looks like it is really just a configuration option.

Hi Magic

This is not even an Ubuntu issue - it’s an issue with your particular setup.

I’ve downloaded an Ubuntu image and booted with a USB stick - it shows exactly the same firefox behaviour as all the other firefox private windows.

Looking at your images, the tab shows ‘about:privatebrowsing’ on one of the tabs - and there’s no mauve private browsing icon shown top right. The tab with the top sites shown doesn’t appear to be a private tab at all, hence the top sites appearing.

You’ve obviously changed something to allow private windows to appear as private tabs. Either changed a preference or installed an add-on.

You’ll need to investigate this further yourself. We’ve already gone above and beyond by helping with an Ubuntu firefox issue on a Fedora forum, and now it appears that the issue is specific to your setup.

Thank you for all your TIME ,TROUBLE and EFFORT…



Great response!
Sarcasm for all the assistance you have been given!

1 Like


Problem solved it works now.

You tube video:



No need for sarcasm … just click on the heart of helpful or liked answers.


Glad you got it sorted. Kudos to ilikelinux, who came up with the youtube video with the answer. You should mark his answer as the solution so that other people can find it.

Don’t forget that we are all volunteers here, giving our time, trouble and effort to help others. In the end, ilikelinux found the solution by pointing to a configuration option that you yourself had changed. I’d say that there was even less occasion for sarcasm than normal in this case.

I made it already :stuck_out_tongue_winking_eye:

Sorry JV, but that is your projection.

I wrote it in Caps as a thank you.

Please don’t ASSUME what you don’t know to be facts.



ilikelinux, the same goes for you as for JV.

I wrote: Thank you for all your TIME ,TROUBLE and EFFORT… Regards, Magic

There is no sarcasm in that.

I know full well these are volunteers. Donating their TIME.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

Hi Jonathan, where do all you guys get off on this sarcasm trip?

Did one of you some how get the idea and spread it around?

I was happy to get a solution and expressed it by writing in caps TIME, TROUBLE and EFFORT.