Firewalld configuration --- new F32 installation

hi all,

fairly new to the Fedora world…

setup F32 on my laptop and the wireless zone on firewalld shows basically all ports open:
ports: 1025-65535/udp 1025-65535/tcp

Is this the default behaviour out-of-the-box?

thanks in advance!

2 Likes

You can list default configuration of default zones with firewall-cmd --list-all-zones command. Apparently, FedoraWorkstation zone allows those ports. It assumes that a home network should be fairly trusted. You can change the default zone with --set-default-zone= option. You can manually add/remove services, ports to any zone with --add-service= and --add-port= options. firewall-cmd man page has a comprehensive list of available options.

2 Likes

This is a known issue:

2 Likes

excellent @vgaetera
changed the wireless interface to the public zone … might remove ssh service (although sshd is disabled by default)…
thank you for the links shared, much appreciated

1 Like

Questions has been asked previously:

2 Likes

apologies @florian … I had done a search for ‘firewalld’ before posting, but could not see this thread

I will check whether I can ‘delete’ my ‘duplicate thread’

No need to delete this topic. I just pasted the link in case you want to read the previous discussion.

1 Like