[FIXED] Installed Fedora 36 Gnome and Nvidia Proprietary Drivers, Now Wayland Option is Missing In GDM

How to enable? I’ve read that Nvidia drivers now support wayland to some degree, I want to check if it’s good enough.

I’ve installed the drivers using

sudo dnf install akmod-nvidia -y

and

sudo dnf install xorg-x11-drv-nvidia-cuda

FIXED?: Apparently this is caused by having two monitors, I unplugged my second monitor and logged out. Upon checking GDM, the option to run Gnome on wayland is there.

This fixed the problem about having no option to run wayland but now another problem is not being able to run dual monitors.

EDIT: It wasn’t the dual monitor that caused the problem, it was because my other monitor was using a VGA connection. I asked other people who experienced similar things and he said it was because his monitor was using a VGA connection, I tried plugging only my VGA monitor and sure enough it logged out by itself and the wayland option is gone, it was only after I swapped the VGA monitor with an HDMI one and rebooted that fixed it.

1 Like

Hi @rencedm112 , welcome to the community.

Wayland is available for a subset of Nvidia hardware. Please take a look here for a start:

https://rpmfusion.org/Howto/NVIDIA#Wayland

2 Likes

I checked and my graphics card is listed.

1 Like

Hrm, I’m not sure about the dual monitor thing. You should open a new topic about that, and we can close this one with your “fix”—could you please post it as a new comment and we’ll mark it as the solution?

It wasn’t the dual monitor that caused the problem, it was because my other monitor was using a VGA connection. I asked other people who experienced similar things and he said it was because his monitor was using a VGA connection, I tried plugging only my VGA monitor and sure enough it logged out by itself and the wayland option is gone, it was only after I swapped the VGA monitor with an HDMI one and rebooted that fixed it.

1 Like