Flatpak Eclipse Install new software error

Hi just installed Eclipse 2021-12 from flatpak as I was getting an error when i used installer downloaded from ecplise.org.

Managed to install Eclipse from flatpak, however, when i try to install new software I am getting the below error. Tried running the same with root, still getting the same error. Software i was trying to install was SAP BW modelling tools.

Any help will be appreciated.

image

If this is the Flatpak, I think you’ll have to report this to the folks providing the Flatpak and see what they say. Flatpaks are not built with Fedora packaging guidelines etc. in mind, they have their own build systems and checks. Additionally, Flatpaks are sandboxed by design, which means that they run in their own limited environments (file system etc.), and that sometimes can create issues with installing additional tools that need to use the file system. The Flatpak providers will be able to provide more insight. Best to file an issue.

If this is the Eclipse Flatpak you installed:

then you’ll need to file an issue here:

In that case I will delete this and install the one I downloaded from eclipse website and post the error I get during that installation

1 Like

I did manage to install the eclipse. However, I had to use root user to install new software. Reason is during the installation of SAP tools I had to accept certain certificates, that part I was getting an error. However, with root user I didn’t have that problem.

Any idea why this would happen?

1 Like

Feels like something specific to the SAP tools you’re installing. So probably best to look at their docs/forums. I’ve used Eclipse just fine as a non-root user but I’ve never installed SAP tools.

1 Like