Flatpak Selinux error issues at boot on Fedora 33 Cinnamon

I am getting a couple of long Selinux errors related to Flatpak that I don’t understand. I am still new to Fedora and could use some advice as to if these issues are serious and how to solve them. The messages are quite long so they can be seen here.

My system is a new install and the errors were there from when I installed Flatpak apps. I have updated the system one time and the errors are still there at boot…

Do you have the flatpak-selinux package installed? Use dnf list flatpak-selinux or rpm -qa | grep flatpak to list your installed packages. If not, installing it may resolve your issue.

Thanks for the reply. Yes, I have flatpak-selinux.noarch installed.

Bumpety bump, bump.

Hello, I know you mentioned that it started appearing when you installed Flatpak apps, but can you be a little more specific? You’ve probably forgotten already but if you could tell us after the installation of which app did you notice this it’s going to be more helpful.

Sure, sorry, that is easy to remember. Installed lmms, mellowplayer, musescore and mypaint all in one go. I.e. “flatpak install lmms mellowplayer musescore mypaint”. I have just sat the laptop that this install is on to one side, because the whole SELinux thing freaked me out a bit, so I haven’t done anything with it since…

I installed all those apps without problem. Another thing I’d like to know, do these errors show whenever you turn on the computer (on logon) or when launching the apps? Could you do a flatpak run on each of those installed apps from your terminal to see if any of them show an execution error? Please share here if any.

The errors only occur at boot. However, there were a lot of other errors when I ran the apps. They were too many to include here, so you can find them here.

One thing, which I noticed with Musescore, that I considered borderline suspicious, were the following lines:
Access to XMLHttpRequest at ‘https://mc.yandex.ru/watch/46887714?wmode=7&page-url=https%3A%2F%2Fconnect2.musescore.com%2F%3Fversion%3D3.6.1.&charset=utf-8&browser-info=pv%3A1%3Agdpr%3A14%3Avf%3Adeodhc9w27kzjb%3Afp%3A859%3Afu%3A0%3Aen%3Autf-8%3Ala%3Aen-US%3Av%3A400%3Acn%3A1%3Adp%3A0%3Als%3A1541438729951%3Ahid%3A174567682%3Az%3A120%3Ai%3A20210209214837%3Aet%3A1612900118%3Ac%3A1%3Arn%3A494903636%3Arqn%3A1%3Au%3A16129001181002904665%3Aw%3A185x462%3As%3A1920x1080x24%3Ask%3A1%3Ans%3A1612900115605%3Ads%3A271%2C441%2C72%2C151%2C1%2C0%2C%2C188%2C2%2C%2C%2C%2C992%3Adsn%3A271%2C441%2C72%2C151%2C1%2C0%2C%2C41%2C2%2C%2C%2C%2C992%3Arqnl%3A1%3Ati%3A2%3Ast%3A1612900118%3At%3AMuseScore%20Connect’ from origin ‘https://connect2.musescore.com’ has been blocked by CORS policy: Response to preflight request doesn’t pass access control check: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.
QMutex: destroying locked mutex
QObject::disconnect: No such slot Ms::MyWebView::stopBusy(bool)

A redirect to Yandex? Hmmm.

The redirect to both Google Analytics and to Yandex appear to be connected to the web-based part of the MuseScore start center, which is no longer active if run with the -w switch, as in:
$ flatpak run org.musescore.MuseScore -w
and can be opted out of in the general section of preferences.

I will probably do a reinstall either today or tomorrow, so if there is data that needs to be preserved, give a shout.

System reinstall?

I couldn’t reproduce this problem on my side, even though I have a system which didn’t come with Flatpak by default (Fedora XFCE). I don’t know if flatpak comes with the Cinnamon spin.

I am pretty sure that the flatpak package was installed, but to be able to install anything, run:
$ flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

This problem has been reported to bugzilla. Most of the reports I’ve seen have been assigned to Zdenek Pytela but Zdenek is yet to provide an update.

https://bugzilla.redhat.com/show_bug.cgi?id=1917173