Forbidden base package replacements prevent upgrades

Hi,

I can’t upgrade anymore my Fedora Silverblue:

$ rpm-ostree update
...
Forbidden base package replacements:
  git-core 2.26.0-1.fc32 -> 2.26.2-1.fc32 (updates)
This likely means that some of your layered packages have requirements on newer or older versions of some base packages. Doing `rpm-ostree cleanup -m` and `rpm-ostree upgrade` first may help. For more details, see: https://github.com/projResolving dependencies... done

Same with what is suggested rpm-ostree cleanup -mandrpm-ostree upgrade`. It always ends up with the forbidden base package replacements.

Is that normal ?

https://docs.fedoraproject.org/en-US/fedora-silverblue/troubleshooting/#_forbidden_base_package_replacements:

“In most cases, waiting for a newer OSTree compose will resolve this problem. The dependent package will be updated in the compose and the package that was going to be layered will be successful.”

This has happened to me on several occasions and it has fixed by itself after a wee while.

1 Like

thank you, you were right, it’s now working fine. I was afraid because I didn’t have this issue on my other computers.

1 Like