Force Fedora legacy BIOS installation

Hello,

I have been wanting to switch to Linux for many years, and I finally took the step to download a Fedora 30 KDE live CD iso (actually USB) and give a try installing it. Since this is the computer I use for work, I want to keep a dual-boot system with Windows 7, at least during a transition period. The installation has not been successful though, and after spending all day today trying to figure out what might be the problem I found this video: https://www.youtube.com/watch?v=HoLUI9H_nTM which was very helpful.

So it turns out my the BIOS in my HP laptop is a modern UEFI, but the Windows 7 installation on top of it is made with a legacy BIOS (the hard disk has an MBR partitioning with a 1GB NTFS System partition for the boot).
The Fedora 30 Live USB I have created with the help of the Fedora Media Writer got booted per default in UEFI mode, and the attempt to install Fedora 30 failed. It doesn’t really matter that it failed since just about every post i have read discourages having two OS:es where one is a legacy BIOS and one is UEFI.
I entered my laptops HP BIOS settings, the “Legacy Support Enable and Secure Boot Disable” was already active, and while I could choose to boot other media in either Legacy or UEFI mode, I could only choose the UEFI mode for my Fedora 30 USB.

So my USB boots in UEFI mode, but I would like to install it in legacy BIOS mode. Is there any way to do this? Can I burn the USB in a different way so that it would boot in legacy mode, or can I add a configuration switch somewhere?

Thank you for your help!

I read about the installation boot menu options, and I discovered the command run by the installer when clicking ‘Test this media and & start Fedora-KDE-Live 30’ is:
linuxefi /images/pxeboot/vmlinuz root=live:CDLABEL=Fedora-KDE-Live-30-1-2 rd.live.image rd.live.check
initrdefi /images/pxeboot/initrd.img

is there a way to change this command to make it run the legacy mode? i tried changing linuxefi to linux and initrdefi to initrd and run Ctrl-x, and the system did start, but I get the same errors as before with anaconda still trying to install and EFI system.

Hi @jonosphere

In the bios into the security options you should can choise between normally into 2 options /3 options:

1-UEFI
2-LEGACY+UEFI
3-LEGACY

In my bios at least i can choise the option 1 or 2. If i select the option 1 i am only disponible to install in UEFI mode so that when I place the usb only can see UEFI:USB install. If I choise the option 2 I will can choise into 2 options when I place the USB:

USB fedora (Install run in mode BIOS/Legacy)
UEFI:USB fedora (Install in mode UEFI)

I think you do need check your configuration into the BIOS. The only thing what is strange to me about it that you did comment is what if you can run only UEFI How is windows 7 loading in mode BIOS, it is what is chocking me.

Regards.

Hi @xtym , thank you for your reply!

Yes, I went to my HP BIOS manual and I double checked that the settings are enabled to be able to run both. As my boot loader is a bit fucked up atm, I need to get to the BIOS boot menu to start the system anyways, and the options I can choose there are (the comments in parenthesis are mine) :

  • UEFI USB (Fedora-KDE-Live 30)
  • UEFI HDD0 (the failed Fedora 30 installation)
  • Legacy HDD0 (my windows installation that boots correctly)
  • Legacy Network card

when I also insert another USB where I moved my HP_RECOVERY partition of Windows 7, I also get the option of

  • Legacy USB Kingston (HP_RECOVERY)

so the Fedora USB only shows up as UEFI, although the installer documentation claims it can be booted as both …

One thing, Can you see if you have more options if you move in the emergent menu trought arrows keys??.

Check this
https://docs.fedoraproject.org/en-US/quick-docs/creating-and-using-a-live-installation-image/

Important point in the link above : Booting from USB sticks

In this link you can see about native BIOS or UEFI

https://fedoraproject.org/wiki/Unified_Extensible_Firmware_Interface

:link: UEFI-native and BIOS-native installations

It is important to realize that most systems with UEFI firmware also implement a BIOS compatibility mode , also sometimes referred to as a CSM . This means they can boot in a way that imitates a BIOS firmware, executing bootloader code from a disk’s MBR and looking to the operating system just like a BIOS firmware.

There is no standard for how this choice (and other boot configuration choices, as we’ll see later) should be shown to the user in the firmware UI, so we cannot tell you precisely how your firmware shows you this choice, if your firmware has this feature. Some just have a sort of ‘toggle switch’ for flipping between ‘BIOS mode’ and ‘UEFI mode’. Some will let you explicitly choose to boot a given disk in ‘BIOS mode’ from the firmware interface. Some will let you configure the boot “disk” order to include both BIOS-native and UEFI-native boots of different disks or installed operating systems.

If you boot a system with UEFI firmware in this BIOS compatibility mode , once the system is booted, it will act to all intents and purposes exactly like a BIOS system.

An installed operating system will usually only be configured to be bootable in either BIOS-native mode or UEFI-native mode. We can refer to these as ‘BIOS-native installations’ and ‘UEFI-native installations’.

  • If you boot a Fedora live or install medium in UEFI-native mode and then install Fedora, it will perform a UEFI-native installation.
  • If you boot a Fedora live or install medium in BIOS-native mode and then install Fedora, it will perform a BIOS-native installation.

If you read about it: the bios/UEFI installation should come from your UI firmware.


Check there are not more options trough arrows keys in the emergent menu, try fix in the bios boot ordet in Legacy /bios mode from the usb in first place.

Regards.

2 Likes

One thing more if for some reason your BIOS don’t leave you choise like you did comment before you can try burn the USB with RUFUS in windows and select by default MBR mode when you select the image to burn.

Here are a video.

It should do BIOS mode by default while burning in case your BIOS is not giving you the chance.

Regards.

2 Likes

Yes!!!
Thank you so much. The USB that RUFUS burned finally was able to be loaded in legacy BIOS mode and after that it was a 10 minute smooth ride to a successfull installation. Now I have a fully functional dual boot.

Thank you so much for taking the time to help @xtym =)

3 Likes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.