Fractional Scaling GNOME on X.Org. How I can enable it?

Hi. Fractional scaling works fine on Wayland have option on settings 125% 150%, it was enabled command like gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']", but how I can enable it on Xorg session? Menu doesnt’s have any fractional scaling option, only 100 and 200%.

Could you please tell us where you found that command to use?

After first installation of Fedora 31 or 32, I find it in google. For example Reddit After execution in gnome settings i can use new options of fractional scaling 125 150 175%. Then I simply was make update to next releases.

gsettings reset org.gnome.mutter experimental-features turn off fractional scaling in wayland

and next enable it:

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']

I was rechecked it now. It works.

1 Like

Do you mean that it works on Wayland, or that it also works on X and so this topic is solved?

PS: Reddit, like blogs etc. aren’t authoritative sources of information. It’ll be much better if we could find some mention of this in the Gnome documentation.

It works on Wayland, but not work on Xorg.

Mmm… other link && link maybe more official. I know that is experimental feature.

1 Like

You can try:

gsettings set org.gnome.mutter experimental-features "['x11-randr-fractional-scaling']"

I don’t know if that still works.

It can also be done with xrandr, reference here

Thanks

4 Likes

Thank u for answer, but unfortunately it not working for me - fraction scaling still unavailable on Xorg session. No need for this for now. Wayland works fine on Fedora and it’s pretty nice.