[fresh install] Audio issues after updating; Timeshift question

Ah thx! Did not recognise this. I ran the command again and now the output is in correct format. I edited my posting.

Edit: Seems like this has to do because I had inxi not installed and used the option to automatically install it and run the command afterwards.

$ inxi -Fzx
bash: inxi: command not found...
Install package 'inxi' to provide command 'inxi'? [N/y] y

which then resulted in

...
* Testing changes... 
 * Installing packages... 
12System:
  12Kernel 5.14.10-300.fc35.x86_64 x86_64 12bits 64 12compiler gcc 12v 2.37-10.fc35 12Desktop GNOME 41.0
    12Distro Fedora release 35 (Thirty Five)
...

afterwards.

So. Timeshift installed. Snapshot created and updated the system. Back to main topic.

systemctl --user status wireplumber.service now gives:

● wireplumber.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; enabled; vendor preset: enabled)
     Active: active (running) since Wed 2022-03-23 23:34:44 CET; 3min 27s ago
   Main PID: 2277 (wireplumber)
      Tasks: 4 (limit: 38349)
     Memory: 7.8M
        CPU: 467ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/wireplumber.service
             └─2277 /usr/bin/wireplumber

Mär 23 23:34:44 fedora systemd[1892]: Started Multimedia Service Session Manager.
Mär 23 23:34:44 fedora wireplumber[2277]: Failed to set scheduler settings: Die Operation ist nicht erlaubt
Mär 23 23:34:45 fedora wireplumber[2277]: <WpNode:0x559890c0af60> Object activation aborted: PipeWire proxy destroyed

And inxi -Fzx seems to give exact same output as pre update. At least in the audio section.

Going into system settings and trying different audio outputs seems to do not have any impact at all as none of my outputs gets sound as far as I can tell. In previous installation I had sound from the terminal app coming out of one output at least. Now I think there is another device selected from which I do not get output due to not having audio hardware installed on all devices.

EDIT:
After looking up on the net, it seems to me there might be an issue with wireplumber

If I knew how to check, which packages where updated from which to which version I would try to manually downgrade some of them. But I can not find any log/protocol of what the software gui did and sudo dnf history shows only the stuff I did manually.

please link the article direct and not thru Quant. Brazil and other countries are without that service.

If you have sound then it shoud be running no need to check😀

This is just to check your system config and kernel and some other stuff it should be same maybe the kernel v changed.

No. I updated the system and after that was my last posting because atm the problem exists as described under systemctl output.

I found several similar issues but looking closer they seem to have different errors though related to Fedor update.

This one seems to be very similar (regards error output) though and also very recent, too:

Is this the wrong place to ask?

About what…?!
We try to solve issue you can also try to solve others issues.

About that sound issue. Because for me it looks like the problem seems to be related to pipewire/wireplumber?! And therefore I ask if this here is the right place to ask or if I should ask somewhere else for example on the mentioned packages support platforms.

I do not understand what you mean.
For me it looked like you understood, that my problem is solved which is not. So no need to feel offended or similar (sorry if that term is not the best - I´m no native english speaking person)

Addition:
I just seen a YT video yesterday where someone else has had sound issues on Fedora 35 but also on Garuda which uses pipewire, too. So that enforces my question if this the right place to ask for.

Update:
I installed “EasyEffects” with gnome-software and it has a test signal built in. If I overwrite the used output device it does work!

Atm the default audio output the system uses can not be changed by gnome-settings. Changing output device does not work. Closing gnome-settings and re-opening it proves this. Setting does not get applied.

Sure it is for everything releted to fedora centos and rhel base systems.
You can ask

It means it is a community where we help each other like if you know something you can help others and others all help you for your issues.

I downgraded wireplumber and this solves my issue.

EDIT:
And additionally I locked updates to it with dnf version lock:
https://docs.fedoraproject.org/en-US/quick-docs/dnf/

About timeshift not showing any disk: It was an issue in the previous version of timeshift but now it is fixed (the package got updated). You may try installing it.

1 Like

That´s right. I solved this issue already. Thx =)

Yeah… just upgraded to Fedora 36. Prior to this I had to upgrade wireplumber to 0.4.10. No sound after that still like with 0.4.9.

So I thought maybe F36 with wp 0.4.10 will work. At first it was a hassle really to get the upgrade even installed (different topic) but after that: nope - audio does not work. Downgrade to wp 0.4.4 not available with dnf.

Thought I´d reboot into F35. Selected it in Grub. Still booted in F36. Great.
No Timeshift has to do its work. Hopefully that will work. Staying on F35 I guess.

EDIT:
Timeshift restore finished. F35 back on track. Can not login anymore.
Guess I´m done with Linux. Sad.

I encountered this timeshift login issue upon restore, this problem must be reported to timeshift devs.

Would you like to share a solution if you found one? I need some data I forgot sadly.

I no longer have the issue since I reinstalled my system and now using btrfs snapshots with snapper

I don´t know why but I kinda missed using Fedora after a couple of days and I digged into it again and found a solution:

(.autorelabel selinux)

The same can be accomplished with sudo touch /.autorelabel followed by a reboot. Does not require booting to live media.