Front Panel Headphone Jack is Not Being Detected

Ok. Recently I was having a problem where my system wouldn’t detect when I connect a headphone into my front panel headphone jack. I was able to fix this by creating a /etc/modprobe.d/alsa-base.conf file and adding options snd-hda-intel model=,no-front-hp to it, which would disable headset autodetection and would make the system always treat the front panel as if it had a headphone connected.

The problem is that I had to reinstall my system, and now when I do the same steps it doesn’t work anymore. I think it might be another related audio config that I should have had in my previous installation that I don’t have anymore, but I don’t know what it is.

###SOME INFORMATION###

cat /proc/asound/card*/codec* | grep Codec
Codec: ATI R6xx HDMI
Codec: Realtek ALC897

alsa-info.sh
https://alsa-project.org/db/?f=e503ef8300c88df2da0e5264e01f534f66ae17a6

Ok. I was able to fix this.

1 - install alsa-tools: $ sudo dnf install alsa-tools;
2 - open HDA Jack Retask: $ hdajackretask;
3 - at the top, verify if the right codec is selected in “Select a codec”. On my case, the right one is “Realtek ALC897”;
4 - on “options”, at the right, click on “Set model=auto” and “advanced override”;
5 - on “pin configuration”, find Green Headphone, front side; pin ID: 0x1b;
6 - click “override” and, on “connectivity” set to “headphone”, on “Location” set to “front”, on “device” set to “Headphone”, on “Jack” I set it to “3.5 mm”, on “jack detection” set to “Not present”;
7 - click “Apply now”, if you get a message saying that the device is busy, click “install boot override” and then reboot.

1 Like