Fstab entries get ignored

Here is my fstab

# /etc/fstab
# Created by anaconda on Sun May 22 20:22:18 2022
#
# Accessible filesystems, by reference, are maintained under '/dev/disk/'.
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info.
#
# After editing this file, run 'systemctl daemon-reload' to update systemd
# units generated from this file.
#
UUID=d0cdf429-d6c0-4a56-82f5-43cbfe3b41fc   /                  btrfs   defaults                               0 0 
UUID=d0cdf429-d6c0-4a56-82f5-43cbfe3b41fc   /.snapshots        btrfs   subvol=snapshots,compress=zstd:1       0 0 
UUID=654bbf2d-cad4-41bf-ab91-f07161a50f2d   /boot              ext4    defaults                               1 2 
UUID=3173-D60E                              /boot/efi          vfat    umask=0077,shortname=winnt             0 2 
UUID=d0cdf429-d6c0-4a56-82f5-43cbfe3b41fc   /home              btrfs   subvol=home,compress=zstd:1            0 0 
UUID=d0cdf429-d6c0-4a56-82f5-43cbfe3b41fc   /opt               btrfs   subvol=opt,compress=zstd:1             0 0 
UUID=d0cdf429-d6c0-4a56-82f5-43cbfe3b41fc   /tmp               btrfs   subvol=tmp,compress=zstd:1             0 0 
UUID=d0cdf429-d6c0-4a56-82f5-43cbfe3b41fc   /usr/local         btrfs   subvol=usr-local,compress=zstd:1       0 0 
UUID=d0cdf429-d6c0-4a56-82f5-43cbfe3b41fc   /var               btrfs   subvol=var,compress=zstd:1             0 0 
###CUSTOM ENTRIES###
LABEL=Games                                 /home/nox/.Games   btrfs   rw,nosuid,nodev,exec,compress=zstd:1   0 0 
LABEL=EXT001                                /mnt/EXT001         ext4    users                                  0 0 
LABEL=the_vault                             /mnt/vault         ntfs    noauto,users                           0 0 
LABEL=NIX_GAMES                             /mnt/nix_games     ext4    noauto,users                           0 0 
LABEL=windows                               /mnt/windows       ntfs    noauto,users                           0 0 
LABEL=EXT010                                /mnt/EXT010        ntfs    noauto,users                           0 0 
LABEL=resQ                                  /mnt/resq          ext4    noauto,users                           0 0 

The permissions/ownership of the mounting folders also seem ok

ls -l /mnt/                                                                                                                                                       
total 4
drwxr-xr-x. 13 nox nox 4096 May 25 16:51 EXT001/
drwxr-xr-x.  1 nox nox    0 May 25 17:40 EXT010/
drwxr-xr-x.  1 nox nox    0 May 25 17:40 nix_games/
drwxr-xr-x.  1 nox nox    0 May 25 17:40 resq/
drwxr-xr-x.  1 nox nox    0 May 25 17:40 vault/
drwxr-xr-x.  1 nox nox    0 May 25 17:40 windows/

I want users to be able to mount (and unmount) all labeled partitions, and that the last 5 don’t get mounted automatically.

What happens is that all ext4/btrfs partitions get mounted and all ntfs partitions don’t. I cannot mount the ntfs partitions as user.

What’s the problem here ?

I did apply my changes with sudo systemctl daemon-reload (and rebooting) but to no avail.

Concerning the NTFS issue, the problem is that you write ntfs in the fstab. You need to use ntfs-3g if you want to use the “traditional” fuse-based NTFS.

However, the kernel already supports ntfs natively, which is much faster and more efficient. If you want to use the native ntfs, you would need to use ntfs3 in the fstab. Some more information about nrfs-3g and ntfs3 in relation to each other are available on your preferred search engine or here:

There used to be some issues when mounting the newer ntfs3 with GUIs (I don’t know if these issues have been solved). If you experience such issues with ntfs3, stick with ntfs-3g: it was sufficient for a long time and it is well embedded into GUIs, etc.

If you use ntfs-3g and it still does not work, ensure that the package ntfs-3g.x86_64 (or whatever architecture you use) is installed. However, I expect it is installed by default.

1 Like

Thank you for the reply.
The problem is partly solved after adding ‘-3g’ after ntfs (the partitions don’t try to get automatically mounted) but I still cannot mount the partitions as an user.
Edit:Removed because not reproduced in the last 2 reboots
This error pops up when I click on the desired partition.

An error occurred while accessing ‘Home’, the system responded: The requested operation has failed: Error mounting system-managed device /dev/sdd1: Unknown error when mounting /mnt/EXT010

This is what the problematic entries look like

LABEL=EXT001                                /mnt/EXT001       ext4   defaults,users  0 0 
LABEL=NIX_GAMES                             /mnt/nix_games    ext4   defaults,users,noauto 0 0 
LABEL=resQ                                  /mnt/resq         ext4   defaults,users,noauto 0 0 
LABEL=the_vault                             /mnt/vault        ntfs-3g defaults,noauto,users 0 0 
LABEL=windows                               /mnt/windows      ntfs-3g defaults,noauto,users 0 0 
LABEL=EXT010                                /mnt/EXT010       ntfs-3g defaults,noauto,users 0 0 

Furthermore, my “noauto” arguments get completely ignored on the ext4 partitions.

After a fresh reboot:
Screenshot_20220525_195457

Do you have problems with all these partitions (including the ext4) or only with the ntfs partitions? This is not yet clear for me.

Maybe you can re-try and repeat the error, and immediately after that check sudo journalctl --since "2 minute ago" and show the output.

It might be noted that you have not yet added the users parameter to the ntfs partitions; only the ext4 partitions have it at the moment.

I assume sudo dnf install ntfs-3g outputs that ntfs-3g is already installed?

I could imagine that the automount of the ext4 is done by the GUI when the user has logged in the GUI. You can check out by logging in only into the console and not the GUI, and see if these partitions are still automounted. If the GUI proves to be the “automounter”, you have to check the GUI configuration of the user, and deactivate automounts of the GUI (this is not the fstab).

1 Like
  • ext4 partitions : (defaults,noauto,users): get mounted automatically despite having the mount option “noauto”. Users can unmount and remount them.

  • ntfs partitions (ntfs-3g in fstab) (defaults,noauto,users): noauto: works; users: doesn’t work, throws the following error when clicking them using dolphin. I can mount them manually using sudo.


    auto (defaults,users): the partition gets mounted automatically, it can get unmounted by the user (without asking for the password) but the same error is thrown when trying to remount it.

I hope that makes it clear.

sudo journalctl --since "2 minute ago on pastebin

Oops, that is a miss-paste, I have corrected it (after making sure that is my current configuration & rebooting.)

Yes I have made sure of that before using it.
Using ntfs3 in fstab throws this error (and it gets highlighted in fstab):

An error occurred while accessing ‘Home’, the system responded: The requested operation has failed: Error mounting system-managed device /dev/sda1: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error

I have logged in via cli after a reboot and indeed, the ext4 partitions weren’t mounted. Thanks, you’re awesome ! You put words on what went trough my head. “mumbles something that is not fstab has to mount these darn partitions… but what… no, no, that’s improbable”

The solution below solved the ext4 partitions being mounted automatically despite having the noauto option in fstab.

The Auto-mounting of disks in Debian-based Linux distros (and perhaps others) comes from a service called udisks2.

Disabling this service will prevent any disk from automatically being mounted, while still allowing manual mounting.

Disable the service - No automatic or manual starts

systemctl mask udisks2

[…] full post here

Ok. So, ext4 issue is now solved and works properly as intended.

After adding the users parameter to the ntfs-3g partitions, you did reboot, and the issue with users being unable to mount ntfs remains? If so, can you show the current ntrfs-3g entries of the fstab? I’ll have a look on the logs in the meantime.

I expect you tried this within a GUI? The issue is that ntfs3 remains not fully implemented throughout the GUIs as it is very new. So, in this case, stick with ntfs-3g instead of ntfs3.

1 Like

That’s the ntfs problem as logged in the journalctl:

May 25 21:16:05 fedora udisksd[2846]: Error opening read-only '/dev/sdb4'
May 25 21:16:05 fedora udisksd[2841]: Error opening read-only '/dev/sda1'
May 25 21:16:05 fedora udisksd[2844]: Error opening read-only '/dev/sdd1'
May 25 21:16:05 fedora udisksd[2846]: : Permission denied
May 25 21:16:05 fedora udisksd[2841]: : Permission denied
May 25 21:16:05 fedora udisksd[2846]: Failed to mount '/dev/sdb4'
May 25 21:16:05 fedora udisksd[2841]: Failed to mount '/dev/sda1'
May 25 21:16:05 fedora udisksd[2846]: : Permission denied
May 25 21:16:05 fedora udisksd[2846]: Please check '/dev/sdb4' and the ntfs-3g binary permissions,
May 25 21:16:05 fedora udisksd[2846]: and the mounting user ID. More explanation is provided at
May 25 21:16:05 fedora udisksd[2846]: http://tuxera.com/community/ntfs-3g-faq/#unprivileged
May 25 21:16:05 fedora udisksd[2841]: : Permission denied
May 25 21:16:05 fedora udisksd[2841]: Please check '/dev/sda1' and the ntfs-3g binary permissions,
May 25 21:16:05 fedora udisksd[2841]: and the mounting user ID. More explanation is provided at
May 25 21:16:05 fedora udisksd[2841]: http://tuxera.com/community/ntfs-3g-faq/#unprivileged
May 25 21:16:05 fedora udisksd[2844]: : Permission denied
May 25 21:16:05 fedora udisksd[2844]: Failed to mount '/dev/sdd1': Permission denied
May 25 21:16:05 fedora udisksd[2844]: Please check '/dev/sdd1' and the ntfs-3g binary permissions,
May 25 21:16:05 fedora udisksd[2844]: and the mounting user ID. More explanation is provided at
May 25 21:16:05 fedora udisksd[2844]: http://tuxera.com/community/ntfs-3g-faq/#unprivileged
1 Like

Yes, I’ll dig trough some udisk params in order to disable the automount (instead of nuking the whole service).

Yep. Sometimes the error says the permission isn’t set correctly, sometimes it’s the “unknown error” message.
I have tried setting gid=1000 and uid=1000 as cited in this post but then the error message reverted back to “unknown”.

Here are the ntfs-3g fstab entries: (note that vault missing the noauto option is intentional)

LABEL=the_vault /mnt/vault ntfs-3g defaults,users 0 0
LABEL=windows /mnt/windows ntfs-3g defaults,noauto,users 0 0
LABEL=EXT010 /mnt/EXT010 ntfs-3g defaults,noauto,users 0 0

Yep. alright, i’ll stick with ntfs-3g.

I saw this error sometimes in the GUI too, so I changed a line in the fstab to look like this:

LABEL=EXT010 /mnt/EXT010 ntfs-3g defaults,noauto,users,gid=1000,uid=1000 0 0

But it didn’t help, do I have to set umask etc too or is that optional ?

Maybe this can help you:

I expect it is the same problem given the error messages and descriptions, and it makes sense in these circumstances.

1 Like

I think my answer lies within Arch wiki’s page about NTFS-3G

By default, ntfs-3g requires root rights to mount the filesystem if it is a block device, even with the user option in /etc/fstab . See ntfs-3g-faq for details. The user option in the fstab is still required.

I’ll update my post once I have found the correct way.

Thank you so much for your assistance !

(it’s weird, I don’t remember going trough all this on my previous installations…)

1 Like

Happy to help. If you finally solved the issue with something in this thread, feel free to mark the “solving post” as solution, in case other people experience the same problem.

1 Like

I’m happy to announce that Linux partitions getting mounted with the “noauto” mount option in /etc/fstab is hereby solved

This post mentionned that udisks2 automount partitions.
The writers provided answers about disabling the udisks2 service or updating the rules.
None of the two options was satisfactory because udisks2 does automount partitions, but it also displays the available removable devices. Disabling udisks2 also hides those entries and I don’t want to manually mount every removable device.

The solution is far more simple. Go to your GUI settings, search for auto mount and… the settings will pop up.
In my case I simply wrote “auto mount” in kde-plasma’s quick search and came across the configuration of removable devices.

As you can see the said devices are greyed out. All you have to do is untick the two top options and you will be able to choose which partition to auto-mount (or not).

Now the mounted devices match what’s specified in my fstab.
Screenshot_20220529_191605

About mounting ntfs partitions without admin privileges
This issue remains unsolved. After reading trough arch wiki’s page about ntfs-3g I was redirected to the ntfs-3g FAQ but I could not make it work.

You can follow my new thread here